Jump to content
EwinRacing Flash Series Gaming Chairs
Mivas

Intel Core i7 8th gen with windows 7 (Intel UHD Graphics 620 Driver - DELL Inspiron 5770)

Recommended Posts

Hi! I registered for the specific topic. So, the big question for which I found no answer in internet.

 

Windows 7 on Intel Core 8th generation.

 

Officially, Intel supports windows 7 up to 6th generation. Unofficially, with an easy trick up to 7th generation. The question is, how can we make it work on 8th generation?

 

I installed windows 7 Ultimate 64bit on my new DELL Inspiron 5770 high end non-gaming 17 inch laptop, without any issue apart from the integrated GPU (Intel UHD Graphics 620). This also blocks the functionality of the AMD Graphics card too.

 

So, since for many reasons I want to have windows 7 instead of windows 10 or Linux, I did my best but I got stuck. I created a hybrid driver from 2 different versions of official Intel drivers, the latest, which supports this iGPU, but only on Windows 10 and the last windows 7 compatible, which does not include support for the specific 8th gen processor/graphics card, since it is newer. I mixed some files and also edited the inf file from the old driver.

 

I will share with you what I did, so that someone who has knowledge might get 100% functionality. I get only partial.

 

So, here is my guide.

 

1. Download the last Win7 compatible driver from Intel for HD Graphics. It is the version win64_15.45.19.4678
2. Download a newer version which is win10 only but contains the driver for your processor. In my case, Intel Core i7 8550U with DEV_5917. I downloaded the latest driver.
3. Make copies/backup of both folders and save elsewhere before starting editing.
4. Unzip both. From the unzipped ones, go to the new driver folder, then Graphics, then copy all components and paste in the Graphics folder of the old (15.45.19.4678) version. Note; So far in my case I didn't play a role if I replaced the same names of the old files with the new ones or skipped them to keep the old ones. Exception; do NOT replace the igdlh64.inf file and the igdumdim32.dll
5. Find the DEV number of the processor. Device Manager (from Control panel or search), right click on generic VGA Adapter, properties, details, ID.
6. Open the igdlh64 file (with a notepad) from the new version (Graphics folder) find the DEV number under windows 10 and copy the whole line.
7. Paste it under the Windows 7 section in the igdlh64 file of the old driver and correct the ikbl win10 with iskl win7 (known trick for 7th gen).
8. Copy all lines that include the 4-digit number from the igdlh64 file from the new driver and paste in the respective sections of the igdlh64 of old driver. In the end of the text, also add the name of the driver as a label, eg Intel UHD Graphics 620.
9. Install the modified old driver (win64_15.45.19.4678) and reboot.
10. After reboot. Copy the igdumdim32.dll file from the Graphics folder of the new version and paste it to the C:\Windows\SysWOW64 replace the existing files

 

This way, I get all resolutions, full brightness, colour, contrast etc control of the display, intel graphics control panel, full windows 7 effects (aero glass etc), but I dont actually get video support (apart from 3rd party software, like VLC/GOM player which even play 4K video smoothly), 3d applications are not functional, I dont get hardware acceleration etc. I concluded that the solution is to edit the igdumdim32.dll file, so that I copy elements from the new version to the old one. This way, theoretically, it should work. Anyone who has experience with driver and dll modification???

 

Share this post


Link to post
Share on other sites
On 24/10/2018 at 8:58 PM, Mengqin said:

 

A HUGE THANK YOU!!! Great job bro!

 

I knew the issue was these two dll files,  but I didn't have the knowledge to dig inside them and find what to edit in them. I edited these two bytes as you said and everything works flawlessly with windows 7! In my case, I have an AMD Radeon graphics card which continued to work even after installation of the Intel modified driver, but a reinstallation is always the best way to go.

 

Thank you again a lot for sharing your knowledge and the final 100% working solution!!! Now I can finally use windows 7 on my new laptop just as I used to in older systems in the past. Everything works perfectly now!!!

 

To all other guys, I confirm that this solution works for other systems as well (like mine that I have different components). Thumps up!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Lisa Scott
      Sometimes, our Computer becomes very slow and gives tough time to make work on it. This makes slow because of hard drive holding the plenty of data, files. So, to make faster speed clear the some space.
      Some background applications or programs running make computer slow.
      Remove or disable any TSRs and startup programs that automatically start each time the computer boots. 
      Scan for Malware and Adware, if your system infected by them.
      Uninstall Programs You Don’t Use
       
    • By qamar198
      Hello Everyone,

      I am trying my Sager NP 9377 to get to work but to no avail. NO POST, NO DISPLAY.
      in short>> powering on laptop causes fans to run at full speed after 10(cpu only) + 10 (now both cpu+gpu) with Caps Lock + Num Lock + Scroll Lock LEDs blinking, continuous 1 second beep, repeats for one minute with 1 second in between, then laptop shuts down.

      IN DETAIL
      System Specs are i7 4810mq 8gb gtx 880m SLI variant (though my laptop has other GPU Slot empty so only singular 880m running) 120 Hz display.

      The Problem
      > if i take out the battery and plug in AC only, the power light comes on ORANGE
      if both battery is connected, then i have both power and battery light ORANGE
      and if only battery is connected then of course laptop is waiting for me to press the power button
      but in all 3 cases the following happens
      > Pressing the power button brings laptop to some signs of life, power LED turns green, both the CPU and GPU fans have a very quick jerk but does not spin., keyboard lights up with Blue Backlight (dont know if this is relevant or not), HDD activity light starts to blink showing HDD access maybe (even when hdd is removed)
      > Display remains blank (i dont even sense the display backlight being on)
      > HDD activity light sometimes goes off after only 1-2 seconds, sometimes shows rapid blinking/activity for 4-5 seconds
      > both fans remain off (i removed back cover to check this)
      > after about 10 seconds or so, the CPU fan spins up (speed is normal, just like when using the laptop in IDLE)
      > after 10 more seconds have passed, the CPU fan seems to be turning off for a split second then both the CPU and GPU fan turn on full speed with a lot of noise.
      > Caps Lock, Num Lock and Scroll Lock LEDs all blink together with single beep for about 1 second, repeats beep with 1 second in between.
      > goes on for about 1 minute then laptop shuts down.
      > forcing the fans to spin down using FN+1 key makes them spin back up to full speed after a split second (dont even know why i tried this one -_-)

      What I Have Tried So Far
      > EC and Bios Reset (take out battery, disconnect AC Adapter, disconnect CMOS Battery, Press Power Button for upto 30 seconds)
      > Change Ram and check all available slots
      change/remove HDD
      > Repaste CPU/GPU and clean out fans
      > Checked GPU...... Flashed the 880m in this Sager with MSI vBios and tested it in a MSI Gt70 2PC i have, gpu ran fine, tested with FurMark, AC Odessey, Ghost Recon Wildlands for over an hour (unfortunately the cooling in my MSI is not good enough it already runs hot, and this 880m causes thermal throttling as well as power limit throttling sometimes). Reflash 880m with original Clevo vBios and put back into the Sager, still no boot, same results as before.
      > Checked the CPU..........checked the 4810mq in the MSI GT 70 which worked fine, as well as tried the 4810mq from the MSI in the Sager, still no boot.
      > Suspected bad GPU fan connection......therefore forced both fans to full speed as soon as i press power button (using FN+1 Keys) and both fans turn on full speed, same results.
      > tried charging the battery to the max before turning on on battery only, same results.

      >>------- The laptop has had some random shutdowns in the past too during gaming but would turn back on fine after waiting for 10 mins or so, then i sold it to some guy who brought it back to me the next day saying that it just turned off during gaming and wont turn back on, i returned his money, did all the troubleshooting above to no avail. then i finally put it aside to wait until i get some other system in which i can test the CPU and GPU.
      Then one day i turned it on (after leaving it untouched for a couple months), same results as above, i decided to try once without battery and it Freakin Turned ON!!!, used it for a couple days without battery, played a few games (thermal throttling was observed here and there), but then this happened again and this time it seems permanent . And now i have not only repeated all the steps above but this time also checked the CPU and GPU in the MSI GT70 too. ------------<<


      Some Observations
      > touching the CPU heat pipes feels warm, but the GPU heat pipes are colder (GPU never even booted?). dont know if this is normal or not.
      > i replaced one of the capacitors near the CPU once, but i did use the laptop for quite a while after that without any issues.
      > my Idle temps were always below 40c for both CPU and GPU, so an overheat warning as soon as laptop is powered on seems unlikely (false overheat warning?, but GPU does not even seem to be detected/ booted as heat pipes remain cold to touch), also i repasted the CPU and GPU multiple times.
      > The guy who sold me the laptop told me that the power adapter was originally a Dell, and it was modified to use with this Sager by replacing the cable with a 4-Pin one from a Toshiba (same pinout as the Sager), but then again i have used this laptop for quite a while on the same adapter.
      > From day 1 of having this laptop, some keys on the keyboard (w, s, t, c and numpad 4) did not work 99% of the time. pressing really hard on any one of them sometimes made ALL of them work for a while. any thoughts on this issue?? (even if its unrelated).

      So what seems to be the issue here?
      GPU not detected ?, False temperature alert?, Bad fan?.
      Any help towards resolving this will be greatly appreciated.
      Thanks in advance .
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       

      View full article
    • By Brian
      Following the release of NVIDIAs new 436.02 driver which I mentioned in an earlier article here, I've decided to make a quick and dirty video showing off NVIDIAs new Sharpen filter which is part of their Game Filter feature. It works with the most popular APIs including DX 9, 11, 12 and Vulkan and can be set on a per-game basis with granular settings of 0-100 unlike AMDs RIS which is limited to Navi and lacks DX 11 support.
       
       
    • By Consumerofmulch
      Hello!
       
      I have recently acquired my Dell Inspiron 15 7000, and I am interested in building an egpu setup for it. It has a USB-C port. Any recommendations/guides out there?
       
      thanks.
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.