Jump to content
EwinRacing Flash Series Gaming Chairs
Venc Dee

Adding internal USB hub to Ideapad Y510p

Recommended Posts

Because I was in need of free USB ports (especially for Bluetooth after Wifi card change) I started DIY work on adding internal USB hub. I wasn't able to found any free USB head on board so I decided to adopt USB-2.0 port on Audio jack board. This was successfull and my Y510p has now 3 more internal USB ports (fourth port is connected out to external USB - except power which is lead directly to allow power-off charging, of course).

 

As usb hub I used mini octopuss hub type, the output cables pretty fitted to free room around HDD and under mPCI slot. On one cable is connected mini bluetooth 4.0 module, on second mini micro-SD reader (for fail-safe and system repair and recovery, including gparted live distro) and one cable is left free, ending just beside mPCI slot. I plan to use it eventually for usb wifi mini-dongle replacing PCI wifi card thus freeing mPCIe slot. The free slot will be then available for PCI riser with external graphics etc. ...  If somebody is interested,  I'm ready to upload complete and detailed photo story :)

Edited by Venc Dee
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By thinkdad
      Hi,
       
      I need help in fixing my Thinkpad.

      I just got a T440p yesterday. It was working perfectly until the following:

      I reinstalled Windows and then I installed Vantage.

      I installed all the latest drivers.
      I also choose to install the bios update. The bios update ran in Windows and it asked me to restart. After restarting, the screen was blank. I tried powering it off and on and I saw the Thinkpad logo but after that the screen was blank.

      I tried powering on and off again and there's no Thinkpad logo now and the screen is just blank with the green power on. No sound, no nothing.


      Here's what I tried:
      Pressing the power button 10 times and then holding it for 30 seconds. Unplugged and battery is detachted Detached the CMOS battery and the reattached it Removed the ram, harddisk and optical disk drive. Attached the battery and inserted the charger. I turned it on and there was a couple of beeps Tried pressing FN+R and created a bootable USB I'd like to ask: How do I fix this? What do I need to do?
      Can I reflash the bios in some other way? Do I need to buy a new motherboard? Will this solve the issue? It's my first thinkpad and I'm really excited but I was bummed out that this happened. Can you please help me?

      Thanks in advance!
    • By sam@83
      Hello !
      I tried a tutorial on the forum to remove the supervisor password on a X260 thinkpad but the winbond 25Q128FVPQ chip is not recognized with the programmer CH341A and ASprogramer (does not detect automatically and not manually). Plugged into the motherboard with a soic8.

      Can you help me with detection?
      Can I find the password with the software or do I have to write it?
       
      Thank you so much !!!
    • By Donz7733
      Hi
       
      Currently I am using Nvidia 376.44 version for SLI functionality. On trying to install any higher version , SLI wont function & only 1 card works.
       
      if anyone is using higher version Than the one mentioned above for SLI, please let me know
       
      Thank You
    • By Cubitci
      To install the unlocked bios, I prepared and booted a freedos usb. I start the installation by typing flash.bat but every time I get the following error: Error 28: Protected Range Registers are currently set by BIOS, preventing flash Access. Please contact the target System BIOS vendor for an option to disable Protected Range Registers.
      How can i solve this problem ?
    • By arifhsn
      https://www.sendspace.com/file/0zjk9f
       
      please help i can't access my g5070's advanced menu
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.