Jump to content
EwinRacing Flash Series Gaming Chairs
Guardian241

Nvidia Geforce GTX 680m to 980m - Faulty GPU or problem with install?

Recommended Posts

So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

UYQGPO8.jpeg

Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?

 

Thanks for any help you can give.

 

- M

Edited by Guardian241

Share this post


Link to post
Share on other sites

You could try NVCleanstall, but this looks like artifacting which is a hardware issue. Most likely RMA or return.

Share this post


Link to post
Share on other sites

By the looks of those visual artifacts displayed on your screen, I'd try to take out the videocard, clean the pin contacts with isopropyl and a paper towel and try again. 

 

Also, make sure to replace the thermal paste or the gpu will over heat. 

Usually, those artifacts mean the gpu chip itself needs to be reflowed with a hot air gun. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By ChuckWhip
      I'm attempting to install a gtx 980m into an m17x r4. I have an unlocked a15 bios booting in pure UEFI. I haven't really messed with any other settings in the bios. I used DDU to uninstall previous Nvidia drivers and all system drivers are up to date.
       
      My issue is the 980m is not being detected at all in the bios or device manager. I believe in the bios, "Discrete Graphics" says "Not Detected". Is there any possible explanation for this other than a dead card? The old gpu still works fine on this device when I switched back,
    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By Klem
      Klem's_vbios_DELL_GTX880M_80.04.F5.00.07_UNLOCKED.rar
      For 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked core voltage adjustments.
      3. Unlocked Power Limit.
      4. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      5. Increased Power Limit and Power Target.
      6. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
    • By Bananoid
      Hello, guys!
      The situation is the following. I am a 3D artist and I work for a Ukrainian company. After the events in our country, most employees moved to safer cities, while the rest have to work remotely. I purchased a non-working Clevo p750dm-g from my hands. The reason for the inoperability is that the owner tried to flash the BIOS with coffee lake support, but something went wrong and he stopped showing the picture (black screen), but the laptop itself starts up, the fans spin, the keyboard lights up, the SSD heats up (too much). I tried flashing the bios using a USB programmer, but that didn't work. I would be very grateful if someone could help revive this car. It is imperative to return to the functional system at work.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.