Jump to content

MSI GS70 6QE (MS-1775) Shutting down with no reason


Recommended Posts

Hi! I have faced this problem a month ago. Laptop is shutting down by itself with no reason!

It happens quite suddenly. It turns off like if  I hold the power button (everything just going black with no error masseges or smth).

After reboot i can see "Kernel-Power 41".

The laptop has 3 performance modes: Green, Comfort and Sport. It turns off when it's working in "Comfort" or "Sport" modes and in "Green" mode this has never happened.

As soon as I put it in the "Sport" the laptop goes out after 2-3 minutes. Without load it works normally in all three modes. There is no overheating, the temps are ~80-82C for both GPU and CPU cores under full load.

All the clocks are default. I already reinstalled windows, reinstalled all the drivers, tried old driver versions... tried everything that i can do via software! Also tried turning "Turbo-boost" and/or "Hyper Threading" off. Nothing helps. Sometimes it's not shutting down, it acts like if I disconnect the power adapter and it starts working only from the battery power, even with power adapter still plugged in. Sometimes it starts "blinking", like power adapter going on and off (1-2 blinks). I also tried 600W power adapter, with the hope that THIS ONE will be enough, but nothing changes. Usually it happens more frequently when battery is under 90% of charge and laptop starts using both PA and Battery, while charging it.

Please, i need help! Maybe you have some ideas how to fix this without sending my laptop to the service?

See laptop specs-file in attachments.


Link to comment
Share on other sites

  • 1 month later...
 I've disabled all services similar to safe mode according to: http://windows.microsoft.com/en-us/windows7/which-drive...

The only services I have enabled right now in normal boot are:

Windows event log

Plug and Play

Remote procedure call (WPC)

Cryptographic Services

Windows Defender

Windows Management Instrumentation (WMI)

I've left it on the desktop (in normal boot) with these services and it's been running without any shut off for about an hour, which is the longest it has ever ran without the charger since the issue came about.

at the moment, it's looking like this may be the fix, but I dont want to jinx it. I have about 33% remaining (1 hour, 9 minutes) til the battery is drained. So ill leave it on for another 10 minutes or so til i start tackling which services to enable. Any thoughts on where to start?

I have a hunch the Remote Procedure Call (RPC) service may be the culprit, so i'll start by enabling other services around that.
does anyone know the important services that need to be enabled first?


GS70 Power battery is not easy to find, please try to buy a OEM battery to check the Power system.

11.1v 5400mAh BTY-L76 Battery for GS70


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.