Jump to content

2015 15" MBP M370x + GTX1070@16Gbps-TB2 (AKiTiO Thunder2) + Win10 [MattGarlandUK]


Recommended Posts



Macbook Pro Retina 15” Mid 2015 

AMD Radeon R9 M370X 2048 MB

2.8 GHz i7, 16GB RAM


Windows 10 64bit ( bootcamp )

OSX Sierra



AKiTiO Thunder2


Graphics card:

EVGA NVIDIA GeForce GTX 1060 6 GB GDDR5 Memory PCI Express 3 Graphics Card


Power supply:

EVGA 100-W1-0500-KR - 500W 80 Plus Power Supply (100-W1-0500-KR)



Molex to barrel adapter to connect PSU to GPU and enclosure

GPU powered by the PSU directly

HDMI cable to connect GPU to monitor

Thunderbolt cable to connect Thunder2 to Macbook

PSU powered on using the 'paper clip technique'



Dell U2715H 27-Inch Widescreen IPS LED Monitor


Info and guides:




Power on and connect the GPU, check that the Nvidia is showing up in the device manager

Install Nvidia drivers

Disable discrete AMD GPU in the device manager and shut down

Boot back up into Windows10 and BOOM, Windows10 should now be using the GPU.


I can reliably get the eGPU to work every time and have experienced NO CRASHES!  I still play games using the AMD when I'm not at my desk, which just requires re-enabling the AMD.  Sometimes switching the AMD on and off can cause the device manager to hang, but restarting Windows 10 sorts this out so I've not had any problems using the system both ways.


Games Performance:

Doom - 1440p max settings - 60pfs ( WOW!!! )

Deus Ex Mankind Divided - 1440p max settings - 30-45 fps

Just Cause 3 - 1440p max settings - 30-45 fps

Star Wars Battlefront - 1440p max settings - 30-45 fps

Overwatch - 1440p max settings - 60fps


Getting Windows10 to select the eGPU as the primary display device:

As far as I can tell, all that is required to get the GPU to power the external display is to disable the discrete graphics chip (AMD R9 M370X) via the device manager in Windows10.  

In my experience, provided the eGPU is connected, disabling the AMD R9 will automatically cause the OS to switch to the eGPU.  Although a couple of times when I've done this without restarting, the AMD has switched itself back on!

Provided the eGPU is connected and powered on, and the AMD is disabled, booting into Windows 10 will automatically select the eGPU and you're away!  





Edited by MattGarlandUK
Link to comment
Share on other sites

  • Tech Inferno Fan changed the title to 2015 15" MBP M370x + GTX1070 @16Gbps-TB2 (AKiTiO Thunder2) + Win10 [MattGarlandUK]
  • 2 weeks later...

Hey, I'm gepsannt how you manage under Win10. I use the same hardware including the EVGA GPU + AKiTiO2 combination with another power supply. From the housing I cut nothing.


The 1060 is recognized with me under Win10 but unfortunately I get it not to start (on an external TV / monitor) although I can install Nvidia drivers.

I hope you come soon with updates)

Edited by Himmellaeufer
Link to comment
Share on other sites

  • Tech Inferno Fan changed the title to 2015 15" MBP M370x + GTX1070@16Gbps-TB2 (AKiTiO Thunder2) + Win10 [MattGarlandUK]
  • 1 month later...

Hi, can help me T-T


Today, I received every component I bought from eBay and tried to set up my eGPU. I intended to power the Akitio and graphic card using the Dell DA-2. However, I didn't realize the barrel plug was not compatible and I pushed it so hard that the central part of the connector broke as the photo showing. Is there another way to power my Akitio?


Edited by 1366921
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.