Jump to content
EwinRacing Flash Series Gaming Chairs
x6tus

Noisy Gtx980? 2015 15" MBP, Thunder2

Recommended Posts

 

Hi, I've not posted on here since I built my eGPU for my 2015 MacBook Pro over a year ago. That unit was an Akitio Thunder2, RM 650W PSU, CoolerMaster 130 case, powered riser cable with a Zotac GTX 770 card.

 

It's mainly used for playing Elite Dangerous on and it has been working perfectly.

 

Recently I had the opportunity to upgrade the GTX 770 to a GTX 980 Reference card. It was pretty much a straight swap out except for the cards power connectors. On the GTX 770 these were 1 x 8-pin and 1 x 6-pin connectors. On the GTX 980 these are 2 x 6-pin connectors.

 

Simple enough with my 650W PSU I just switched connectors. I am using the same powered riser cable for the PCIe connection.

The unit boots up and works okay on Windows 10 via the display port connection. It will even play Elite Dangerous on Ultra settings and give a steady 60fps.

 

So all good! Why am I posting here and asking for help???

 

Well, I noticed that when playing Elite Dangerous I could hear a high pitched electronic screaming noise coming from the unit. At first I thought it was the GTX 980 power coil as apparently they do sometimes do this. However on closer inspection the noise is coming from the Akitio board.

 

It appears to be power related, so I tried to stress the card (and hopefully use more power) by using 3D Mark 11. Sure enough when running the benchmark tests the Akitio board makes a very high pitched electronic screaming noise. The noise stops when the tests stops. So it is caused by load on the graphics card and therefore I presume power, or lack of it.

 

Do you think power is the problem here? If so, what should I do? I don't use the 2.5mm power adapter input on the Akitio board because my powered riser cable has a MOLEX adapter attached to it. 

 

Should I scrap the powered riser cable and get a non-powered version and then create a MOLEX to 2.5mm DC adapter plug for the Akitio power socket? Would that supply enough power for the GTX 980.

 

The GTX 770 never had this problem, but I presume the GTX 980 draws a lot more power under load.

 

I've attached some pictures below. Any help or advice you can give would be appreciated.

 

Thanks,
X6

aa.jpgbb.jpgdd.jpg

ee.jpg

Share this post


Link to post
Share on other sites

Noises because of GPU load are more common nowdays with the Maxell GPUs! That is because the GPUs now have a very complex power management, allowing the GPU to switch extremly fast between power states and loads.

A very common problem are the GTX970 cards with poor coils and weak power system on the card.

A bad PSU can cause the same problems, but I would say that the AKiTiOs power system was not made for such high loads and reacts with that sounds. It's no problem, just a bit uncomfortable.

Share this post


Link to post
Share on other sites

Okay, that's good to know. The card does operate correctly even with the noise.    

 

Are you saying there is no advantage to switching to a MOLEX to Barrell connector instead of a powered PCIe riser cable?  

Share this post


Link to post
Share on other sites

It appears to be :)   I guess I'll be using headphones anyway so I won't hear it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Sarafan
      Does anyone have experience with this?

      Some threads I've seen have done it on a 17 inch laptop, I was wondering if it was possible on the 15 inch version as well.

      What issues will I face? I read about having to have a custom BIOS and vBIOS..but also HDMI/audio issues.

      I guess I should also upgrade my CPU, which runs really hot (i7 4800MQ), but not sure another Haswell chip will run any cooler.

      I've used liquid metal and even that hasn't changed temperatures much, it still reaches 93C pretty easily.
    • By sigma
      I have a Clevo P170EM with a GTX680m from 2012 and it's starting to show weight of the years  
      I would like to squeeze little more performance out this "outdated" GPU.
      Can someone help me ?
       
    • By mrsmile1015
      Just recently puchased a Clevo Gtx 780m on ebay and inserted it into my Alienware m17x r4. I'm terrible dissapointed to find the BIOS a12 unlocked and device mananger doesn't detect it at all. Are there some steps I have to undergo to make it work? 
    • By mrsmile1015
      Just recently puchased a Clevo Gtx 780m on ebay and inserted it into my Alienware m17x r4. I'm terrible dissapointed to find the BIOS a12 unlocked and device mananger doesn't detect it at all. Are there some steps I have to undergo to make it work? 
    • By kela777slk
      Hi people.  I looking for unlocked vbios for gtx670mx clevo for overclocking my old p370em.  I find vbios on this site -  kepler bios mod but i can't download it.  No access.  
      Maybe whose help me please download for me only OC vbios 670mx.  Thanks
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.