Jump to content
EwinRacing Flash Series Gaming Chairs
µgnier

Problem with 8970m Crossfire on p370sm

Recommended Posts

Hello,

I come to you because it is very rare to find topic concerning crossfire notebook.

I have bought 2 years ago a p370sm with 2 8970m 4GB paired in crossfire.

1 year ago , one of the two graphic card stopped to work. I've tried to swap the graphic card from their slot and I concluded that one of the two gpu was dead.

I stayed for a long time with only one GPU on the primary slot, and 2 weeks ago , i ordered a copy of my card on Aliexpress:

http://www.aliexpress.com/item/HD8970M-HD-8970M-R9-290X-4GB-GDDR5-MXM-for-CLEVO-P570WM-P370EM-P37xSM-P37xSMA-P150EM-P150SM/1978000913.html

The card was recognized by my laptop and It showed two cards 8970m in the Device Manager.

On CCC , the two cards were recognized but the second was "(desactivated").

I tried to reinstall catalyst but the problem is still here , i can't enable crossfire on the Radeon menu.

i've made a gpu-z test and i've seen that the version of the two GPU were not the same. Moreover the bus version is different between the two cards.

The responsible can possibly be the wire between the gpus ,it stayed in a drawer for 1 year.

I've heard that @Prema is very qualified in Clevo gpus.

Thank you for your future response.

Have a good day,

 

(All apologies for  my english , I'm french)

 

gpu1.gif

gpu2.gif

radeonscreen.PNG

radeonscreen2.PNG

Share this post


Link to post
Share on other sites

So , I solved the problem by MYSELF .

If it can help someone this is how i proceded.

The problem was caused by the different versions of the VBIOS of the two GPU

the gpu i've ordered was a p570wm gpu and wasn't compatible with the p370sm.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Onehit
      I've been scouring the internet in search of anything regarding an updated bios for my Clevo P170SM. I have found many mentions of Prema Bios mods on various websites, but good luck trying to find actual download links. They all seem to vanish or have dead links. Wayback Machine doesn't help either and I was only able to find stock Clevo bios as early as 2015 via the WayBack Machine. If anybody has an updates Prema Bios or some other unlocked bios file for the P170SM, that would be fantastic! Otherwise, I might have to consider paying over $100 to Eurocom for their unlocked bios.
    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By rsk
      Hello everyone just a little question. 
       
      i've just flash my p751dm2-g with the backed's bios and i gonna overclock it of course but i don't know how to clear cmos on this laptop.
      i have find nothing about it in the manual so i ask here. 
       
      Thanks 
    • By rsk
      Hello everyone I'm new on this forum and i'm new with clevo laptop. 
      I've recently buy a second hand laptop a clevo p751dm2-g with a i7 6700k and a 1070 mxm and unfortunatly the bios is locked i can't overclock my cpu or my ram. :sadge: 
      So i wanted to know if you guys on this forum have alternative solution to oc your cpu and your ram with a locked bios. 
      Thanks 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.