Jump to content
EwinRacing Flash Series Gaming Chairs

GX740 RAM upgrade problems

Recommended Posts

Hi everyone

I have some problems upgrading the RAM from my GX740 (Board: MS-1727). It came with 4GB of RAM, which sometimes is a bit too little, so i thought I could upgrade it to 8 GB.

On my old RAM is written 1333mhz and a friend of me has some with 1333mhz, he gave me to test.

Strange is, when i look on the clockspeed during the running OS it's at 1066mhz. (Does it clock down? Nevermind, thats not the mainproblem)

Now the problem is, when the new RAM is installed, my laptop turns on normal, but as soon as the Windowsbootlogo (Win8.1) appears, it crashes with a nice BSOD. When i boot into my linux, it boots correctly but short after you log in it crashes too. The RAM is ok, because it worked well in an other machine, but when I run Memtest86+ in my machine with the new RAM it even refuses to start the test (error after one second and stops).

Is the RAM just incompatible with my board, or is there a possibility to fix that problem with an unlocked BIOS?

thanks in advance


PS: Sorry if there are some english mistakes, my swiss-english isn't that good :)

Share this post

Link to post
Share on other sites

hi, which CPU is installed on your laptop? is it core i5? if so, then the speed of 1066 mhz is due to the CPU's limit. i7 can run at 1333 mhz.

Share this post

Link to post
Share on other sites

Hi everyone!

i have the same problem with my gx740.

there is i5-430m on it and max speed for memory is 1067Mhz. but in gx740 was inserted 2 Samsung ram modules at 1333Mhz (yes they are clockdown to 1067mhz)

So I take another ram module Samsung 4gb 1333Mhz and inserted to Notebook. When i boot to safe mode windows7 it stoped at classpnp.sys.

i think this problem maybe in bios \ or incomptailable this RAM and laptop.

maybee it would be a surprise to you but in spite the same characteristics of RAM some of them may not work :-)

p.s. today i try update bios. (my version is too old)

After that i put 4gb RAM once again. may be updating bios helps me.

p.p.s. also you can go to the store, where a specialist will select RAM for your laptop and you can check that work RAM, if he agrees.

Share this post

Link to post
Share on other sites

It could be incompatibility with the one ram to the other try just the new one and remove the old one to test go in bios and look if you system see's the ram as it is. I think it's just an incompatibility on the 2 ram stick.

Share this post

Link to post
Share on other sites

Test with only the one "new" ram dim and remove the old one and test.

Share this post

Link to post
Share on other sites

hello again. it seems this problem is solved.

as you know, intel icore processors 1st generation hold's only 8gb ddr3 memory. in fact, my laptop don't hold's any new ram with memory chip's large than 256mb. Today most of ram's consist some 512mb chips, in that reason MSI laptop don't work.

How to Find memory that would be work in msi gx740:

it' just so simple! 1st , maximum size of ram 4gb per plank. 2nd, you need a ram with 16 memory chips on it. (4gb devide 16 chips - 256mb per chip) done!

look at picture, it should help to you post-28206-14494997977971_thumb.jpg (this is backside, in other side should be the same)

Good Luck!

  • Thumbs Up 2

Share this post

Link to post
Share on other sites

I have run into the problem that sky_bb describes and can confirm that my GX740 with arrendale cpu i5-450m also bluescreen on the windows logo. Oddly enough i couldt find this limitation described anywhere on the web other than here.

I have the ordered the I7-920xm and will switch the cpus later, do anyone knows if the clarksdale cpu will support my sk hynix 4gb 1 rank memory sticks with 512mb chips? It seems to be a whole different chip with a different memory controller.

Share this post

Link to post
Share on other sites

I have recived the I7-920xm and will answer my own question for others to know.


The clarksdale i7 cpu seems to have a memory controller with better support for larger chips. My 2x4gb Hynix 1Rx8 PC3 12800s that dont work with the I5-450m do work with the I7 cpu.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By whysigninwall
      Hi everyone i was wondering if it was possible to upgrade the clevo P775DM3-G to P775TM1-G you know if feasible by buying new motherboard and new heatsink, my idea was to upgrade to i9 9900k and rtx 2080/2070.
      Motherboard Clevo P775DM3-G
      Motherboard Clevo P775TM1-G
      Heatsink rtx 20xxx
      PS: I thank you to all  in advance.
    • By OnaStack100
      I have a p150sm which has a seemingly dead 780m due to a perpetual error 43 which came after a big BSOD about 6 months ago. I upgraded the laptop to a 980m and modded the inf files. The upgrade was perfectly fine for a week. One day, i left the laptop and something related to sleep or power may have caused the laptop to shut off. Since then, the laptop with the 980m won't boot. I tried many things like resetting cmos, taking out the hardware and putting it back in, and resetting bios, and buying a 230W adapter. Nothing worked. The laptop works fine with the old dead 780m in there, but now when the 980m is in there, holding the power button generates a green light flash and then the power LED goes back to orange. No sounds, maybe one tick, and that's it. What is left to try?
    • By Andrew2009
      Please could you check if it is possible to unlock my A17 BIOS? I have Alienware 17 R5(2013). 120 Ghz 3D. gtx 980 m. I want upgrade to 1070 but I have dark picture. Turns on but does not start with 1070. 980m-All good. What could it be?
    • By IveGotRoot
      I have recently upgraded my laptop(an M6800 firepro 6100) and replaced it with an GTX 980m. Nvidia says that the latest driver(461) supports my card but i can only install up to 388.13 Ive tried to mod it but i can't figure it out. I can run the latest linux driver tho
    • By pippocarlot
      Hello everyone! I am looking for an answer to a problem I cannot find a solution to ... I purchased an Amd wx 4150 MXM GPU module su e bay to upgrade my HP 8570W Mobile Workstation which is currently equipped with a Fire Pro M4000. Once the new GPU has been installed, the PC screen no longer turns on but works only with external monitors connected via the docking station. The same happens once the drivers are updated! If I put the old card back on, the integrated monitor starts working again ... How can I fix it?
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.