Jump to content
EwinRacing Flash Series Gaming Chairs

Recommended Posts

I hope it works out for you. I really thought I wasn't going to get my 1070 to work until I worked out the vBIOS issue and I had resigned to the fact that I had wasted $420USD (about $660AUD at the time). 

Share this post


Link to post
Share on other sites

yup I hope it really works out for me also. I don't want to blow 400 USD down the drain to have a useless bricked card if a bad flash happens or something along the lines of that occur that renders the card useless and unreturnable. It would be just be frustrating

Share this post


Link to post
Share on other sites

So I eagerly recived my 1070, but I get a black screen when I turn on the computer and insert it in. I have made sure UEFI boot is on and PEG mode is on. Im not sure what could be causing this as I also tried connecting an external monitor to the hdmi in and out with no result

Edited by Crustieraxe

Share this post


Link to post
Share on other sites

I'll see what I can find out. Maybe try re-seating the card just to make sure it's sitting right. I've heard some people have fixed it by closing the lid and opening it again but it probably won't work in this instance. 

Share this post


Link to post
Share on other sites
12 minutes ago, MattyB said:

I'll see what I can find out. Maybe try re-seating the card just to make sure it's sitting right. I've heard some people have fixed it by closing the lid and opening it again but it probably won't work in this instance. 

I didn't try closing the lid. But i did try putting the card in several times. I also got no beep codes. 

Share this post


Link to post
Share on other sites

Did you Disable Load Legacy ROM in the BIOS? Usually you'll have to do a clean Windows installation when switching from Legacy to UEFI as you have to change your drive partition from MBR to GPT. 

Share this post


Link to post
Share on other sites
13 minutes ago, MattyB said:

Did you Disable Load Legacy ROM in the BIOS? Usually you'll have to do a clean Windows installation when switching from Legacy to UEFI as you have to change your drive partition from MBR to GPT. 

I installed windows 10 with legacy mode on and then switched to UEFI. I think that was my problem I can't really remember

Edited by Crustieraxe
EDIT: Would that probably be the cause of the black screen?

Share this post


Link to post
Share on other sites

That could be your problem. You need a pure UEFI environment which usually means switching everything to UEFI and disabling Legacy ROM and then reinstalling Windows. During the installation it will tell you that you cannot install Windows on the disk because it's not of the GTP type, or something like that. You have to use Command Prompt to change the disk type. I had to do all this when swapping my M18x to UEFI. I googled how to swap the disk type using Command Prompt and it worked perfectly. 

I was told that I had to have UEFI so I swapped over from Legacy. After I did it I spoke to someone else with an M18x and he did the upgrade without UEFI. I'm not sure if the M17x is different though because of the 120Hz display. 

Good luck!

Share this post


Link to post
Share on other sites
2 minutes ago, MattyB said:

That could be your problem. You need a pure UEFI environment which usually means switching everything to UEFI and disabling Legacy ROM and then reinstalling Windows. During the installation it will tell you that you cannot install Windows on the disk because it's not of the GTP type, or something like that. You have to use Command Prompt to change the disk type. I had to do all this when swapping my M18x to UEFI. I googled how to swap the disk type using Command Prompt and it worked perfectly. 

That is probably 100% my problem because it doesn't make sense it won't even give me any picture

Share this post


Link to post
Share on other sites

Hopefully. I would think you'd get a beep code if there was a hardware issue. 

Share this post


Link to post
Share on other sites
9 minutes ago, MattyB said:

Hopefully. I would think you'd get a beep code if there was a hardware issue. 

My current windows installation is GPT. My problem lies somewhere else.

Share this post


Link to post
Share on other sites
Just now, MattyB said:

Is the Legacy ROM enabled or disabled?

Disabled. So the bios can't be my problem. Video mode is alos on PEG

Share this post


Link to post
Share on other sites

Yeah sounds like you have everything set right. I've never done it on an M17x which makes it harder to help. I would suggest to start a new thread at NotebookReview. Sometimes questions get missed if you comment on another thread. 

Share this post


Link to post
Share on other sites

Will it boot to the BIOS with the card installed?

Share this post


Link to post
Share on other sites
3 minutes ago, MattyB said:

Will it boot to the BIOS with the card installed?

Nope it will not boot to bios at all. It also has no backlight when it is turned on. I'm confused as to why its not working since I did everything correctly.

 

Edit: is there a key combination I can do to get into any setup screens that will get me into the bios?

Edited by Crustieraxe

Share this post


Link to post
Share on other sites

I can't quite remember but I thought it was SHIFT-F or SHIFT-D. I'll see if I can find it. The problem with the 120Hz display is it needs the GPU to run it so if the GPU isn't working then you get nothing. Do you have to reinstall your old card to see how the BIOS is set up?

Share this post


Link to post
Share on other sites
7 minutes ago, MattyB said:

I can't quite remember but I thought it was SHIFT-F or SHIFT-D. I'll see if I can find it. The problem with the 120Hz display is it needs the GPU to run it so if the GPU isn't working then you get nothing. Do you have to reinstall your old card to see how the BIOS is set up?

Yup I have the old card on right now and i can see everything in the bios. But when i have the 1070, I don't see anything. I'm thinking the vbios is not compatible with this laptop. If that's the case then I'm just goinf to return because i can't even get into the machine with the card to flash a new vbios onto it

Edited by Crustieraxe

Share this post


Link to post
Share on other sites

It's definitely possible. If it did come from the ASRock machine like the other guy said then it will definitely have an incompatible vBIOS. I would have thought that your M17x would still pick it up as an Nvidia card and at least boot the machine. It's a different situation with your 120Hz display though and it makes things more complicated. My 1070 vBIOS was wrong but the M18x uses SG mode for the 1070 so the laptop would still boot fine with the Intel graphics. Flashing the correct vBIOS was pretty simple. If you lived a little closer I could test it out for you. 

 

You could also look at using a BIOS programmer. I have zero experience or real knowledge about them but many people use them to flash a BIOS. I believe it actually clips onto the BIOS chip and you flash it this way rather than it being inside the laptop. I've never looked into it though. 

Share this post


Link to post
Share on other sites
16 minutes ago, MattyB said:

It's definitely possible. If it did come from the ASRock machine like the other guy said then it will definitely have an incompatible vBIOS. I would have thought that your M17x would still pick it up as an Nvidia card and at least boot the machine. It's a different situation with your 120Hz display though and it makes things more complicated. My 1070 vBIOS was wrong but the M18x uses SG mode for the 1070 so the laptop would still boot fine with the Intel graphics. Flashing the correct vBIOS was pretty simple. If you lived a little closer I could test it out for you. 

 

You could also look at using a BIOS programmer. I have zero experience or real knowledge about them but many people use them to flash a BIOS. I believe it actually clips onto the BIOS chip and you flash it this way rather than it being inside the laptop. I've never looked into it though. 

Well, my machine has SG mode as well. Could i possibly boot with the 1070 in this mode instead of PEG?, furthermore will I be able to boot again to bios if i put it in this mode with my 660m 

Share this post


Link to post
Share on other sites

You will most likely get an 8 beep code and I've also heard that it could brick your board. 

Share this post


Link to post
Share on other sites

So I have found older posts of people running SG mode and stating to run SG mode on the laptop as quoted from a notebook revoew thread

 

You can run Optimus mode (SG) and support the following GPUs:

1070: https://www.ebay.com/itm/New-Nvidia...490959?hash=item2cdd7c974f:g:VgYAAOSwNo9b0ulz

1060: https://www.ebay.com/itm/Nvidia-GeF...487546&hash=item2f2a9c5b14:g:RCQAAOSw5pRcSDe1

or if you want to run PEG (dedicated mode) you can use:

980M: https://www.ebay.com/itm/NEW-Dell-A...sh=item23b20b1e05:g:vhoAAOSwwvZZU2yI&LH_BIN=1

780M: https://www.ebay.com/itm/Nvidia-GeF...sh=item3d8b4bbcbf:g:RM0AAOSwgTxc4nbX&LH_BIN=1

680M(native support): https://www.ebay.com/itm/Nvidia-GeF...sh=item2cec1c5ccf:g:5QkAAOSwZbFc94wG&LH_BIN=1

680M will provide 2x your current performance
780M will be around 10-15% faster than 680M
980M will be 4x your current performance (2x 680m)
1060 will be around 10-15% faster than 980M
1070 will be 8x your current performance (~2x 980m)

If you want a cheap upgrade, native support, 2x performance, 680m is great.

980M will provide a much bigger performance increase while keeping native PEG mode.

1070 will provide current gen laptop performance.

Share this post


Link to post
Share on other sites

Ok, that's interesting. Optimus (SG) will not work with the 120Hz display so it will be interesting to see what happens. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Noxco
      Hello to all can you help me change the graphics card?
      Alienware m17x r4
       i7 3610qm
      quadro k4100m
      display 120hz 3d
      bios a15
      trying to install 980m but not getting 5 or 8 beeps removed the battery and reset the bios. disabled legacy and secure boot in settings windows 10 gpt uefi
      help how to be?
    • By Klem
      If someone wants upgrade Wi-Fi card and remove witelist, or unlock hidden additional menus and settings, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread.
    • By x86-64
      My laptop's CPU is i7 4700MQ, iGPU is GMA HD 4600, and dGPU is NVIDIA GeForce GTX860m.
      Please send me a modified BIOS(.ROM) file with GMA HD 4600 disabled among the two graphics.
      Stock BIOS Firmware : https://url.kr/kpegx5 (4MB)
    • By -GP
      I got a msi ge60 2pf Apache pro & its specs :
       
      Processor-i7 4710MQ
      Ram-16GB 
      VGA- GTX 860M 2GB Maxwell 
       
      Could anyone tell me the best overclock that I could use on this GPU?
      Please keep in mind that the voltage cannot be changed as this is a laptop
       
      Thank you
    • By -GP
      Hi, My laptop is msi ge60 2pf Apache pro.
       
      *Specs: i7 4710MQ , GTX 860M 2gb (Maxwell), 16GB RAM
       
      Could anyone please tell me a good stable overclock for Performance improvement of gaming? (For my GPU ? - please keep in mind that it couldn’t go over +135mhz & also voltage cannot be changed its locked)
       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.