Jump to content
EwinRacing Flash Series Gaming Chairs

P170SM-A GPU defect?

Recommended Posts

Hello Forum, 
I got a weird Problem with my laptop.


Win 10 Pro 19041

GTX 870M 6gb
2x4gb Kingston Ram

BIOS 1.03.11
EC 1.03.09

I had the problem, that ill get a BSOD every now and then while gaming, i think because it overheated. 
So i began to search.
Some years ago i made a BIOS update, from Premamod i believe, to gain access to the fan-controll of my GPU.
Which didnt work sadly - BIOS update wasnt the problem, but i didnt had acces to the fans still..
But i didnt know what to do so i just let it be like that and tryed to tweak some settings down to apply less stress to the GPU. 

The 870M, after some more BSOD's, suddenly became a "Basic Display Adapter",
and the driver wont install anymore - "not compatible".

I rebooted and the BIOS did only show me a GTX 780M
Back into Windows the hardware ID of the GPU became 119F.7481.1558
119F Is indeed a 780M..

BTW 119F.7481.1558 doesnt exist in any of the .inf file of the driver. 

In safe mode with configured "nvcvi.inf" , DDU and deactivated driversignatur checks i managed to install the driver again
but i had a hard time ingame, heavy lag spikes and crashes every now and then

And now, today, i had the "Basic Display Adapter" again
In safe mode with configured "nvcvi.inf" , DDU and deactivated driversignatur checks i do still get the error of no compatible device(??),
I didnt change the driver files and it did work befor but now it wont let me install those with the setup.exe

So back to the Device-Manager, manually applied the nvcvi.inf and chose the 870M.
Now its shown as a 870M but the ID is still wrong and BIOS also tells me its a 780M
Also the systemsettings of Nvidia are not available so the laptop will often choose the Intel GPU for games instead of the GTX..
Sadly, i cant find the initial post where i got my BIOS update from back then and im not 100% sure if it was the exact BIOS i needed to be honest.
I was alot less carefull back then ....

So two things in my mind:
First, which i dont know if its a thing even, that i chose the wrong BIOS, which actually messed up the hardware ID's ??
Or one of the GPU RAM-Chips died which would make it a 4gb Ram Card (780M does have 4gb) but i dont know how to find that out..
Of course i changed the thermal paste and pads already and i didnt notice any darker spots on or near the GPU nor the MB or CPU which would speak for overheat or something simillar

Im a bit lost now and dont know what to do .. so thanks in advance.

PS: Sorry for the novel & the bad spelling, im not good in such forum-post-things..

Im trying to add a Picture of the Specs and also a BIOS screen but it wont let me upload,.



Edited by XionMk1

Share this post

Link to post
Share on other sites

Notihing? No one? 
If i should add some more info or such, please tell me to.. 
As i said, im not to familiar with such forum things.

I got the old driver to apply again.
It somehow updated the directory with an actually unedited inf file so i just edited it again to match the GPU.

It would be sad if i cant do something to it. I can run gta 5 at like steady 60fps but those spikes just killing the laptop and i just dont know why.
When i look at HWmonitor it doesnt even hit 95C.. so since its a laptop i dont think its just the heat .. 



Ouh and i checked the Chip on the GPU and it says gk104 which means its a true 870M .. i didnt think it would not, but who knows.. 

Edited by XionMk1

Share this post

Link to post
Share on other sites

When you say the system settings for nvidia aren't available, do you mean the nvidia control panel? This happened to me when there was an issue with the modded .ini file and driver combination - have you tried getting the latest modded .ini from https://forums.laptopvideo2go.com/ ?

Share this post

Link to post
Share on other sites

Yea the control panel is missing.
Well since my Hardware ID doesnt match the Hardware itself.. those ini's probably wont work either ..
Its the original nvidia driver just with the .inf file edited so it will find and except my weird card..
I'll have a look still, maybe ill find something helpfull over there!


Share this post

Link to post
Share on other sites

With forced driver installation the card seems to work just fine again.
Control panel is there too, but i sometimes get a Bluescreen as soon as i tweak and apply something within the panel. (not every time tho)

Not sure what changed - but i can game like i used to befor.
The Device ID and the VGA card reading of the Bios still doesnt fit.
It shows up as 780M and every 2 reboots or so i have to force-install the driver again,
since it goes back to "Microsoft basic display adapter", even tho i disabled automatic updates ..


After some research i found that thread about "Hacking" an NVIDIA card to change the GTX card to a Quadro. 


Which made me think, that one of the resistors might be broken.
Resistance corresponds to read =
5K   = 8

10K = 9
15K = A
20K = B
25K = C
30K = D
35K = E
40K = F

ID should be:          1199 
But it is:                   119F
So if the resistor at the end, which corresponds to 9 @ 10k, just burned and now has 40k+, it should spit out 119F.. if i got that right.(?)

Since its a damn little pcb .. i couldnt find any obviously broken resistor nor capacitor..

And i dont know where could be located at all.

Only thing i didnt get is how the 1's are generated.
But since that thread is about an 670 im pretty sure that theres more to know about the 870M,

but i did'nt manage to find any info about the resistors for that card.
If anyone knows something more about that, please tell me or just tell me where i could find more bout that topic.

I would like to try some things next to that:
First of all, if anyone could provide me with a link to a Clevo Bios, i would try to just flash the Bios again,
in hopes that the initial flash back in the days messed something up.
On the bill it says its P170SM-A.

Secondly i would like to flash the Vbios of the 870M. But i cant find any VBios with the exact ID's i need.
Which would be : 10DE 1199 1558 7481

Any help appreciated!! Even just verify that what i think could be right or just completely wrong.
I really cant affort to just give up on that..

PS: I should say that i already cleaned everything and made sure everything is in place. New paste applied.

Edited by XionMk1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.