Jump to content
LoganWPatch

Need Help M18X R2 with a11 unlocked bios ran EVGA precision xoc

Recommended Posts

I have a M18X R2 running windows 7 with a11 unlocked bios with 980m. I have been running without an issue for over a year. I just installed EVGA precision Xoc to check fan speeds and temps and it was running fine until I restarted. Now I get 8 beeps at start up and can not get into bios. I found out that EVGA precision will affect a number of Alienware laptops, m17x r3, r4 m18x r1, r2, 17 r1, 18. I have read that it affects the bios, vbios, and display. I have removed the ssd and removed the installation for EVGA. I am in need of help to fix my new paperweight.

 

Thanks

Share this post


Link to post
Share on other sites

I have R1 not R2; but this leaves questions for you to answer for more help...

 

Does it post?  What happens when you apply power to it?

 

Power, black screen? Black screen with backlight?

Beeps x8?

End of excitement?

 

Have you tried downgrading bios to OG, via the SATA port method?

 

Just another M18x owner trying to pay it forward...

Share this post


Link to post
Share on other sites

No post

 

Power on, lights on fans on black screen no backlight

Beeps x8 and repeats

 

I have the M18R2A03WIN bios for the blind flash

I also still have m18xr2-SwicksModv2 for the upgrade

 

I have not tried to downgrade yet the 980m is in right now I do have a 280m that I can put in is place.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.