Jump to content
AGmR

[GUIDE] How to get NVidia Optimus work in WIN10

Recommended Posts

Hello everyone ^_^ , after lots of searching and testing also i just figure it out the final modification method will makes optimus works 100% functionality on windows 10, just follow those steps and enjoy optimusing :D

 

>> This guide for beginners and experienced just for fun also is common for any Nvidia GPU card model brands but just different Device ID, subsystem & (Section no. inside .inf) <<

 

Modding steps :

 

*Frist : 

u will need to download latest version nvidia driver for windows 10 (x86 or x64 depend on ur system) whatever desktop or notebook will not affect. aUwP7DW.png

wherever u downloaded driver just right  click on it and choose Extract to ....  .oqtH3uN.png then will be a folder of driver open it and go to the frist folder  >> Display.Driver << 

 

all above steps r easy and nothing :rofl:

 

 

we need a thing to modify dependable on it

right click on start bottom and choose device manager then go to display adaptors tab and double click on ur gpu 

a menu will popup then go to details and choose hardware Ids in menu we will need just secound line 

 

0BhoGGW.png

 

 

*Second :

Search in this folder u entered >> Display.Driver << for u laptop manufacturer .inf

 

Acer & Gateway = nvaci.inf
Asus = nvami.inf
Apple = nvaoi.inf
Compal = nvcti.inf
Clevo (Sager & other re-brands) = nvcvi.inf
Dell & Alienware = nvdmi.inf
Fujitsu = nvfmi.inf
HP = nvbli.inf
HP = nvhmi.inf
LG = nvloi.inf
Lenovo = nvlti.inf
MSI = nvmii.inf
NEC = nvqni.inf Siemens = nvfui.inf
Sony = nvszci.inf
Toshiba Qosmio = nvtdi.inf
Toshiba = nvtsi.inf

 

they all the same .inf if u compared, but just for accurate choose the right one i picked nvdmi.inf cuz my laptop is dell :D

 

then open it by double click on it will opened in Notepad or i recommended  this programme called Notepad++ (Here) so much better than normal Notepad on windows platform to play on it :D

after that in .inf u choosed click on (CTRL+F) a tab will popup and then type >> NVIDIA_Devices.NTamd64.10.0 << hit enter WKNsH6c.png, then type ur Device ID (The number after DEV_ )U6YypH3.png

u will see max 2 lines for ur number but different section no. and also subsystem numbers we need now to just put a line like that for the gpu we have but what section we will choose!!

easy same section for the one of those have (this line >> NVSupportOptimus = 1 <<) so we will just in search tab we will go to both section by type again Section0xx (*xx ur no.s)

and see what section of those have NVSupportOptimus = 1 

UtQLalk.png

then go back to NVIDIA_Devices.NTamd64.10.0 and add another new line just copy any line under NVIDIA_Devices.NTamd64.10.0

and change as ur PCI\VEN_XXXX&DEV_XXXX&SUBSYS_XXXXXXXX as above photo (New Line)

 

follow collors >> uGVa1sz.png

 

& section u will enter the one have NVSupportOptimus = 1 (for me 52 not 28 as u see in above photo)

 

after that we need also to add new line but not under NVIDIA_Devices.NTamd64.10.0

search again by enter ur Device ID (or just type GTX XXX* ) *ur GPU model

untill u go to something like that under [string] menu >> NVIDIA_DEV.XXXX.XXXX.XXX = "NVIDIA GeForce GTX XXX"

 

as mean >> YeNoEhd.png

and enter as same but with ur NVIDIA_DEV.XXXX.XXXX.XXXX  as collor above (between " ..... " u can enter any name u want for ur gpu :D)

 

click (CTRL+S) and close this .inf

 

*Third :

 

we need also to modify anther .inf in same folder >> Display.Driver <<

but here its just one same .inf file for anyone called nv_dispi.inf

open it by Notepad++ also as above then search by type ur Device ID (The number after DEV_ ) also, then u will just find one line under NVIDIA_Devices.NTamd64.10.0

but here its different section and also line w/o subsystem anyway we just need to know what section for it as mean (section009) but u will be different section no.

T1IhZP6.png

 

 

then go to [sectionXXX]

 

we need here to add some new lines under section

9Cg1SXq.png

 

replace with new lines 

Vd0QJ1y.png

NVAllowIR3DDriverPreStage = 2
NVAllowMCVirtualAudioPreStage = 0
NVBusUpperFilter = nvpciflt
NVDefaultBPP = 32
NVDefaultHorizontal = 1400
NVDefaultVertical = 1050
NVOptimusHCloneDisabled = 1
NVSupport3DVision = 2
NVSupport3DVisionForOEM = 1
NVSupportDisplayUpdate = 1
NVSupportGFExperienceExtendedOptions = 1
NVSupportGFExperienceUDA = 1
NVSupportOptimus = 1
NVSupportPhysx = 1
NvSupportMSHybrid = 1
RegisterDLLs = nv_common_registerdll

 

then hit (Ctrl+S) and exit ...

 

Now we just finish modifiy  both .inf

 

Thats it ^_^

ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

*Final steps to install Nvidia driver with modded .inf s *

 

Frist U will need to fully DDU Nvidia installed driver (Here) this tool fully uninstall ur driver from its roots :D by Sir/Wagnard (Special thanks to him)

 

after that also u will need to enter ur windows in "Driver Signature Enforcement (disabled) mode" How >> here u go ..

 

then after hit f7 restart and login go to nvidia driver folder and double click on setup.exe 

u know the next steps :D but w8 when driver is installing the special tab will appear

SWLGqef.png

Hit install this driver software anyway then the setup will continue till finish successfully  & yeah OPTIMUS UNLOCKED :32_002:

 

Reference (Thankx <3) >> http://null-bin.blogspot.com.eg/2015/08/how-to-modify-nvidia-notebook-driver.html

                                            https://forums.geforce.com/default/topic/912887/nvidia-gpu-not-detected-solved-/

ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

Also another article guide from utopian201 (Thankx to him) >> explaining  anotherway to modify both .inf files 

 

ـــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

 

Sorry if i talked too much in this guide but im really just wanna to explain every steps as much as i can to be easy with you, I hope this guide will help u as much as possible

 

and yea enjoy :)

Edited by AGmR
  • Thumbs Up 2

Share this post


Link to post
Share on other sites

Will this still work with the Windows 10 Anniversary update which requires drivers be signed?
 

When you go to device manager and look at events, what driver inf file is it using?

 

I have a similar guide here

 

But instead of adding lines to nvdispi.inf, I removed the desktop driver so that it HAS to use the notebook drivers.

 

I think what you have done is add capabilities to the desktop driver.

If your device manager says it is using nv_dispi.inf, you can skip the first part modifying notebook vendor inf and just go straight to modifying nv_dispi.inf.

Share this post


Link to post
Share on other sites
On 8/4/2016 at 10:43 AM, utopian201 said:

Will this still work with the Windows 10 Anniversary update which requires drivers be signed?
 

Didnt try redstone update yet but in couble days will upgrade to it, anyway i think its sameway to disabled driver signature enforcement .

 

Edit >> ic6kqWM.png confirm worked on rs1 update.

 

 

Quote

When you go to device manager and look at events, what driver inf file is it using?

 

Its showing now nvdmi.inf (dell) now but thats why >> cuz the modding effect. Before modding if u just install the stock driver w/o mod nv_dispi.inf will just show.. and thats why >> cuz nvdmi.inf wasnt have the right line for gpu to detect so its just picked the line was in nv_dispi.inf (w/o the lines added in there section), so both depend on each other.

 

On 8/4/2016 at 10:43 AM, utopian201 said:

I have a similar guide here

 

But instead of adding lines to nvdispi.inf, I removed the desktop driver so that it HAS to use the notebook drivers.

 

I think what you have done is add capabilities to the desktop driver.

If your device manager says it is using nv_dispi.inf, you can skip the first part modifying notebook vendor inf and just go straight to modifying nv_dispi.inf.

 

yes its great way also to modify, i didnt noticed this.

Nice instructions from you will add this in main thread post ..

 

i said in main post (after lots of searching and testing:D ) so if u just modify nv_dispi.inf >> when you go to setup drive u will get error dnt know why, so thats why should also modify notebook vendor inf .

Edited by AGmR

Share this post


Link to post
Share on other sites

Hey @AGmR, thanks for the detailed info.  I tried to do this but my nvaoi.inf file (because I have an macbook pro) doesn't list my video card, it just has like 10 in the list, which makes sense I guess.  So I just copy pasted the SectionXYZ from the dell file.  

 

I put a custom name for my card in the [Strings] section, to verify that it worked, but I still see the default name in device manager after installation.  I have the optimus icon in the taskbar but my card says it's (Inactive) next to it.  Nothing ever runs on it.

 

Is there anything I can check to see if I did everything correctly?

Share this post


Link to post
Share on other sites
2 hours ago, UncleGravity said:

Hey @AGmR, thanks for the detailed info.  I tried to do this but my nvaoi.inf file (because I have an macbook pro) doesn't list my video card, it just has like 10 in the list, which makes sense I guess.  So I just copy pasted the SectionXYZ from the dell file.  

 

I put a custom name for my card in the [Strings] section, to verify that it worked, but I still see the default name in device manager after installation.  I have the optimus icon in the taskbar but my card says it's (Inactive) next to it.  Nothing ever runs on it.

 

Is there anything I can check to see if I did everything correctly?

 

Hello @UncleGravity, you are welcome :)

Okay i checked nvaoi.inf yes right they just put few lines (12) in NVIDIA_Devices.NTamd64.10.0 & also for M gpus [Strings] section, even same for desktop driver lol  ..

so yes u must create fully new section (copied from another .inf) as u did from dell for example

 

But addition :

 

When u copy section should section have (NVSupportOptimus = 1) and also refer for your GPU not any section as said

also i think u didn't noticed this when u copy the section theres also like 

 

[SectionXYZ]

......

.....

.....

u must copy those also 

[SectionXYZ.abcd...]

.......

[SectionXYZ.abcd...]

.......

[SectionXYZ.abcd...]

.....

[SectionXYZ.abcd...]

.....

 

2nd ... theres also modification in section u copied 

(Will be add if not work)

_________________________________________________________________________________

so u modified also >> nv_dispi.inf   << as above ? must done to get optimus work

and also check r u setup driver under Driver Signature Enforcement (disabled) mode ?

 

 

Share this post


Link to post
Share on other sites

Hi AgMR

 

what's your system ? Did you use Setup 1.30 ?

 

With optimus profile, I cannot activate DSR and some nvidia features

 

Share this post


Link to post
Share on other sites

I change switch my PE4C 3.0 

SW 1 = 2

SW 2 = 1

For different purpose

 

And this happen

Spoiler

DVC.JPG

 

When I check nvdmi.inf

Spoiler

NVDMI.JPG

 

 

could I enable optimus ?

Share this post


Link to post
Share on other sites
5 hours ago, gharimanto said:

Hi AgMR

 

what's your system ? Did you use Setup 1.30 ?

 

With optimus profile, I cannot activate DSR and some nvidia features

 

Hello @gharimanto


my system rig will be add soon with new thread :D

I dont use Setup 1.30 everything works fine w/o it.

unfortunately DSR + some nvidia features not available when u r on optimus, but for DSR if u want it there's another trick to add custom resolution on optimus (will be added)

ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

1 hour ago, gharimanto said:

I change switch my PE4C 3.0 

SW 1 = 2

SW 2 = 1

For different purpose

 

And this happen

  Reveal hidden contents

DVC.JPG

 

When I check nvdmi.inf

  Reveal hidden contents

NVDMI.JPG

 

could I enable optimus ?


Yes this line only avaliable with hot fix driver (368.95) for (1060 Reference Card i guess)
%NVIDIA_DEV.1C03.068B.1028% = Section130, PCI\VEN_10DE&DEV_1C03&SUBSYS_068B1028 

so theres only one line for new gpu (1060) for just one section [130]

 

yes theres ability to enable optimus 


so special thing here u need also modify this section cuz its not have Optimus

 

just in this line change 068B to 0532 and SUBSYS_068B1028 to SUBSYS_05321028

 

also change in [Strings] to >> NVIDIA_DEV.1C03.0532.1028 = "NVIDIA GeForce GTX 1060 6GB"

 

then go to section [130] and add >>  NVSupportOptimus = 1      under (NVSupportGFExperienceUDA = 1)

 

after that go modify (nv_dispi.inf) as described above your section will be [Section062]

 

I think u will be the frist one in the world run eGPU GTX 1060 optimus :encouragement:

 

Edited by AGmR

Share this post


Link to post
Share on other sites

Hey @AGmR,  I appreciate how thorough you are with your answers.  Really helpful.  

 

So I installed the drivers by following your guide (copied all the sections, with NVSupportOptimus = 1, disabled driver signing, etc) and that didn't fix the problem.  Then I checked the "Events" section of my gpu, and it turns out it didn't even use nvaoi.inf.  It actually used nvpcdi.inf

 

gpu-status.jpg

 

So I'll try to repeat the process, but using nvpcdi.inf instead.  

Share this post


Link to post
Share on other sites

@UncleGravity  , yes sry i forget to tell u also in previous reply to put the new line for ur gpu under [NVIDIA_Devices.NTamd64.10.0] in nvaoi.inf

 

                               %NVIDIA_DEV.XXXX.YYYY.ZZZZ% = Section000, PCI\VEN_10DE&DEV_XXXX&SUBSYS_YYYYZZZZ  

 

                                           *Change XXXX,YYYY,ZZZZ & number section


Regards! :)

Share this post


Link to post
Share on other sites

@AGmR I modified nvpcdi.inf (since this is the file that gets installed).  My process was:

 

First I modified nv_dispi.inf and added the lines from your guide. 

Then I opened nvpcdi.inf, which already has my exact card in the list, all the same numbers (PCI\VEN_10DE&DEV_13C2&SUBSYS_136619DA)

I noted the section (it was section 006)

I added these lines to the main part of Section006

    NVSupportOptimus = 1, 

    NVOptimusCheckCookie = 1
    NVOptimusHCloneDisabled = 1

I modified the name of my card in the Strings section to make sure it works in the end.

Installed drivers successfully and I can see the new name I put in device manager.

 

But it still doesn't work.  The optimus icon shows up, but it's always "off", and my card always says "Inactive" when I mouse over the icon.  So even if I tell nvidia to use the "High Performance NVIDIA Processor" by default, it never actually does it.

Share this post


Link to post
Share on other sites

@UncleGravity yes ur steps great, so weird still optimus refuse to work. I think theres something missing maybe :02: or ur system just hate optimus  lol.

 

Look don't give up there's another final way to get ur games or applications works under optimus more easy than this, will be explain..

Share this post


Link to post
Share on other sites

@AGmR IT WORKED!  I'm so psyched right now! 

 

Ok ok, these were my steps, I think they are a mix of your instructions, and the ones you linked from @utopian201.  Both of you are awesome.

 

If I install my drivers without modification, a file called nvpcdi.inf was being installed.  I found this out by looking at the "Events" panel in the properties for my eGPU in the Device Manager.

I opened nvpcdi.inf and found my exact card in there, so I commented out the two lines that reference my card:

 

%NVIDIA_DEV.13C2.1366.19DA% = Section006, PCI\VEN_10DE&DEV_13C2&SUBSYS_136619DA  (in the [NVIDIA_Devices.NTamd64.10.0] section)

NVIDIA_DEV.13C2.1366.19DA = "NVIDIA GeForce GTX 970" (In the [Strings] section)

 

Also opened up  nv_dispi.inf and commented out the other two lines that reference my card type (I just ctrl+F my DEV number, which is 13C2)

 

%NVIDIA_DEV.13C2%           = Section045, PCI\VEN_10DE&DEV_13C2 (In the [NVIDIA_Devices.NTamd64.10.0] section)

NVIDIA_DEV.13C2 = "NVIDIA GeForce GTX 970" (In the [Strings] section)

 

Finally, since my vendor .ini (Apple), did not include my type of card, I just went through all of the ones you listed and found my type of card (13C2) in nvdmi.inf (for Dell, so same as yours).

 

I ctrl-F for my DEV# and found the section that has NVSupportOptimus = 1 (section 113 in my case)

 

So I added:

%NVIDIA_DEV.13C2.1366.19DA% = Section113, PCI\VEN_10DE&DEV_13C2&SUBSYS_136619DA (to the [NVIDIA_Devices.NTamd64.10.0] section)

NVIDIA_DEV.13C2.1366.19DA = "Zotac NVIDIA GTX 970 eGPU" (To the [Strings] section, I modified the name)

 

Then I ran DDU on my nvidia drivers, restarted, installed everything, restarted again and boom.  Everything worked.

 

I'm still curious about the "easier" solution you mentioned.  Maybe it makes more sense than what I just did haha.

 

EDIT:

I'm using nVidia drivers 368.81 Windows 10 64-bit, and Iris Pro drivers 15.40.25.4463.  These steps might not make sense for other versions.

 

Edited by UncleGravity

Share this post


Link to post
Share on other sites

@UncleGravity ooo im rly so glad its worked, xD i think nvdmi.inf is the king here haha

 

so now i suppose u got in event >> Device installed (nvdmi.inf) << , right?

 

& bout another solution i will post it later dnt wry, i was just wanna this guide to makes more deep in modified ⇑ ⇑

 

Regards!  :)

  •  
Edited by AGmR

Share this post


Link to post
Share on other sites

hello,please mod my inf?I am noob :)

 

PCI\VEN_10DE&DEV_1402&SUBSYS_32081462  (gtx950 desktop version)

Edited by franck

Share this post


Link to post
Share on other sites
4 hours ago, franck said:

hello,please mod my inf?I am noob :)

 

PCI\VEN_10DE&DEV_1402&SUBSYS_32081462  (gtx950 desktop version)

 

Hi franck :)

 

Here U go >> https://www.dropbox.com/s/ic5xcpdf2fv8tsx/franck.rar?dl=0       modified for latest driver only (372.54)

 

Frist : Disable Disable Driver Signature as described >> Click Here

 

Second : replace both files into setup folder then hit setup.exe 

 

& lemme knw results 

 

Regards! :-)

Share this post


Link to post
Share on other sites
6 hours ago, AGmR said:

 

Hi franck :)

 

Here U go >> https://www.dropbox.com/s/ic5xcpdf2fv8tsx/franck.rar?dl=0       modified for latest driver only (372.54)

 

Frist : Disable Disable Driver Signature as described >> Click Here

 

Second : replace both files into setup folder then hit setup.exe 

 

& lemme knw results 

 

Regards! :-)

 

hi AGmR sorry not work :( I have clevo notebook

not found my card video

I hve replace two files in folder display.driver 

Screenshot (6).png

Edited by franck

Share this post


Link to post
Share on other sites

@franck , Can u install driver normally (desktop 372.54 ) w/o modded inf and tell me wat driver installed (...inf) in Events tab.

Share this post


Link to post
Share on other sites

Can anyone help me?

I did everything right, my egpu is recognized and functional except by the fact that when i try to play any game it only use intel hd and don't use the GTX.

I'm trying to play using my internal monitor, is it possible? With an external monitor the GTX Works.

 

 

picture1.jpg

picture2.jpg

Share this post


Link to post
Share on other sites

Thanks AGmR, this method really worked for me. 

The only problem was that my PC has a dedicated graphic card(Nvidia 820m), i have to disable it first and now everything is working fine.

I'm Using GTX 650 and my notebook is Asus X450LD.

Share this post


Link to post
Share on other sites

Hi,

Can u please help me? :rofl:

 

I have an eGPU with GTX1060 working just fine on a external monitor, but I can't made it work in the notebook screen, i followed yours instructions but didn't work.:(

 

Is there another way?  My notebook is an Asus G75VW.

 

Thx!

 

 


1.jpg

2.jpg

Share this post


Link to post
Share on other sites

Hi folks

 

I am trying to enable Optimus on my iMac, as of now i have the following :

- Akitio Thunder 2 

- EVGA GTX 1050 Ti SC

- Windows 10 Home

- booting the iMac with apple_set_os.efi, in order to have the Iris enabled so i can see :)

 

On this setup, the driver (378.78, latest) is installed from nv_dispi.inf section 088, i checked and no NVSupportOptimus exists in that section.

 

I searched in nvdmi.inf (because this is the only INF that has anything with GTX 1050 Ti ) and for my card i can only find these entries which none of them have Optimus enabled

 

%NVIDIA_DEV.1C82.068B.1028% = Section277, PCI\VEN_10DE&DEV_1C82&SUBSYS_068B1028 
%NVIDIA_DEV.1C82.0790.1028% = Section260, PCI\VEN_10DE&DEV_1C82&SUBSYS_07901028 
%NVIDIA_DEV.1C82.079A.1028% = Section275, PCI\VEN_10DE&DEV_1C82&SUBSYS_079A1028 

 

My device should be 1C82.6253.3842

 

 

 

However, connecting the same setup to my Macbook pro retina late 2013 works like a charm and Optimus is enabled, and surprise, the driver is loaded from the same nv_dispi.inf.

 

Any ideas how to enable it on iMac ? Is there other check that gives result that iMac is not notebook platform and disables Optimus ?

 

Thanks

capture1.JPG

capture2.JPG

Edited by t0x
added data

Share this post


Link to post
Share on other sites

I have a desktop with a gtx 1060 the only file that shows up in logs is nv_dispi.inf and also in it i found my card in 2 sections (Section 135 and Section 136). I edited them both, installed the driver and still optimus is not enabled. What i did wrong?
Also dirver version is 388.59

Spoiler

4IHnKSD.png

Edited by DevilSoul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.