Jump to content

14" Dell Latitude E6430 - Performance Upgrades and System Mods

Recommended Posts

16 minutes ago, Devo552 said:

As long as it is docked, or plugged in, you should not. Depending on what you are doing, it may run a couple degrees warmer than now. 

If you are not plugged in or docked and running on battery alone, it will drain faster due to the higher demand by the processor.

If you are running games, then yes it will run hotter than usual. 

My E6430 has a 3rd gen i7 in it now, and I run a R9 380 eGPU with it. And while running high demand games such as Monster Hunter top graphics settings and Need For Speed Payback, my computer does run hotter than normal, but the original fan and cooling unit are enough to keep it at a manageable level.


Thank you for the information, i greatly appreciate it. 

Link to comment
Share on other sites

  • 8 months later...
  • 2 weeks later...

Hi, does anyone know the pointerstick (btw G,H,B) on keyboard is related with the upper mouse buttons (the 3 buttons below the spacebar) ?


i had an old kb that has a pointerstick, and the lower 2 mouse buttons below touchpad, and the 3 mouse buttons above touchpad were working fine.


i decided to change the kb with an illuminated one (that one do not have pointerstick.),

i changed kb. and gave the old one away.

Now the 3 upper buttons do not work ???


best regards.

Link to comment
Share on other sites

  • 2 weeks later...
On 5/25/2020 at 12:04 AM, squareguy said:

any interest in removing Intel ME from the e6430?  I was successful in doing this with A24 BIOS using https://github.com/corna/me_cleaner along with information from this thread.

What part of the guide did you follow to do this?  I have two e6430's I'd like to do this to..

Link to comment
Share on other sites

  • 2 weeks later...

Dell has been disabling the management engine themselves, by hand apparently. the unit I have is on the a17 bios and it has a sticker on the bottom that says 'ME DISABLED" . Along with that, the base clock cannot be manipulated. Id like to reenable that option. How do I "RE-ENABLE" the management engine? I like breaking the rules. I dunno why you would disable it yourself. Unless you are the man....jk. lol..

Link to comment
Share on other sites

  • 4 months later...
  • 1 year later...
On 9/18/2015 at 4:52 PM, timohour said:

As Tech Inferno Fan noted

EC - mPCIe --> Southbridge Gen2

dGPU-->          Northbridge Gen 3

dGPU on the Gen3 northbridge is wired directly to the CPU as you can see here pg.115.

By the way Gen 3 uses a more efficient 128b/130b encoding resulting in a real bandwith per pair of 984 MB/s out of the 8 GT/s, not 8b/10b. pg.30

On pg.30 you can also see that the configuration with the more Gen3 capable PCIe ports is 1x8 and 2x4, a total of 3 ports. That's what PEG0/1/2 is. In our E6430 it is set as 1x16 and it is dedicated for the dGPU which is the only port you can set to Gen3 speed. (NVS5200M is only Gen2 capable so it is mostly a waste). There are no systems AFAIK that sport an EC or mPCIe port rated Gen3.

EDIT : Just for proof I tried some fiddling with the PEG0 port speed Gen.

Setting variable 0x1f5 to Gen1 will result in the following result


While on default it is set to Gen2 will result to this


Setting this to Gen3 (although it is useless since NVS5200M is just Gen2 capable would have some strange effect on the card clocks. It would clock @ 202MHz and it would have terrible performance... I had to clear CMOS to revert to default clocks and Optimus to work as normal.

Hi! I know this thread is probably dead, but I was interested in connecting my GTX 780 to my E6430 w/NVS 5200m via ExpressCard. What's the highest bandwidth I can do through that and would you recommend that I get an EXP GDC? Thank you.

Link to comment
Share on other sites

  • 1 year later...


I know this is a old thread but i got a problem that can't findo anywhere. My NVS 5200 stop to show on bios and i simply can't install anu driver (besides the Micorosft basic displau). GPU-Z detects his presence however without any memory or clock frequency. Is it dead? Can i revive it by reflashing his firmware (wich is another problem: can't find it anywhere). Any help will be much apreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.