Jump to content
EwinRacing Flash Series Gaming Chairs
Valeral

MSI GX60 Laptop overclock

Recommended Posts

Were you ever able to make this work while the IGPU is under load? Is it even possible while keeping it under TDP? Your help is very much needed if you were successful in doing so. All my attempts at this bring my 5750m to a stutter when the GPU is in use. Also, i read that you were able to lower CAS latency..? How did you do this? I didnt want to bring up an older thread but i had no other way of contacting you and many questions that you have the knowledge about.

To prevent GPU stutter set the GPU clock with overdrive. It can't be overclocked, but setting it to turbo or higher will lock it to its turbo clocks.

Setting CAS latency sometimes causes a crash, which is likely why it isn't normally available. I find it only ever works if I set it with the other timings loose, then I tighten the other timings after tightening CAS.

To lower CAS:

1. write 0x0001F5F8 to D0F0xB8

2. write 0xFF to lowest byte of D0F0xDC

3. write desired CAS latency directly to the memory at location 0xF80C2200 bits 0-4

4. set bit 0 of 0xF80C110C high

5. write desired CAS latency again to 0xF80C2200 bits 0-4

6. write 0x00 to lowest byte of D0F0xDC

The direct memory writes in steps 3, 4, and 5 is needed since BAR-EDIT does not support writing to extended PCI address space on AMD systems.

This sequence also locks the northbridge to 1.6ghz instead of the normal 1.3ghz when the IGP is active. Overdrive will reset the northbridge to default after you use it to tighten the other timings, but you can set it back to 1.6ghz again with steps 1 and 6. Locking the NB clock is actually a bigger gain than improving CAS.

Share this post


Link to post
Share on other sites
To prevent GPU stutter set the GPU clock with overdrive. It can't be overclocked, but setting it to turbo or higher will lock it to its turbo clocks.

Setting CAS latency sometimes causes a crash, which is likely why it isn't normally available. I find it only ever works if I set it with the other timings loose, then I tighten the other timings after tightening CAS.

To lower CAS:

1. write 0x0001F5F8 to D0F0xB8

2. write 0xFF to lowest byte of D0F0xDC

3. write desired CAS latency directly to the memory at location 0xF80C2200 bits 0-4

4. set bit 0 of 0xF80C110C high

5. write desired CAS latency again to 0xF80C2200 bits 0-4

6. write 0x00 to lowest byte of D0F0xDC

The direct memory writes in steps 3, 4, and 5 is needed since BAR-EDIT does not support writing to extended PCI address space on AMD systems.

This sequence also locks the northbridge to 1.6ghz instead of the normal 1.3ghz when the IGP is active. Overdrive will reset the northbridge to default after you use it to tighten the other timings, but you can set it back to 1.6ghz again with steps 1 and 6. Locking the NB clock is actually a bigger gain than improving CAS.

I have tried locking the iGPU with overdrive to its turbo frequency but when i load up a game cpu usage instantly goes to 100 percent and frame rates drop tremendously from what they would be without locking with BAR-edit probably 20 frames lessl. It works great for strictly cpu tasks though. Without the lock cpu drops to 2.1 ghz or less unless I turn off turbo core and then it stays closer to 2.5 ghz but still drops down to 2.1 . I would really love to be able to run this thing while the IGPU is loaded at a constant 3.2 but I a m not sure whats going on. I don t have the dedicated card its strictly the 35watt APU.

I set a CAS latency of 9 on bit 0-4 but after checking my timings CAS reads 5 and all the rest were lowered with the timings of 5(tRCD), 6(tRP), 12(tRAS) ,17(tRC). Are these real readings? Both AOD and CPUZ show this.

Edit- My screw up. Only problem I seem to be having is I can not write to D0F0xDC. I get it to work about 10 percent of the time the rest of the time it crashes my laptop. Any tips? I have tried setting timings lose but it still will crash even if i set CAS higher then 11. Nb state doesnt seem to be locking to 1600 either . Is this because I am not able to write 0xFF on step 2? Is there something that I am doing wrong or another way around this?

Do you have an idea why the turbo lock is causing so much problems? All 4 cores should be able to lock to p state 1 with know problems This thing is backwards from intel. It clocks up on idle to 3.2-3.5 ghz but when i really need the speed it clocks it self down.

Edit 2- I finally have CAS lowered without crashes (took me a while to figure it out after numerous crashes). I am using 9-9-9-24 and it seems to be working great. Thank you for this more people should know about it. Now if i could only figure out whats going on with the frequency lock this wouldnt be such a bad laptop.

I have one more question. Is it possible to overclock the RAM to 1866? The 5750m supports up to 1866 and my specific laptop actually was supposed to come with it but come to find put HP lied on the specs. Its DDR3 1600 ram.

Share this post


Link to post
Share on other sites
To prevent GPU stutter set the GPU clock with overdrive. It can't be overclocked, but setting it to turbo or higher will lock it to its turbo clocks.

Setting CAS latency sometimes causes a crash, which is likely why it isn't normally available. I find it only ever works if I set it with the other timings loose, then I tighten the other timings after tightening CAS.

To lower CAS:

1. write 0x0001F5F8 to D0F0xB8

2. write 0xFF to lowest byte of D0F0xDC

3. write desired CAS latency directly to the memory at location 0xF80C2200 bits 0-4

4. set bit 0 of 0xF80C110C high

5. write desired CAS latency again to 0xF80C2200 bits 0-4

6. write 0x00 to lowest byte of D0F0xDC

The direct memory writes in steps 3, 4, and 5 is needed since BAR-EDIT does not support writing to extended PCI address space on AMD systems.

This sequence also locks the northbridge to 1.6ghz instead of the normal 1.3ghz when the IGP is active. Overdrive will reset the northbridge to default after you use it to tighten the other timings, but you can set it back to 1.6ghz again with steps 1 and 6. Locking the NB clock is actually a bigger gain than improving CAS.

CAS latency will not work anymore. When i go to location 0xF80C2200 it is set to 00000608 automatically now but cas is not 8 and the other timings are obviously not 0 and 6. When i try to write CAS nothing changes. On step 2 and 6 do you mean write to D0F0xBC, because that is the one that changes NB for me although when when i write it 0x00 it changes Nb state to 1200 and not 1600. In fact trying to write anything changes it to 1.2ghz. I can lock Nb to 1.6 with PScheck but it show incorrect voltages and when looking at BAR-edit bit 0-7 are not cleared. If i write 1 on bit 3 at location F80C220C CAS will change to 5 but memory scores are actually lower

Share this post


Link to post
Share on other sites
To prevent GPU stutter set the GPU clock with overdrive. It can't be overclocked, but setting it to turbo or higher will lock it to its turbo clocks.

Setting CAS latency sometimes causes a crash, which is likely why it isn't normally available. I find it only ever works if I set it with the other timings loose, then I tighten the other timings after tightening CAS.

To lower CAS:

1. write 0x0001F5F8 to D0F0xB8

2. write 0xFF to lowest byte of D0F0xDC

3. write desired CAS latency directly to the memory at location 0xF80C2200 bits 0-4

4. set bit 0 of 0xF80C110C high

5. write desired CAS latency again to 0xF80C2200 bits 0-4

6. write 0x00 to lowest byte of D0F0xDC

The direct memory writes in steps 3, 4, and 5 is needed since BAR-EDIT does not support writing to extended PCI address space on AMD systems.

This sequence also locks the northbridge to 1.6ghz instead of the normal 1.3ghz when the IGP is active. Overdrive will reset the northbridge to default after you use it to tighten the other timings, but you can set it back to 1.6ghz again with steps 1 and 6. Locking the NB clock is actually a bigger gain than improving CAS.

Im at a loss, after doing some stress testing with OCCT locked in turbo, framerate stays steady for the first 30 seconds or so then drops down to about 10 fps. When the gpu

is not locked i can see its voltage and frequencies drop, which cause the huge drop in performance. The strange thing though is when I lock the gpu to its turbo the framerate

drop still happen. When the frame rate plunges i took a look in task manager and it shows my cpu usage up to 80-100 pecent but there is no process using the cpu. Its

almost like its still trying to throttle but it cant because its locked. Do you have any idea whats going on?

I thought it may be temperatures but everything stays pretty cool even with very heavy load. 59 degrees c or less. Its kind of like the computers not getting enough power or something. When the cpu is clocked high the gpu tries to clock low and vice versa. Very annoying .I kind of wish i would have went with the hd 4600 but everybody told me the 8650g would blow that out of the water.

Share this post


Link to post
Share on other sites

khenglish cheers for all your contribution and expertise on this subject. I've got a gx70 and I thought I followed the jpg pretty accurately but it actually dropped my clocks on cpuid to 1.5ghz and made my system really unstable. also increased average temps on cpu by about 10 degrees C on hwmonitor. I was using a win 8 edition of the gx70, does bar-edit not support this or am I doing something wrong? Any advice would be great cheers mate.

EDIT: nvm I was using the wrong power settings. it's working now, it just overheats and crashes instead! i'll work on that undervolt now and see if I can't find a happy medium, cheers again =]

Share this post


Link to post
Share on other sites
Im at a loss, after doing some stress testing with OCCT locked in turbo, framerate stays steady for the first 30 seconds or so then drops down to about 10 fps. When the gpu

is not locked i can see its voltage and frequencies drop, which cause the huge drop in performance. The strange thing though is when I lock the gpu to its turbo the framerate

drop still happen. When the frame rate plunges i took a look in task manager and it shows my cpu usage up to 80-100 pecent but there is no process using the cpu. Its

almost like its still trying to throttle but it cant because its locked. Do you have any idea whats going on?

I thought it may be temperatures but everything stays pretty cool even with very heavy load. 59 degrees c or less. Its kind of like the computers not getting enough power or something. When the cpu is clocked high the gpu tries to clock low and vice versa. Very annoying .I kind of wish i would have went with the hd 4600 but everybody told me the 8650g would blow that out of the water.

I never had any issues with CPU usage unless I also disabled pb1. Make sure you aren't accidentally doing that with the wrong values.

As for GPU downclocking, you can prevent that by trying to set an overclock in overdrive or afterburner or whatever you prefer. It doesn't actually set an overclock, but it will lock the GPU to the top turbo speed.

Share this post


Link to post
Share on other sites
I never had any issues with CPU usage unless I also disabled pb1. Make sure you aren't accidentally doing that with the wrong values.

As for GPU downclocking, you can prevent that by trying to set an overclock in overdrive or afterburner or whatever you prefer. It doesn't actually set an overclock, but it will lock the GPU to the top turbo speed.

Its not the wrong values. I thought it my be a bar edt problem with windows 8 but the same happens with rw everything and ps check. Thought maybe i was being held back by the 65 watt power supply but i tried a 90 watt and that didnt help. The only thing that does help is an undervolt but it still lowers frame rate by about 15, without the undervolt it freezes the computer as soon as i load up a game, works fine for anything else though. I think if i could undervolt the igp i could make this work but as far as i know there is no way to do this. All i can do is change the default p1 state to 2.4 instead of 2.1 with pscheck so it wont down clock so low and keep turbo enabled. Do you know the msr number to undervolt the northbridge? i think if i could do this a and undervolt the IGP to its idle state it might work. 1.175v seems to be ridiculously high for 720mhz. If that wouldnt work i guess this laptop isnt capable of using turbo with any sort it of load on the igp. Without locking the igp it locks to 300 mhz so it seems to be a power draw problem. It is not heat problem.

Share this post


Link to post
Share on other sites
Its not the wrong values. I thought it my be a bar edt problem with windows 8 but the same happens with rw everything and ps check. Thought maybe i was being held back by the 65 watt power supply but i tried a 90 watt and that didnt help. The only thing that does help is an undervolt but it still lowers frame rate by about 15, without the undervolt it freezes the computer as soon as i load up a game, works fine for anything else though. I think if i could undervolt the igp i could make this work but as far as i know there is no way to do this. All i can do is change the default p1 state to 2.4 instead of 2.1 with pscheck so it wont down clock so low and keep turbo enabled. Do you know the msr number to undervolt the northbridge? i think if i could do this a and undervolt the IGP to its idle state it might work. 1.175v seems to be ridiculously high for 720mhz. If that wouldnt work i guess this laptop isnt capable of using turbo with any sort it of load on the igp. Without locking the igp it locks to 300 mhz so it seems to be a power draw problem. It is not heat problem.

GPU can be undervolted. I never did it much though since it doesn't improve temps much. The GPU pulls much less power than the CPU.

It might be a while till I get back to you on how to undervolt the IGP. I completely forgot how to do it and am busy with other things. Beware that this undervolts the memory controller as well.

You did try setting the IGP clock right? As I said you need to set it to prevent it from downclocking. Just try setting it to anything at or above 720 and it will lock to 720.

Share this post


Link to post
Share on other sites
GPU can be undervolted. I never did it much though since it doesn't improve temps much. The GPU pulls much less power than the CPU.

It might be a while till I get back to you on how to undervolt the IGP. I completely forgot how to do it and am busy with other things. Beware that this undervolts the memory controller as well.

You did try setting the IGP clock right? As I said you need to set it to prevent it from downclocking. Just try setting it to anything at or above 720 and it will lock to 720.

Yes I am setting the igp to its turbo clcoks with no better results then if i were to leave it alone. It still performs like its at its idle speed but igp is at 1.175v at 720mhz and cpu locked at 3.2. Ive tried this on another a10 and it works flawlessly.

If you do ever get the time please get back to me on that. This is about the last thing i can think of that might make this work.

Share this post


Link to post
Share on other sites
Yes I am setting the igp to its turbo clcoks with no better results then if i were to leave it alone. It still performs like its at its idle speed but igp is at 1.175v at 720mhz and cpu locked at 3.2. Ive tried this on another a10 and it works flawlessly.

If you do ever get the time please get back to me on that. This is about the last thing i can think of that might make this work.

Was the other A10 a trinity? Maybe this only works on trinity and not richland. Perhaps richland power management does not like being stuck over the power limit.

If so them trinity is preferable over richland, unless you get an unlocked richland (very rare, ES only).

Share this post


Link to post
Share on other sites
Was the other A10 a trinity? Maybe this only works on trinity and not richland. Perhaps richland power management does not like being stuck over the power limit.

If so them trinity is preferable over richland, unless you get an unlocked richland (very rare, ES only).

It was richland the difference being it had a dedicated card. Maybe with the dedicated card the majority of the power can be put to the cpu.

if you monitor it without locking anything, when the cpu clocks up to turbo the igp down clocks and when the igp clocks up the cpu clocks down vice versa. It seems impossible for both to be in turbo at the same time,

With the dedicated card the igp doesn't have to work as hard and share power, balancing out the apu to stay under tdp?

Id really like somebody to try this if they do not have a dedicated card to see if this works for them or get the same results i am getting. Could it be possible for an OEM to mess with power management features in order to keep heat down or something?

I think if i can lower the igp turbo voltage to its idle voltage i can lower power draw enough to trick it to running a fixed turbo on both.

Share this post


Link to post
Share on other sites
Was the other A10 a trinity? Maybe this only works on trinity and not richland. Perhaps richland power management does not like being stuck over the power limit.

If so them trinity is preferable over richland, unless you get an unlocked richland (very rare, ES only).

Khenglish, when locking to 3.2 if I unplug the charger then plug back In see a huge gain in performance like it should, only problem is after about two minutes framerate drops again. Cpu total power is upwards to 50 watts when i do this, when performance starts to drop cpu power falls to something in the low 20s. I know your busy but can you think of anyway to prevent this?

I was also able to get into some hidden settings in the bios with advanced options and a few power options. Do you think something in the bios could be the problem?

Share this post


Link to post
Share on other sites
Khenglish, when locking to 3.2 if I unplug the charger then plug back In see a huge gain in performance like it should, only problem is after about two minutes framerate drops again. Cpu total power is upwards to 50 watts when i do this, when performance starts to drop cpu power falls to something in the low 20s. I know your busy but can you think of anyway to prevent this?

I was also able to get into some hidden settings in the bios with advanced options and a few power options. Do you think something in the bios could be the problem?

Interesting. It looks like Richland power management has other means of dropping power draw other than P-states, unlike trinity. I'm guessing Richland power management has clock modulation control. I don't know how to prevent this on an AMD system.

You cannot change power settings unless you have an ES CPU. You can try in BIOS, but it shouldn't work.

Share this post


Link to post
Share on other sites
Interesting. It looks like Richland power management has other means of dropping power draw other than P-states, unlike trinity. I'm guessing Richland power management has clock modulation control. I don't know how to prevent this on an AMD system.

You cannot change power settings unless you have an ES CPU. You can try in BIOS, but it shouldn't work.

Yep sadly i guess your right. Locking to Pb2 provides the same results.

Really appreciate the time though man.

Share this post


Link to post
Share on other sites
Interesting. It looks like Richland power management has other means of dropping power draw other than P-states, unlike trinity. I'm guessing Richland power management has clock modulation control. I don't know how to prevent this on an AMD system.

You cannot change power settings unless you have an ES CPU. You can try in BIOS, but it shouldn't work.

Wait, i got it working somehow, and not sure exactly how i did it. I disabled turbo and APM with amdmsrtweaker and was playing around with pscheck. I think whatever i did in pscheck somehow enabled turbo again but its still faded and disabled in overdrive. I cleared the bits in bar edit and what do you know its finally working. I see a significant gain in performance with playable framerates on a lot of games. Not to bad for the 8650g . Scared to turn the computer off now because i am not sure why its working

Edit- I have been able to reproduce it. If I turn off turbo with overdrive and then turn it back on with amdmsrtweaker then unplug the charger and plug back in the lock sticks and

performs as should. I am not sure why but if turbo is grayed out in overdrive and i do this it works. Very weird. Now temperatures is the problem. I have never seen it go passed 61

degrees c with an undervolt, but now temperatures reach close to 80. I am just glad its finally working though I wish there was a more reliable way of doing it.

Share this post


Link to post
Share on other sites

Hello, I am a complete newbie when it comes to overclocking or locking CPUs. I have MSI GX60 Destroyer (AMD A10 5750).. I was able to lock it to 3.15 to 3.2 GHz using Bar EDIT... but can I lock it to 3.5Ghz? Are there any more tweaks I can do using other softwares?

Share this post


Link to post
Share on other sites
Hello, I am a complete newbie when it comes to overclocking or locking CPUs. I have MSI GX60 Destroyer (AMD A10 5750).. I was able to lock it to 3.15 to 3.2 GHz using Bar EDIT... but can I lock it to 3.5Ghz? Are there any more tweaks I can do using other softwares?

No you cant lock it to 3.5 ghz , you need an engineering sample (ES) of AMD A10 5750m processor which have unlocked multipliers

Share this post


Link to post
Share on other sites

This multiplier lock does cause problems when the IGP is active since the CPU will try to exceed its TDP, which does not work. This causes stuttering in games, but for pure CPU tasks this works fine. I'm trying to figure out how to get the CPU to recalculate power draw after lowering the voltage to prevent this stutter.

Hi, I have a10 4600m es, and i cant overclock or locking the cpu clocks. I read all things but i can't do it. Bar-edit, pscheck, amdmsrtweaker etc. If i lock or overclock the cpu, games stutter or mouse lagging after overclock. I can turn off apm and turbo. Then simple, increase the cpu clock and increasing voltage for P0. The cpu works normal, for example at 2500mhz or 2700mhz, but in game low fps. The cpu and gpu can't work together, like you said.

I have a simple rig, a10 4600m es and 7670m. I am using 7670m at games. Do you have any idea, what is the problem? Not enought power? Limiting TDP? And sometimes if i success the oc, like 2900mhz(or locking 2400-2500), in game fps is good but stuttering, and characters moves fast, like 1,5x. I can't figure out. Ram things, nb vid? What can i do? I have es cpu but i give up for overclock, just want to locking 2,7ghz. Is this impossible to with cpu+gpu? Do you have any idea, what can i try?

Share this post


Link to post
Share on other sites
Hi, I have a10 4600m es, and i cant overclock or locking the cpu clocks. I read all things but i can't do it. Bar-edit, pscheck, amdmsrtweaker etc. If i lock or overclock the cpu, games stutter or mouse lagging after overclock. I can turn off apm and turbo. Then simple, increase the cpu clock and increasing voltage for P0. The cpu works normal, for example at 2500mhz or 2700mhz, but in game low fps. The cpu and gpu can't work together, like you said.

I have a simple rig, a10 4600m es and 7670m. I am using 7670m at games. Do you have any idea, what is the problem? Not enought power? Limiting TDP? And sometimes if i success the oc, like 2900mhz(or locking 2400-2500), in game fps is good but stuttering, and characters moves fast, like 1,5x. I can't figure out. Ram things, nb vid? What can i do? I have es cpu but i give up for overclock, just want to locking 2,7ghz. Is this impossible to with cpu+gpu? Do you have any idea, what can i try?

Your problem is the clock control on hardware lavel. There is no way to avoid it. But you can trick it. Use amdmsrtweaker to assign the same values to all Pstates. (example for syntax: AmdMsrTweaker.exe turbo=1 APM=1 P6=4@0.830 P5=9@1.00 P4=14@1.15 P3=17@1.25 P2=20@1.36 P1=20.5@1.4125 P0=21@1.425)By doing it there will be the same frequency and voltage in all Pstates and there will be no matter in which Pstates your CPU is. Use WIn8 or 10 to avoid synch problems after overclocking. Win7 doesn't support properly mobile amd cpus.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.