Jump to content
Sign in to follow this  
Zahja

GTX 970 Modded inf not working 378.66-378.92

Recommended Posts

My apologies if this is the wrong section I was hoping to find some help!

 

I have a "NVIDIA GeForce GTX 970", I am trying to upgrade my driver to any of the recent three; 378.66, 378.78, 378.92, as is required to play the new Mass Effect game. I  have my graphics card on a custom PC, with ASUS, Windows 10 (version 1607), my current graphics driver is 376.33. Previously I hard a hard time installing new drivers but could do so with DDU and a clean install.

 

These new drivers (yes i've checked all three) give the message: "This NVIDIA graphics driver is not compatible with this version of Windows.

This graphics driver could not find compatible graphics hardware."

 

I've followed this guide  to modify my inf, I modified the (Asus =) nvami.inf, and nv_dispi.inf with my hardware ID "PCI\VEN_10DE&DEV_13C2&SUBSYS_29743842" as the guide says so and tried to launch the driver using this guide

It hasn't fixed anything unfortunately I am still getting the same message and am sort of lost what to do next? Any help would be greatly appreciated!

Edited by Zahja

Share this post


Link to post
Share on other sites

Did you disable driver signature enforcement?


From MS anwers:

a. Press the Win + C and click on PC settings.

b. Switch over to the “Update & recovery” section.

c. Then click on the Recovery option on the left hand side.

d. Once selected, you will see an advanced startup section appear on the right hand side. You will need to click on the “Restart now” button.

e. Once your Computer has rebooted you will need to choose the Troubleshoot option.

f. Then head into Advanced options.

g. Then Startup Settings.

h. Since we are modifying boot time configuration settings, you will need to restart your computer one last time.

I. Here you will be given a list of startup settings that you can change. The one we are looking for is “Disable driver signature enforcement”. To choose the setting, you will need to press the F7 key.



Or, Are you sure the strings has proper formatting ?

mine look as:

Spoiler

[NVIDIA_Devices.NTamd64.6.1]
%NVIDIA_DEV.1618%           = Section024, PCI\VEN_10DE&DEV_1618


[NVIDIA_Devices.NTamd64.6.2]
%NVIDIA_DEV.1618%           = Section025, PCI\VEN_10DE&DEV_1618


[NVIDIA_Devices.NTamd64.6.3]
%NVIDIA_DEV.1618%           = Section113, PCI\VEN_10DE&DEV_1618


[Strings]
DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1"
NVIDIA = "NVIDIA"
NVIDIA_A = "NVIDIA"
NVIDIA_DEV.1618 = "NVIDIA GeForce GTX 970M"

 

 

 

%NVIDIA_DEV.1618.7102.1558% = Section064, PCI\VEN_10DE&DEV_1618&SUBSYS_71021558

%NVIDIA_DEV.1618.7102.1558% = Section063, PCI\VEN_10DE&DEV_1618&SUBSYS_71021558

NVIDIA_DEV.1618.7102.1558 = "NVIDIA GeForce GTX 970M"

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
7 hours ago, aaronloveweed said:

Did you disable driver signature enforcement?
 

I. Here you will be given a list of startup settings that you can change. The one we are looking for is “Disable driver signature enforcement”. To choose the setting, you will need to press the F7 key.



Or, Are you sure the strings has proper formatting ?

mine look as:

 

  Reveal hidden contents

[NVIDIA_Devices.NTamd64.6.1]
%NVIDIA_DEV.1618%           = Section024, PCI\VEN_10DE&DEV_1618


[NVIDIA_Devices.NTamd64.6.2]
%NVIDIA_DEV.1618%           = Section025, PCI\VEN_10DE&DEV_1618


[NVIDIA_Devices.NTamd64.6.3]
%NVIDIA_DEV.1618%           = Section113, PCI\VEN_10DE&DEV_1618


[Strings]
DiskID1 = "NVIDIA Windows (64 bit) Driver Library Installation Disk 1"
NVIDIA = "NVIDIA"
NVIDIA_A = "NVIDIA"
NVIDIA_DEV.1618 = "NVIDIA GeForce GTX 970M"

 

 

 

%NVIDIA_DEV.1618.7102.1558% = Section064, PCI\VEN_10DE&DEV_1618&SUBSYS_71021558

%NVIDIA_DEV.1618.7102.1558% = Section063, PCI\VEN_10DE&DEV_1618&SUBSYS_71021558

NVIDIA_DEV.1618.7102.1558 = "NVIDIA GeForce GTX 970M"

 

Hi Aaron thank you so much for the response. I can't believe I was so close to figuring things out last night, you're right with your steps at "I." I pressed [7] instead of [F7]. I'm sort of dumbstruck that was all I was missing! I don't know maybe its because I was trying to figure it out at 4am but I guess I made a dumb mistake. But anyway thank you so much! I was able to download the 378.92 driver with modded inf files today. :) I'm going to go play my game now!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.