Jump to content
EwinRacing Flash Series Gaming Chairs
godlike flash

Acer 4750g can DIY EGPU 1050 nvidia?

Recommended Posts

hi! im new here. and im planing to do a egpu for my laptop. i wanna ask weather my laptop 4750g can do a egpu for 1050 mini 2gb nvidia graphic card? with v8 beast adaptor

Share this post


Link to post
Share on other sites

currently im waiting someone to reply me =D

please advise anything

acer 4750g

intel 2410m 2.5ghz up to 2.9 turbo boost

4 gm ram

can i install 1050 into my system? 

if can. what i need to prepare aside gpu adaptor and psu

Share this post


Link to post
Share on other sites

anything with nvidia 10 series card will give error 43! chose anything from 900 series or below, if your laptop have a mPCIE slot it will work 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

thx for reply bro. but i already brought the 1050. can i use older driver to make it work? i saw YouTube some success with 1000 series. any idea? 

Share this post


Link to post
Share on other sites

System Specs:

acer 4750g: i5 2410m, 4GB Ram, Nvidia 520M dGPU, Win 7 64bit, mpcie interface.

EXP GDC Beast 8.0, with an zotac 1050, connected through the mpcie interface, powered by a 96W 12V DC power supply. Using the Nvidia 375.63 drivers (Which seem to be the only 1050/TI driver that doesn't give a Code 43 Error, thanks to jimteo for sharing that).

 

 

The 375.63 drivers installed without any trouble, didn't need to modify anything. Device Manager detects the 1050 without any errors, as well as HWInfo, GPU-Z, and the Nvidia Control Panel. However, I can't seem to be able to set the 1050 as the main GPU to be used. I've tried setting it as the Physx Processor in the Nvidia Control Panel, as well as setting it to be used for CUDA, but games and 3DMark11 still uses the dGPU (NVS 5200M). I've tried disabling the NVS 5200M in Device Manager, but everything starts using the Intel HD iGPU instead. Can someone please explain to me how to set things to use the 1050?

I'm sorry if this is a stupid question, this is the first time I'm trying an eGPU setup.

Thanks

Success :D. Last time I tried disabling the dGPU in Device Manager, but programs would then use the iGPU instead of the eGPU. This time I disabled the PCI Express Root Port in Device Manager, which includes disabling the dGPU, and programs are now running with the eGPU (Thank you to dani29m for this method). Just tried the Witcher 3, the card is running at x1 2.0, bus usage peaked at 91%, but mostly sat at around 60-70%. Hot-Plug also works fine (using ExpressCard). Gonna run FireStrike now, will post the results here once done. All of this is through the laptop's internal LCD, so I guess there'll be a performance hit from that.

 

Benchmark results:

4774 in Fire Strike, and 1807 in Time Spy, both using the internal LCD. Will try and benchmark with an external monitor later on.

Share this post


Link to post
Share on other sites
On 2/28/2017 at 8:10 AM, godlike flash said:

System Specs:

acer 4750g: i5 2410m, 4GB Ram, Nvidia 520M dGPU, Win 7 64bit, mpcie interface.

EXP GDC Beast 8.0, with an zotac 1050, connected through the mpcie interface, powered by a 96W 12V DC power supply. Using the Nvidia 375.63 drivers (Which seem to be the only 1050/TI driver that doesn't give a Code 43 Error, thanks to jimteo for sharing that).

 

 

The 375.63 drivers installed without any trouble, didn't need to modify anything. Device Manager detects the 1050 without any errors, as well as HWInfo, GPU-Z, and the Nvidia Control Panel. However, I can't seem to be able to set the 1050 as the main GPU to be used. I've tried setting it as the Physx Processor in the Nvidia Control Panel, as well as setting it to be used for CUDA, but games and 3DMark11 still uses the dGPU (NVS 5200M). I've tried disabling the NVS 5200M in Device Manager, but everything starts using the Intel HD iGPU instead. Can someone please explain to me how to set things to use the 1050?

I'm sorry if this is a stupid question, this is the first time I'm trying an eGPU setup.

Thanks

Success :D. Last time I tried disabling the dGPU in Device Manager, but programs would then use the iGPU instead of the eGPU. This time I disabled the PCI Express Root Port in Device Manager, which includes disabling the dGPU, and programs are now running with the eGPU (Thank you to dani29m for this method). Just tried the Witcher 3, the card is running at x1 2.0, bus usage peaked at 91%, but mostly sat at around 60-70%. Hot-Plug also works fine (using ExpressCard). Gonna run FireStrike now, will post the results here once done. All of this is through the laptop's internal LCD, so I guess there'll be a performance hit from that.

 

Benchmark results:

4774 in Fire Strike, and 1807 in Time Spy, both using the internal LCD. Will try and benchmark with an external monitor later on.

Hello, im trying to use msi gtx 750ti using exp gdc beast and have follow all these steps but mu laptop wont boot and the screen just showing some garbage/artifact display.i am using aspire 4750g, same system spec as you.do you know how to fix this problem? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.