Jump to content
TheBDog

Getting an Akitio Node eGPU Enclosure in the UK?

Recommended Posts

Hey guys,

 

I am pretty new here. This is my first post (I posted a similar thing on Reddit). :) I have been a long time lurker and am keen to get your guys' input on what I have to offer.

 

So I found the Akitio Node for sale from this UK company:

http://www.equip-u.com/shop/index.php?main_page=product_info&cPath=45_896&products_id=20752

Seems like a legit site from what I can tell etc. And it's even linked on the Akitio official website 'Where to Buy' page for Europe (https://www.akitio.com/where-to-buy/akitio-sites). But there's nothing on their site about being in stock etc.

Now I've been lurking for a while and it looks like none of the Thunderbolt 3 eGPU boxes(apart from the Razer Core) are actually available at all in Europe yet. Am I missing anything?

TL;DR version: Is it worth ordering from these guys on the chance that they actually have it in stock?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Blocker35
      Hi guys, bit of a rookie to the whole EGPU scene. Currently I have:
       
      - MacBook Pro 2015 13inch (3.1GHz Core i7 16GB RAM)
      - Razer X Core 
      - Apple TB3 to TB2 Adapter
      -  TB2 Cable (Cable Matters)
      - 23inch AOC External Monitor
       
      I am wonder about what graphics card to get to run X-Plane11 with high graphic settings?
      I have purgewrangler set up and ready to use with an AMD graphics card, but am also open to the idea of an Nvidia graphics card.
      Any advice appreciated. I did not buy a Windows PC as I need a Mac for various other things and wanted an all-in-one laptop.
    • By SnipeKing17
      The GPU works, The PSU works, The system works. [individually they all do work]
       
      The system works perfectly fine without the WLAN card.
       
      When i put the system to sleep and hotswap the mPCIe riser and WLAN press something on the keyboard.. Restarts.
      Will shutdown in roughly 27 seconds for those 27 seconds it works just fine like how it normally would on external monitor.
       
      When i shut it down and plug the riser and switch it on, same story. 27 seconds.
       
      I don't even see a error. I get to login screen directly. I used DDU already.
       
      I timed it. no matter what i do if i use the eGPU, External monitor it restarts instead of pause-play. I have 27 seconds.
       
      Need help!
    • By aBug
      Hello Everyone!
       
      I have problem with VBIOS/EEPROM(?) after installing of a GTX1060 N17E-G1-A1 GPU NVIDIA Graphics Chipset (old one has temp. damages). 
       
      I  modified new 416  and old 391 nvmii.inf file and try to install drivers, but every combination gave me no success. There is only yellow triangle in  Windows Device Manager :|
      Is there a way to bring my card to life?
       
    • By captcavy
      Hello everyone,, I need your expertise, I have a m17 r4, (2012) unlocked A15 bios thanks to Klem, it has a Gtx 675m in it now, 
      I would like to know the best GPU to upgrade to without losing a lot of the factory functions of the alienware laptop, like being able to use both VGA functions such as intel 4000, and the factory bios for the cooling of the GPU, I don't want to solely rely on the nvidia
      As a full dedicated GPU, let me know what VGA card to get and what vbios to use, I will gladly donate beer to you for your help, or point me to a member on this forum who can help me,
      Thanks, Shelby,  Aka captcavy
    • By Kel
      I got the exp gdc beast 8.5 got all the connections right... laptop boots up... fans turn on the gpu.... device manager detects gtx 1060 with a “ ! “ in a yellow triangle. Now what to do.... i tried to do the bios mod.... but realised that i have 3.07 version. 
      Questions-
      1 is there any way to get this done without the mod?? 
      2 if mod is the only way... kindly help me with step by step instruction in laymans terms... i m not a techy... so i might not understand technical terms.... altho i am interested... but learning yet. Please help. 
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.