Jump to content
EwinRacing Flash Series Gaming Chairs
Andromedus

Acer Nitro V17 Nitro Black HQ + AKiTiO Node TB3

Recommended Posts

it's great!! :)

 

is it for new drivers/firmware?

could you show some screenshot?

 

 

there is a post about this vn7-592g+akitio node on egpu io.

 

 

 

Edited by sicily428

Share this post


Link to post
Share on other sites

 

2015 17" Acer V17 Nitro Black GTX960M (VN7-792G) + GTX1070@32Gbps-TB3 (AKiTiO Node) + Win10 [tunatoro]^ // 20Gbps vs 40Gbps TB3 cable

 

 

 

 

 

 

[gallery800x600]
[photo=https://***********/wp-content/uploads/wpforo/attachments/2359/thumbnail/1759-IMG4404.JPG][/photo]
[photo=https://***********/wp-content/uploads/wpforo/attachments/2359/thumbnail/1775-Capture6.PNG][/photo]
[photo=https://***********/wp-content/uploads/wpforo/attachments/2359/thumbnail/1776-Capture5.PNG][/photo]
[/gallery]

 

Edited by sicily428

Share this post


Link to post
Share on other sites
On 3/27/2017 at 3:30 AM, haz100 said:

WOW.......!!!!!!

 

i dont know if this is the best place to post this but after 3 months of trouble with my thunderbolt , i have finally got my node with a GTX 1060 going with my VN7 592g :w00t:

 

finally .........

 

im testing but it all seems good WOW

 

can someone tell me where i should post this ... in all its details 

Hey! First off congrats man!! :D 

 

I have the same laptop and am thinking about an e-gpu setup, have you tested it out with the laptop lid closed? I use my Acer with an external screen and when the lid is closed, the performance is greatly reduced because the nvidia card automatically limits itself (tried changing power settings, nvidia control settings, to no avail). I'm figuring the performance wouldnt be hurt because the GPU would be external and not the internal card, if you could confirm this that would be great :) 

 

Grats again!

Share this post


Link to post
Share on other sites

Hey fellow gamers,

Also have the Nitro Black VN7-792G with 4K screen and just ordered the Akitio Node (expected in a few days)

Wondering which of the GTX1070 or GTX1080 to get?

I understand there's in any case some throughput loss compared to desktop performance via the TB3 40gig - Also read some issues with overheating and the node switching off...

Knowing that I move from the 960m which manages between 40-55fps on optimised AAA titles with low to mid settings at 1080p (or about 30 on non-optimised), I would assume the 1070 should manage 60fps with mid-high at 1080p. Would the GTX1080 manage 60fps at ultra or even get me something nice @ 2k  or 4k?

 

Edited by j0nnnnn0

Share this post


Link to post
Share on other sites

So got the Asus Strix 1080 as the purse and brain couldn't stretch to the 1080ti...

Followed most of the instructions from the thread - I do disable the 960m in device manager to force the 1080

What a difference it makes, even though I'm displaying on the laptop's screen 

Running most AAA at least 1440p with high presents at 60fps (Battlegrounds and Ghost Recon being the notable exceptions where running at 1080p makes more sense)

Sandbox Universe 2 at 4k ... beautiful

 

The Node and card are a bit noisy (especially given the short cable provided)  but nothing too nasty - temps are great - and apart from the form size of the Node (bigger than expected), I 'm quite happy. As I have other laptops with T3, the investment made sense for me as nearly 1000CHF (am in Switzerland) between the import of the Node and the card makes for an expensive gaming upgrade - will have to start mining bitcoins to offset :-)

 

Edited by j0nnnnn0

Share this post


Link to post
Share on other sites

So what's the bottom line here?

I have a Nitro Black

VN7-592G-71ZL 15.6"

I bought an Akitio Node and an MSY GTX1660ti.

All are running but I cannot get the gpu to show in the device manager.

My Thunderbolt specs say NO egpu support. Did someone here actually manage to make this work?

Acer has a third party chat that is worthless.

I've updated BIOS, Thunderbolt, and Nvidia driver...but no luck.

 

T3-1.jpgt3-3.jpg

Edited by RapidDog

Share this post


Link to post
Share on other sites

I am struggling with a similar setup.

Got the 15" VN7-592G with the Core X and an nVidia RTX2080.

Got latest BIOS and NVM fw ver 15, did use DDU to clean up and did a fresh install of latest Nvidia drivers for the RTX. The card is NOT recognized on the device manager.

TB3 seems working, the Core is recognized. All similar to rapidDog post as well.

Any more help/suggestions on this topic?

Running-DDU.jpg

Edited by Megal
Added pics

Share this post


Link to post
Share on other sites

Some more pics

RTX not recon.jpg

Final one

 

 

GPU support NO.jpg

I did all mentioned here and got all as mentioned.

https://support.razer.com/gaming-laptops/razer-core-x/

 

If you are using a Razer Blade Stealth 12.5” (2016) - INTEL 6500U Laptop (Model number RZ09-01682-xxxx) please see the FAQ “Required update for using Razer Core and Razer Blade Stealth 12.5” (2016) - INTEL 6500U Laptop”. All other models please proceed as below.

Please follow the steps in the order they are listed below. These steps will work for the Razer Core, Core V2 and Core X.

Please note: From Windows 10 RS4 update on, you don’t need to install a GPU switcher for the Core to work. If you do not have the latest update a GPU switcher is required.

The first step is to make sure your laptop has installed all the latest updates to its OS. So please ensure you have checked for updates and installed any recommended updates.
Next install your chosen GPU into the Razer Core.
Connect the Core to your laptop using the supplied Thunderbolt 3 cable and turn on your computer.
Download and install the latest NVIDIA® GeForce® or AMD Catalyst drivers for your compatible graphics card. The Razer Core and GPU must be correctly connected to your notebook prior to installing the graphics drivers.
Note: When downloading graphic drivers from the NVIDIA website, it is highly recommended to select the "Express" option. Selecting the "Custom" option may result in the drivers not installing and updating successfully.
Turn off your computer and connect the Razer Core to your external monitor using the display port on your graphics card.
Turn on your computer and begin enjoying all the benefits of your Razer Core.
Should you need any further assistance please contact our support team at https://support.razer.com/contact-support

Share this post


Link to post
Share on other sites

hello, im going to change the screen from mine to a new 144hz screen aftermarket. has anyone done it before?

Share this post


Link to post
Share on other sites

I know it's a little late coming but I did follow through on getting the Akitio Node. Today I received the Node as well as a GTX 1660 Super and I can confirm that they do work on the VN7-92G (Acer V17 Nitro Black).

The difference is astonishing. I'm using the internal 4k monitor, not an external monitor. My FPS in one intensive game went from 25 FPS (ultra setting, 4k) to 60-100+ (same settings, 4k).

I will note that for some reason you need to set the game to "exclusive full screen mode" NOT "windowed" or "borderless" or any of that. For some reason full screen increases my FPS by around 70%. I suspect it may be related to CPU bottlenecking but I can only speculate.

Set up was virtually plug n' play for something this niche. I will say that you should install the latest TB3 drivers first, then connect the TB3, and then, WHEN the device is recognized as plugged in, install the latest Nvidia drivers (clean install). For the TB3 drivers you can get Acer's latest, I got a newer one over at Gigabyte but your mileage may vary. 

A notable detail is that I do NOT have to disable in internal GTX 960M. The drivers know to prioritize the GTX 1660 Super. When I unplug the eGPU, it goes back to prioritizing the 960M.

The only thing that's a little finicky is connecting. It seems to be most reliable when the eGPU is plugged in first, turned on. This is when it is most likely to recognize that something was plugged in.

Cheers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.