Jump to content
EwinRacing Flash Series Gaming Chairs
0000

EC Flash went wrong on an Clevo W350/W355

Recommended Posts

Hy,

my EC flash on an Clevo W350/W355 (Schenker XMG A504) went wrong. Screen stays black but USB access indicator and Laptop LED are working. the fan speeds up when i keep holding fn+b, which tells me that the keyboard is still working despite the failed ec flash.

Any hints on how to get this working again?

I´ve found the perma recovery guide for failed bios flashes, is there an equivalent for ec?

Thanks in advance.

cheers!

Share this post


Link to post
Share on other sites
Guest

The EC isn't bricked if the system still charges, FANs work, keyboard functions etc.

A system with bricked EC would do anything.

Do a CMOS reset...

Share this post


Link to post
Share on other sites

Ok, i will try that first.

Is there anything else i could try when this is not working? An emergency recovery for the ec like for the bios?

thanks!

Share this post


Link to post
Share on other sites

Bad news, thanks anyways!

The USB access indicator at the flash drive is on, and no matter what key i hit all LEDs on the laptop start flashing. Screen stays black.

So CMOS reset apparently did not work. Most probably need to send it in. Should i rather send it to XMG/Schenker or the german Clevo Service partner?

Clevo Germany

cheers

Share this post


Link to post
Share on other sites
Guest

Are you sure you flashed the EC and not the BIOS? No BIOS flash involved at all? OR maybe you flashed an EC for another system?

Try this file for FN+B: https://mega.co.nz/#!7FkhERrY!_6oYJhhhk7UAqiIHzh5VRjMF0pvSdUt8NVBhZBUUSdc

If it is indeed the EC, then you will need a new motherboard as no re-seller will be able to reprogram the firmware hosted directly in the 133PIN ITE controller as its documentation and required programmer software is still classified.

Share this post


Link to post
Share on other sites

Sounds bad...

Is there a difference if I flashed an ec file for a different system to a failed ec flash?

Could the wrong ec file be recovered?

Thanks again

Share this post


Link to post
Share on other sites
Guest

If you have a wrong EC then you need to try recovery by using the matching wrong BIOS. ;)

Share this post


Link to post
Share on other sites

Might have flashed the ec for the P504, Clevo P157SM-A.

EC_1.03.08

Any chance this would work with the right bios?

Share this post


Link to post
Share on other sites
Guest

When we use FN+B the BIOS on the USB is booted from instead the one on the system, so yeah, there is a small chance that it'll at least boot to flash the correct ones.

I'll prepare a file for you later...

Share this post


Link to post
Share on other sites

Hy,

tried your file. The A504/W355SS is not booting with the P504/P150SM bios. Screen stays black, fan starts when pressing any key. :(

I tried the method on my P303/W230ST which is working fine and booting into recovery.

Seems like i need to send it in.

Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.