Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
katkiller

Help Needed GT-60 (medion erazer x7817) with rx 480

Recommended Posts

Hi there !

I'm creating this thread because I've got a problem :

My old Medion Erazer x7817 just lost his poor gtx 560 gpu.. and I could get my hands on a rx 480 mobile 4Go supposedly manufactured by ZRT (Unknowned to me).

My problem is that i can't manage to use it properly.

I'm dual booting windows 10 an Kubuntu 20.04 with a gpt hardrive (UEFI) and got different outputs with the OSs :

 

- Windows : fans start spinning crazy just before getting to Desktop, and in devide manager I can see the rx 480 but disabled (with the yellow exclamation mark). Same problem when installing the last Adrenalin drivers, and I can't open the GUI (It says that i don't got a properly functional amd gpu). GPU-Z only shows the specs of the integrated GPU (HD 4000).

 

- Linux : No crazy fan spinning. the command "lspci | grep VGA" shows me that the gpu is properly detected, and can run basic 3D objects using "DRI_PRIME=1 glxheads" but crash whithin seconds with heaven benchmarks, it seems that It can't handle "harder work".

 

I searched a lot (maybe badly, but I really tried..) over distinctive forums and know these informations :

- rx 480m might not work with legacy bios, but I use UEFI (and tried also with legacy) - I'm unable to find the link where if read this -

- rx 480m can't output on LVDS screens (which I got) if the motherboard doesn't support OPTIMUS/ENDURO (Ok with the gt 60) -> http://forum.notebookreview.com/threads/hp-elitebook-8760w-compatible-with-an-rx-480-4gb-mobile.834335/page-2

 

Do you think that could be some bios or vbios problem ? I also read somewhere that optimus laptop include the vbios inside bios.

I'm also thinking about power, maybe the 480 draw too much for my psu ?

Or the fact that I changed from Nvidia to AMD gpu ?

 

If somebody got a clue about what is happening, it would be wonderfull to explain it to me here !

Laptop Specs :
- Medion Erazer x7817 with ms1761 motherboard (compatible with MS-16f3 bioses)

- GPU : rx 480 mobile 4Go

- CPU : i7 3610 qm

- OSs : Windows 10/Kubuntu 20.04

 

Share this post


Link to post
Share on other sites

Got some good news ! I could made it work ! I'll copy what I wrote in the netbookreview forum, and hope it'll serve to somebody here ;)

Hello ! Some news here :
I flashed the card bios with one provided by @SMGJohn here :
http://forum.notebookreview.com/threads/rx-480-in-m17x-r3.830397/

I've used the one called "Rx 480M 4GB vBIOS - 015.050.000.001.000000 Samsung & Hynix TDP70W.rom" aaaaaaaand the gpu is kind of working. I had to force the flash because the SSID was different, but it ran smooth.

- Now under linux I can run heaven benchmark without crash, but it's a bit sluggy, like alternating smooth/lag rythmicaly.
I also launched Steam and it worked ok, the steam summary detect the rx480m, but the only game that I downloaded (Hades, launches via proton 5.13) send me a error "No gpu detected".

- Under Windows I could install and launch Radeon software, gpu-z and hwinfo detect the gpu, "among us" videogame worked, but Heaven benchmark lead me to a BSOD.

- Also there's differences in the bios settings if inspected with amdvbflash : the name of the gpu change from "C958 ELLESMEREM XT A1 GDDR5 128Mx32 4GB 300e/300m" to "C958 ELLESMEREM XT A1 GDDR5 256Mx32 8GB 300e/150m", there's no bios config file, the bios P/N is not avalaible, and the ssid change from 0000 to 0B31.

So it seems that the problem comes from the vbios, and that with the proper one I could use the card. Or I'm totally wrong..

I also tried to flash another roms from the techpowerup library :
- One from supposely zrt : https://www.techpowerup.com/vgabios/218964/218964, which handle a bit more time heaven benchmark before crashing
- One from a msi card (it was a stab in the dark) : https://www.techpowerup.com/vgabios/186550/msi-rx480-4096-160825, I couldn't even get a image while passing the boot screen.

Did somebody came through the same problems ? Or have a clue of what's happening ?

@SMGJohn, do you care if I copy this message with the bioses link you provided in the Tech inferno and msi forum ?

Sorry for any language mistake !
 
 
 
 
Hi there !

More news here : With the "Rx 480M 4GB vBIOS - 015.050.000.001.000000 Samsung & Hynix TDP70W.rom" vBIOS, the problem seems to come from vulkan/DirectX API.
OpenGL games works great (Portal 2 and Hades via wined3d) without crashed under linux.

It seems so that this bios doesn't permit me to use the vulkan api (under linux) o directX under windows (the crash with heaven benchmark using directX11).

I tried to search a bit but couldn't find any information : Does anybody have a link about vBios modding or want to play with me at the "Will your computer burn if you install that" game ? :)

Anyway I might speak alone, but at least if somebody pass through the same problems, he/she'll have here a bit of information.
 
 
 
 
Even more news ! I flashed another BIOS from here --> https://linustechtips.com/topic/126...esartifacting-problems-when-its-underclocked/
which seems to work a bit better, but I steal got the same problems with vulkan (I used the one named 700).

So I thought, why don't I give a try with this poor Windows that I everytime forget and then tadaaa : Directx 11 and Vulkan work there.
Weird thing, this bios seems to be from a rx 580.
I tried with the same game "Hades" which can run with both api.

So we could say that a rx 480 mxm can work within a Gt60 Ol' Laptop, wich is great IMO, I'll upload here the vBIOS I got from Internet in case of somebody might need them.

ANYWAY, if somebody want to help me with the linux problem (still searching for a solution), I'll be honored .
 
 
 
 
Oh, and a last detail, but of importance : My motherboard BIOS is flashed.
I remember doing it a long time ago (years), seeing a thread about putting 980m inside my mobo. I flashed it in case of, but i can't remember where i found the file.
Anyway, the bios name is E16F31MS.51X (yes, it's from another motherboard, but it's compatible) and the EC is 1762EM71 ver 4.05.

 

 

Here's the link with the vBIOS I've found :
https://drive.google.com/file/d/1q9K0j7zgLCMHvHXzaoZIDzJyjk4V29LX/view?usp=sharing

It's a zip archive, hope it'll serve to somebody ;)

Edited by katkiller
aestetic

Share this post


Link to post
Share on other sites

Last news : Vulkan now work with Linux !
I changed the distro from Kubuntu 20.04 to Solus Plasma, and now I can use it !

The truth is that I don't really know if it's the reinstall that did the trick, or changing distribution.. buuut it works and I do prefer solus, so it's ok for me ;).

Hope this thread will help the few crazy people that still own these olds machines, and will go with non official gpus !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.