Jump to content

Unable to load into Windows via safe or normal mode

Recommended Posts

Well I have now banged my head against this wall for a week.


Here is the basics of my system, all other parts are standard:

Alienware M17xR4 (delivery date May 2012)
Intel 3720QM processor w/Intel HD 4000 iGPU
AMD 7970m (if I read the right sticker)
Samsung 850 Evo SSD msata 1TB (removed other 2 Mechanical HDD's to simplify troubleshooting
8 GB Ram
Windows 7 64bit service pack 1 - installed fresh not a factory install, manually installed drivers myself  (Winupdate last run in Feb 2016, then ran it on May 17, 2016 with a restore point being created before the windows update started, windows failure May 19, 2016 approx 10pm local time for me)

System Bios:  A12


Overclocking Notes:

No overclocking attempted, ever.  All parts are running at system spec settings


Driver notes:

 AMD are Leshcat drivers 15.7 WHQL Unifl.  

IntelRST 11.x - version required with

Dell drivers for Alienware OSD, Respawn, and other related software, all drivers where possible were most current on site or by maker of product, i.e. Intel Management Interface)


Trouble started:  

While I was playing a game a week ago, the computer froze, no mouse movements, alt-f4 would not close the program, no keyboard response.  It was typical as this game has issues with the switchable graphics and only sees the Intel HD4000, even though in the AMD CCC I set it Max Perform (main reason for running Leshcast drivers since Dell and AMD had old versions and/or drivers that were having issues or had the CCC lock some programs into one performance category or another and user couldn't change).


Inital Action Taken:

So when I rebooted nothing showed up.  So I did my normal routine, windows recovery environment off Windows 7 Sp1 64bit retail disc.  Nothing happened.  sfc /scannow wouldn't run, chkdsk with the various / settings found nothing.  I thought this was strange never had this issue before.  So I figure well lets go into safe mode and find out what is going on.  It just went to a blank screen with a mouse cursor I could move but no shortcut keys brought anything but sticky keys up.


After spending hours trying different things, I started to get the 0x07b error.  So I did something I don't like, system restore.  The only restore point I had was just before a Windows Update was done.  Now everything started to go wrong. I would find one solution, but it would not work.


Possible Mistakes:

 I deleted the prefetch directory and removed the Panther directory, in hopes of resetting the prefetch setup.  

Trying to learn how to put back together the Windows Boot Manager/BCD.  I can't confirm if the BCD has been configured in the registry or not since I am only able to load the 5 hive keys in the c:\windows\system32\config and the date on the registry backups were almost 2 hours after the problems started, so they have been of little use.  

No additional restore points, just the one that I already tried and of course that leaves me with nothing.

Reading to many forums


Some of the Solutions attempted:
rename amd drivers and oem file
safe mode
safe mode w/networking
windows system repair x3
sfc /scannow - won't allow
rebuilt the bcd, uefi partition correctly labeled
adjust entries in reg to remove amd/ati (but made backups before deletion of the keys)
removed all drives but the SSD and no usb devices
ran Norton Tool (ISO) for scanning for viruses/malware - results clean as a whistle (and that was with SSD + 2 HDD).


Other Notes:

I have seen about 5 different errors show up in the Windows RE, but they change frequently, I get the Boot Status Indicates that the OS booted Successfully.


I even put in an older clone of this computer, it was from around August 2015.  It got into Windows normal mode.  I looked around in the SSD for some sort of errors, bad files, etc. Then I made the mistake of seeing if I could boot again into Normal mode on this clone.  Opps!  Now it won't boot.  I can off and on get into safe mode on the clone (not the ssd).

Finally it went to the black screen with mouse cursor.  I gave up and removed it as it obviously wasn't of much use now.


The Alienware model physical installation location of the Msata part is not at all easy to get too, as it all but requires a system tear down almost down to just the frame holding the motherboard.


When I had access to safe mode/normal (fyi, I do not have either ways to access Windows) I had Samsung Magician 4.7 software check the status of the SSD and no issues.
A new issues that started to appear was in the bios of the laptop.  It no longer called the discrete graphics AMD 7970m and Intel HD 4000, now calls them ATI gfx and Ivy Bridge, respectively.


I eventually got Windows RE command Bootrec /scanos to say there was a windows install.  Now it says there isn't, so it sounds like the BCD/UEFI Boot manager/etc is again wrong.


Where am I now on this problem:

I just don't know what else to do.  I want to try and avoid a reinstall as it can take a long time with all the software and *cough* games I install.  Didn't bother contacting alienware as it is really Dell support and someone reading a script that tells them to have me reinstall immediately, so pointless.


I can use the help at this point.  I have way too many websites/forums, etc. bookmarked it could take years to clear all of them.  So I feel I have reached that point that this problem is beyond my knowledge or expertise or lack their of.


UPDATE:  MAY 28, 2016, Sat, 10pm, as noted below I removed the GPU to verify it wasn't the 7970m, while out I think I came across the sticker that shows the bios version of the video card, it was the only sticker that had a proper looking vbios,

Edited by danger007
updated vbios
Link to comment
Share on other sites

In terms of physically removing it, no.  In terms of killing the drivers, I have not deleted but instead renamed each and every amd/ati directory with a _disable at the end (since I might need to have them so didn't delete).  Went into the registry (well loaded the 5 hives) and yanked out the key amd/ati entries in the various software areas (but I didn't do a total removal from the sections that could be drivers, since there could be several drivers that are needed otherwise, but with an AMD product in it, I don't know as well what I can zap in the registry for them (I make a backup of every entry I do remove or alter, once again in case they need to be restored).  I also did run the ePSA bios test from Dell and the thorough test on the 7970m and it passed 3 different times with no errors.


What I am thinking happened in terms of the bios just seeing ivy bridge and ati gfx is that once the drivers are working in windows normal they will send or update the bios (meaning using the dell drivers as the base and then upgrade to current intel and amd drives and not use the leshcat drivers since they don't appear to be updated anymore).  I have thought about reflashing the bios or flashing it up to A13 (but the fact that the A13 is not on the official driver page leaves me concerned as towards the stability of the bios, since I can't trust Dell and won't be their beta tester :).    I just wish the Nvidia MXM laptop video cards like that nice 980 you have weren't so expensive.  I figured I would much rather put it towards a new laptop with it in, so I am stuck more or less with the AMD (lesson learned).  However I think this laptop will still be around for a long time.  If I can save myself from reinstalling, it could be back up and gaming, I mean doing productivity work.


The other theory I have about the AMD, is that in safe mode it isn't suppose to load any drivers other than what is needed to run the Windows barely.  So if I am not wrong, the VGA driver (generic) should be the driver coming up.  I know that in safemode as it list out the drivers it is loading if I rename amdkmpfd.sys so it isn't there, then I get a 0x07b error, and the last driver it shows loading is classpnp.sys.  If I allow the amdkmpfd.sys to load, then it shows as the last driver to load before it switches to the black screen.  Most if not all of my boot logging attempts always fail at hal.inf (and like others on the internet, tons of other drivers fail or load and then a few entries down fail, things like battery.inf, the cpu.inf and on,) I went through that and couldn't really pick out the issue and there are few things mentioned about hal.inf fixing, which again I am assuming probably has something to do with the bootmanager/bootloader/uefi stuff under diskpart and bcd.


Thank you however for your suggestion/solution you offered.  I want to hold out on actual physical removal to the very end if I can.  In regards also to your suggestion, I sadly can't identify the bios version, but I am sure it is a non-uefi compat. version so I have my computer set to load legacy drivers in the bios.  If dell knows there is an issue I wish they would release them instead of hoping we will just buy a new alienware - ha ha.


UPDATE:   Sat, May 28, 2016 10pm,  I went ahead and removed the AMD 7970m from the system (was surprised how easy it was and I removed it with heat sink on to avoid having to deal with re-pasting), no luck, system still failed to boot into safe mode or normal mode, once again a black screen and free roaming mouse cursor.


UPDATE 2:  The vbios sticker, appears to be

Edited by danger007
Bios of vid card added, Tried one of the suggestions - hail mary pass - a US Football term
Link to comment
Share on other sites

On ‎28‎.‎05‎.‎2016 at 9:48 AM, danger007 said:

I have thought about reflashing the bios or flashing it up to A13 (but the fact that the A13 is not on the official driver page leaves me concerned as towards the stability of the bios, since I can't trust Dell and won't be their beta tester

A13 is on the official driver page. On the driver page you have to switch the OS to Win 8.1, then it is there.


I think the best way to figure out if you have a hardware or software problem is to make a fresh clean install. If you wont lose your current installation make a image (with Acronis True Image or something like this) and give it a try. You can also upgrade to win 10 and see if your problem still exists.

Link to comment
Share on other sites

In regards to A13 being on the Windows 8.1 page, do you think there is something in the bios code that could create more problems, since it isn't on the Win 7 page?  Also if I do try to update the vbios, is it already included in the A13 bios or should the vbios be updated before the A13 sort of like once you get past a certain bios A8 or A9 that if you have A10,11,12 it is very difficult to drop back to older bios to get the unlocked version on.


In regards to Win 10, after I read that post about Win 10 and Nvidia and Panels going bye-bye I am curious to see if AMD is having same issue or if both companies having same issue and since AMD does have the commanding lead in number of users, that they are underreported.


How about I give you my computer and I can have your M17x R4, then problem solved :) - just kidding need to find some humor in this nightmare.


The clean install could be my last desperate step.  I only have 1 Samsung 850 Evo 1Tb msata, of course couldn't do two in the system since the only other port in the system is used by the Intel Centrino/Bluetooth combo mini-pci card and I haven't heard if anyone was able to convert it to a msata slot, without using an unlocked or locked bios.  Of course if I got a Samsung 2.5" Evo instead of msata that would allow the clone.


Now the clone of the SSD I have on a Mechanical HDD from Jan 2016, I am just starting to debate if I might consider falling back to that version, wouldn't have too much to reinstall.  I still think something in the startup of the registry or the uefi/bootmgr/bootrec/bcd/bcd00000000 is out of whack somewhere and I just can't see it.


I do however think I found an explanation to the repeated Did not Load Driver notices in the ntbtlog.  I compared the registries by loading hives, exporting them and then comparing.  From the Reg on the clone that I assume is still good, it might list the cpu once.  While under the current reg on the current drive I am trying to fix, the registry in almost each of those drivers being listed as not loaded, they show up in almost a 1:1 correlation to the number of did not load drivers.


One thing that has me worried in Norton.  I know they have a way of getting in front of a system restore if you don't turn off a setting Norton Product Tampering and ruining the restore.  Saw it all through xp, vista, and 7.  While it might protect against someone trying to undo Norton, it has in all my cases that I have encountered screwed up system restores.  I now wish I had allocated enough space on the SSD for at least 1-2 more system restore points.  Of course the problem would remain that if Norton is hampering the restore effort, it would end up with same results.  All I do remember is that when I did have the system in normal mode on an older clone from 2015, I noticed the BCD0000000 key in HKLM was missing.  Since that is built off of the stuff on the system reserved 100mb UEFI and they registry works together with it (supposedly can't edit the bcd0000000 registry key) so I don't know if with it missing that even if I got the bootmanger/uefi stuff all sorted out, would it rebuild that key or not.


It is just like I put out one fire and think I learned what not to do and then another fire is burning elsewhere showing I didn't find the solution I thought, and it repeats over and over.


Sorry sounding like gibberish now, 5am right now, better stop before I give away my social security number, address, bank pin and password!

Edited by danger007
Bios A13 vs vbios already being in or do before.
Link to comment
Share on other sites

I had been originally informed it was a sata 3/mini pci capable.  It was only after buying and looking up more information that I found the screen I saw when I bought and what the sales person at Dell/Alienware incorrectly listed that msata as Sata iii when it was only Sata ii.  I found out also I wasn't the only one who got duped on that.  However it is supposedly a limitation of the HM77 chipset used with the Ivy Bridge CPU and supposedly they could have made it sata III but it would have meant they would have to alter how many USB 3.0 ports could be on the system (of course to me, they should have just put a third party chip on to handle extra 3.0 ports but oh well).  While I lose the performance of the Sata III, it still is more than twice the peformance of the SATA III Mech. HDD.  Also was the only upgrade option left for me.  I already had 1 750gb and 1 1TB 7200rpm drives in my system using the HDD Slot 0 and 1 for 2.5".  No one currently makes a 2tb 7200rpm 2.5" for laptops and probably never will.  Not a RAID setup either.  I just install a great deal of stuff, some of it is redundant in terms of software, and of course games take up a hefty amount of space.


So that is why I had no choice but to go with the msata version over the 2.5" of the Samsung 850.


Another reason is that I always do my drives in pairs.  If I use a 3tb for my desktop to boot, I won't use it unless I have a 3tb spare to use as a clone (so that is why the 750 is still in the system, I haven't decided if buying 2 1tb HDD just to gain 250gb more space is very cost effective and why I had counted out the Samsung 850 in 2.5" format, after I give up nearly 200GB for OP I would really have gained nothing in terms of space.


The day I bought my Samsung, they annouced a 2TB version but it was close to $800 or $999 MSRP and when I found out I was initially bummed out, but then I thought between the sata ii port issue, the cost and the warranty/150tb data limit I would not bother.  I could have gone with a Seagate 2tb 5400rpm, but I have had issues with Seagate drives and I had a 5400 on my previous laptop (of course that was a PATA not SATA) I swore never again to use 5400 as an every day use, just storing data/backups/clones.  Reviews seemed to backup at least to me that a 5400 would be a bad choice for a gaming laptop.


I did further research on the registry.  I looked at the clone of the SSD and my desktop drive as well as my test drive (I use it to test software before it is allowed on my desktop, don't like being a unpaid and unknowingly a beta tester) and discovered that all copies of the reg on my SSD inside my laptop appear to be too full of excess entries to fix, so I now admit defeat on saving the current install.  So based on what you have suggested this is the plan I am going to schedule for:


1.  Take the 750GB that I mentioned above which was an old clone of the system from late 2015 and try to install Windows 10 on it.  Then use that as a way to find out for sure if the AMD is working.  Since that drive was messed up as well when I tried to use it to help fix the current install, no loss in the try then.


2.  Clone/Ghost via Acronic onto the SSD the Jan 2015 version of the system and then just apply the updates between then and now.

-  What I have to decide here is whether to attempt to apply an updated vbios that I found on another site that starts with Tech, since I don't know if I really have earned the right yet to download from here (I have the promotion, but I haven't been able to really help anyone else yet, which is why I say I haven't earned) and then A13 or A13 and then the vbios.  I know I would need to do these last two after the clone is working on the SSD, since it was done under the A12 bios and 015.017 vbios.


3.  If clone/ghost fails to work, I will then go for a clean install as you recommended.  The question then becomes update the system and video card bios.  Of course which one first A13 or vbios and should they be done before I start the install, so I don't run into issues of the past with the different bios from dell (between I think the A09 and A11 or A10 - it hosed my system back then so I had to restart).  I also will need to decide on the exact drivers for the Intel iGPU, MEI, Gb Ethernet and any other drivers that are newer than what Dell provides.

Link to comment
Share on other sites

Well new snag on the Windows 10 test install on that older drive.  It doesn't like the monitor.   Assigns it a Generic PnP but says it isn't correct and when I search the Windows Update site it says the driver I have is the best.  Hmm.


I tried using DDU, then installing Intel's most current Win 10 driver for the Hd 4000, and then the 16.3.5 AMD.  Computer will just crash to error of Thread Stuck in Device Driver.  Can't find anything that comes remotely close to solving this issue.

Edited by danger007
new information to add
Link to comment
Share on other sites

  • 3 weeks later...

Try the vbios first, it is easier changing vbios than a normal bios. Also screw up the vbios only srews up the gpu.


Do you still having trouble downloading the vbios?

Do you have another laptop so you can try switch graphics card?

Link to comment
Share on other sites

  • 4 weeks later...

Well new update.  Under the advice of responses here and 2 other sites, I finally tossed in the towel on the AMD and went fishing for a Nvidia 680m.  Yes there are more powerful cards but this one was designed to work with the M17xR4, so modded anything needed (as long as the card is the true Nvidia 680m 2GB model for Alienware M17xr4 or Dell).


Since I only have a 30 days return on it (no restocking) I decided to get it into my system and do the normal clearing the bios/cmos and then starting the install of the nvidia drivers.  However when in Optimus mode, the 680m refused to load (windows error code 43) no matter which of the 3 official drivers from Dell I tried.  Okay lets go with the good old, manual selection of graphics.  Instead of Red lines on the screen I get all these ---- mashed together in 5 or 6 layers at a time all across the screen, but unlike the AMD lines, these don't affect me being able to see what I am doing or typing.


So back to day 1, back in early May 2016 again.  No dgpu only igpu working.  However it is much more stable than trying to troubleshoot the AMD.  Things I notice no matter if in normal mode/igpu, normal mode/dgpu (remember with AMD I could not get into windows, only with the Igpu) or safe mode, the Nvidia shows error code 43.  When I boot normal/igpu, I run gpu-z.  Unlike the AMD, I cannot get a bios version and several other settings, almost as if they aren't there.


Oh I bought the video card from comp_eve on Amazon marketplace since that I felt was slightly safer than ebay or craigs list.


What am I not seeing or doing?   I ran the extended ePSA test and every time it errors on the video card when it is set to Nvidia as primary, with a memory validation error.  I tested moving the memory (system/ram) around the 2 slots and no difference.  Help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.