Jump to content
EwinRacing Flash Series Gaming Chairs
gerald

Y510p Ultrabay Graphics card

Recommended Posts

On 4/9/2018 at 3:37 PM, AllanDavidson said:

do you have any more pictures/information on this mod? What is this? A Ultrabay adaptar that have both PCI Express and SATA connectors?

That's simple.Just glue a 2.5“ to ODD tray and the adapter together then everything is great

19 hours ago, gerald said:

I bought it at online components.com

You purchased 3 items
44869647.jpg 2199015-1 TE Connectivity / AMP Brand 
Conn Power PL 30Power/88Signal POS Solder RA Thru-Hole/SMD 118 T
$10.90
   
 
50 Ships Today Quantity:  50

Ewwwww... I don't know whether I could get one. The stock is likely to be in a weird state.

Edited by Swung Huang

Share this post


Link to post
Share on other sites

Hey, I replaced my HDD with a SSD a few days ago and now the external card causes reboots and blue screens whenever it's plugged in. I didn't think that the BIOS would have to be modded again after replacing the HDD, so is there an easy way to see if it's my graphics card that went kaput? I don't have another computer to test that card with though.

Here's the info I've gathered.

-The card lights up and fans come on

-The BIOS looks the same as the modded one provided by @High_Voltage

-My computer doesn't recognize my card in Device Manager

-I formatted the m.2 2242 drive because I had another OS on it

-I replaced the HDD with a SSD and DID NOT migrate files over

 

Would any of the drives contain BIOS files that I may have accidentally deleted? I know the main BIOS is stored on the motherboard but is there an EFI partition I may have deleted?

Share this post


Link to post
Share on other sites

@Luthercorp First of all, neither the original nor the modded bios store any kind of data on HDDs. The BIOS should function perfectly even if all of the drives are disconnected. Therefore, replacing the HDD with SSD should not have changed anything in BIOS and it doesn't have to be reflashed.

 

The issue you described might be caused by incomplete OS migration or driver-related problems in case it was a fresh install.

 

Also, how can you tell whether the card is detected in device manager or not, if as you say it causes PC to reboot and bluescreen whenever connected? I should also mention just in case, that the adapter does not support hot plug, therefore you shouldn't connect it to a PC while it's already running. Doing so might damage the card or the PC.

 

My recommendations would be to try the following:

 

  • First of all, clean the connectors (both inside the ultrabay and on the adaptor) with some compressed air. Disassembling your PC in order to swap the drive could have caused dust to get into the connector and cause poor contact.
  • Check that all your drivers are installed properly. Maybe, try installing the original HDD back and see whether it works as before. Try clean install of Windows.
  • Try resetting the BIOS to factory defaults by either clearing CMOS or selecting the option in the BIOS itself.

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

@High_Voltage thanks,

I forgot to say that it wouldn't recognize the card with the Nvidia driver uninstalled (it doesn't recognize what it is, just that something's connected.) Once the driver was installed, having it boot with the card in would cause the blue screen/ bootloop

Share this post


Link to post
Share on other sites

Definitely sounds like an OS-related issue to me. Try different version of drivers, for example the one provided by Lenovo on the support pages. Still, cleaning the connectors won't hurt either.

Share this post


Link to post
Share on other sites
8 hours ago, Luthercorp said:

@High_Voltage thanks,

I forgot to say that it wouldn't recognize the card with the Nvidia driver uninstalled (it doesn't recognize what it is, just that something's connected.) Once the driver was installed, having it boot with the card in would cause the blue screen/ bootloop

Actually, it seems like a poor contact. Sometimes I loosen my adapter accidentally can cause this issue.

Share this post


Link to post
Share on other sites

@gerald 

I saw that you have some adapters to sell and I would like to buy one. Will you have another round of selling on ebay? If not, how could I purchase one?  Thanks

Share this post


Link to post
Share on other sites

Hey,everyone. I have some exciting development on the adapter.Actually now its more like a dock.

-3d1b2fc6618ca669.jpg

-538e1fba9c1994e9.jpg

-5aa85e08360375.jpg

45d8a62014f954d9.jpg

-77b48bc69f317ad6.jpg

82817e93cd5adee.jpg

4906a484bebb59a8.jpg

-2ffe2035d57ae9f3.jpg

-1d0230e069fa6531.jpg

82817e93cd5adee.jpg

-2ffe2035d57ae9f3.jpg

And more pics

 

ea05751ca7b88ec.jpg

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
1 hour ago, Swung Huang said:

Internal display works on y410p/510p with nvidia cards

-7e51e6ba838481b4.jpg

-2d5531fccfdd93d9.jpg

 

Hi, could you describe how to get the internal display to work with the eGPU?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
7 hours ago, Swung Huang said:

 

 

@Swung Huang I can't believe you really did it! :hyper:

 

 

7 hours ago, Swung Huang said:

For the hareware mod: desolder these resistor and solder your arduino to it.

4a6d94432864b334.jpg

 

What is the purpose of the Arduino Mod?

Share this post


Link to post
Share on other sites
11 minutes ago, AllanDavidson said:

What is the purpose of the Arduino Mod?

 

To use any eGPUs on y500/y510p without modding the BIOS.

Share this post


Link to post
Share on other sites
15 minutes ago, High_Voltage said:

 

To use any eGPUs on y500/y510p without modding the BIOS.

I have Y500 and Geralds adapter and that's funktionless. How can i use Arduino mod.

Share this post


Link to post
Share on other sites
22 minutes ago, Kuneroll said:

How can i use Arduino mod.

 

I'd rather recommend you trying this BIOS mod first. The more people test it, the better.

 

Edit: But if you are really more hardware person, and do have decent soldering skills, the hardware mod can be found here.

Edited by High_Voltage

Share this post


Link to post
Share on other sites
15 hours ago, MWichni said:

 

Hi, could you describe how to get the internal display to work with the eGPU?

for y410p/510p, attach the egpu (must be nvidia card), disable the GT750M/GT755M, disconnect any external display and everything should work fine. Optimus should be utilized in this way.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
30 minutes ago, MWichni said:

Hi and thanks for the reply. Just tested it and everything works fine. 

 

So you're saying it works with internal screen now? This is awesome! What GPU model are you using? And did it only require disabling internal Nvidia in device manager or also in BIOS?

Share this post


Link to post
Share on other sites

I'll try it tonight on Y500 with both gpu nvidia and amd and then i'll post result.

Edited by Kuneroll

Share this post


Link to post
Share on other sites
11 minutes ago, Kuneroll said:

I'll try it tonight with both gpu nvidia and amd and then i'll post result.

 

That'd be awesome! Thanks!

Share this post


Link to post
Share on other sites
5 hours ago, MWichni said:

Hi and thanks for the reply. Just tested it and everything works fine. 

According to my tests,just disable them in the device manager.(Haven't found related bios options lol) nvidia ones works fine. It seems that amd ones don't work in this way.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By mssfss
      hi,
       
      I need a help to remove whitelist from bios to install my new wlan.
       
      model :lenovo g405 
       
      thanks.
       
       
      https://www.sendspace.com/file/7gvm11
    • By blaz_evic
      Hello

      I upgraded my old laptop with i7-3632qm and its working fine, temps are ok but he wont boost. Lenovo g500s could be bought with i7-3632qm and it had same cooling as was 2020m so i dont think cooling is problem. Can i bios unlock? I cant acces advanced settings in bios. i need help

      thanks
    • By Klem
      If someone wants upgrade Wi-Fi card and remove witelist, or unlock hidden additional menus and settings, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread.
    • By alexey621
      Hello, I have several Lenovo L530 notebooks, but there is no wi-fi adapter inside. I tried to use my wi-fi adapters, but whti every adapter I have an error "1802 unauthorized network card is plugged in". I have already used all available wi-fi adapters, but no result. I really need professional help and I hope I find it here. As far as I understand there is a way to remove whitelist in BIOS, so here's the file with my BIOS dump.
      https://disk.yandex.ru/d/GcILQafHeDzxZw
      Hope you can help me with BIOS mod. Thanks in advance. 
      P.S. Sorry my English, I'm from Russia
    • By FlubDaBlub
      Hi all! I am wondering if it's possible to remove the bios whitelist easily. Because of the whitelist, my external gpu setup that I got recently refuses to work. If it helps at all, I know that the wifi card that used to be in the slot was the intel 8265ngw. Here's the bios link if that helps too: laptops and netbooks :: thinkpad x series laptops :: thinkpad x380 yoga :: 20lj :: 20ljs20n00 :: mp1e15eb - Lenovo Support US
      Thanks for your help!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.