Jump to content
EwinRacing Flash Series Gaming Chairs
pavchogeo

Y500 gt650m sli UHD perfoermance

Recommended Posts

I am interested  in getting an external UHD 4k external monitor for my Lenovo y500 sli ... As i read in specs gt650m supports 4k resolution ... Has anyone tested the overall performance of the laptop when hooking it up to a UHD monitor? i am mostly interested  in CAD use

Share this post


Link to post
Share on other sites

I was not aware that the 650GT which what my Y500 has supported 4k, I assume you simply connect it to the 4k tv using the display port connector. I am too interested to find out how the quality is, I do not own a 4k tv or monitor yet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Iron Lungs ☺
      Hey guys,
       
      what are some accepted wireless card that has 5G which is compatible with Lenovo Y500? 
       
      Thanks!
    • By AMV
      Hello to all big format laptop users!
      I`ll try to make it as short as possible. I have the Alienware M18X R1 for about 7years, i think. It was a problematic machine all the time. But during warranty period local support fixed everything super fast and free of charge :). I even upgraded from gtx 580m sli to gtc 780m sli. And made primary hdd samsung evo ssd. Unlocked Bios. Power brick i changed 3 times by now. Battery once. And 6moths ago one of the long time ago installed 780m died ( started with artifacts on screen then refused to boot windows). Replaced that and was as happy as ever. The machine kept working stable and i pushed all i could get from it in reasonably modern titles. Even tried RDR2 on default settings, gave me 17fps :). Not sure if SLI is supported for that game. The point is it was running fine for last 6 months.
      What happened:  Gaming as usual, room temp 23C. After around 2hr suddenly black screen. The laptop switched off by itself.
      What i check: First checked power brick. Green light off. Unplug from wall and laptop. After plugging in wall green light back on. Connect laptop light off.
      Next: Tried take out battery, unplug. And hold the PWR button for 1 min. Try to start on battery - nothing. Plug in - green light off again.
      Later: after some googling found that need to try to remove video cards. Done that. OK Nice! Plug in power and it starts as nothing happened on the integrated intel video.
      Found out that i one of the video cards is plugged in that triggers the power brick to trip. (the original upgrade 780m from years ago). 
      Start with GPU: Insert the other one in its slot. Systems start. But immediately i notice there`s no video drivers. OK i think reinstalling and job done. Drivers reinstalled, asked for restart. After restart nothing. Still no driver.
      Windows device manager: This is bogging me. it shows that i have 670M instead of 780m. Windows gives Code 43 Error.
      BIOS: I go into bios just to find that that it has reverted back to A05 (hows that possible?). And its so limited that i cant even choose witch video card to use. But it detects nVidia GFX.
      How to get at least my single 780M to be working?! Update bios again to unlocked? Did this event fry Vbios on my other card maybe?
      System: m18x R1
      SLI gtx 780m
      Unlocked bios (before event)
      nvidia driver 443.x(or there about)
      Win: 7, 64bit
    • By Donz7733
      I am planning to get this Charger (170w 20v 8.5a) - https://www.amazon.in/Lenovo-ThinkPad-4X20E50574-170W-AC/dp/B00MLTQ99Y
      &
      the Adapter - https://www.aliexpress.com/item/32975526334.html?spm=a2g0o.productlist.0.0.27cb747e6TEc28&algo_pvid=a7db42d0-97cb-4a37-be7a-d19c44bddf73&algo_expid=a7db42d0-97cb-4a37-be7a-d19c44bddf73-0&btsid=8d6ee0f9-08e9-4474-b63b-cc751403b4c7&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_60
       
      Will this combination work to run Both GT755m of Y510p?
       
       
      Thanks
       
    • By rusTORK
      When my first CPU fan on Y500 is broke i replaced it on something compatible (non-original) and planned to replace it later on original. Since that time happened a lot things, but i still using that non-original fan. But i did some research and here is what i founded:
       
      I. ORIGINALS
       
      1. Forcecon (marked as FCN on fan)
      DFS5413005MH0T-FC1C (5V - 0.5A)
      Spotted in: Y400, Y500.

       
      2. Asia Vital Components (marked as AVC on fan)
      BNTA0612R5H-P007 (5V - 0.5A)
      Spotted in: Y410p, Y500, Y510p.

       
      3. Sunon (marked as SUNON MagLev on fan)
      MG60120V1-C230-S99 (5V - 2.25W (0.45A))
      Spotted in: Y410p, Y500.

      So, which to choose? Any recomendation? Maybe there also unexpected way (completely diffirent fan from another company for another laptop)?
       
       
    • By mocji117
      Hi, I got a Sager NP8278 (Clevo P170SM) with a gtx970m 6GB. is there a way to have SLI or what are my upgrade options for the video card?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.