Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
Colt141

Alienware M17x-R2(P01E) GTX765M OC upgrade

Recommended Posts

So, I'm facing some issues with a hardware upgrade on an Alienware M17x-R2 model P01E. I've been attempting to get a GTX 765M OC edition card that I pulled from another Alienware to work fully with the system. As of right now I can only boot the system into Windows 7 through safe mode.

What I've done thus far:

         -Rewrote the INI file to allow Nvidia's drive to install

         -Flashed the vbios from the original to Kepler

 

Whenever the system tries to boot normally it crashes and the screen changes to a random color, usually pink or black.

 

If anyone could point me in the right direction to making this work that would be great.

20160407_182809.jpg

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

disable integrated idt audio through bios or disable while in safe mode worked with 770m pending os cause just did it couple month ago been testing other card also so give it a try unless you got it already!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By Klem
      Klem's_vbios_DELL_GTX880M_80.04.F5.00.07_UNLOCKED.rar
      For 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked core voltage adjustments.
      3. Unlocked Power Limit.
      4. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      5. Increased Power Limit and Power Target.
      6. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
    • By Noxco
      Hello to all can you help me change the graphics card?
      Alienware m17x r4
       i7 3610qm
      quadro k4100m
      display 120hz 3d
      bios a15
      trying to install 980m but not getting 5 or 8 beeps removed the battery and reset the bios. disabled legacy and secure boot in settings windows 10 gpt uefi
      help how to be?
    • By Guardian241
      So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

      Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?
       
      Thanks for any help you can give.
       
      - M
    • By Guardian241
      Hi,
       
      I've recently got my hands on an M17x R4 Alienware Laptop from 2013 which I love. I've replaced the screen, keyboard, RAM, and hard drive to make it into a fully modern laptop. However, I'm currently waiting on a replacement for the 680m GPU with a 980m from ebay. My question for you all is, do I need to do anything with the BIOS to make this 980m work? Is there a way to prevent the laptop from using Intel HD Graphics with Optimus? I think the Intel HD Graphics on this laptop are currently broken as I see static-looking dots flash on the screen. (See image below for example). My theory is that because Intel HD Graphics with Optimus is still in-use while in-game, the dots are being caused by it.
       
      Thanks for any help in advance.
       
      - M
       

       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.