Jump to content
EwinRacing Flash Series Gaming Chairs
Tech Inferno Fan

eGPU experiences [version 2.0]

Recommended Posts

I don't understand too :confusion:

Did you manage to get it working on the internal screen?

You have a Fujitsu AH532 right? I have the exact same laptop, and I used to have a GTX660 before upgrading to the 770.

I could play on both internal and external.

I'm sorry if you already explained, but could you clarify the issues you get?

Yes, I have got it working on the internal screen, I have also managed to working on the external screen, but not without problems. I enable Gen2 port in the setup 1.30, and when I get to the welcome screen, this is where the problem comes in. The display switch back and forth between internal and external screens, with the "an error when running Nvidia graphics driver" pop up appear. It does that repeatedly until BSOD shows up. How did you make it work on your laptop? Please help me out.

Share this post


Link to post
Share on other sites
can anyone help me out here?

i still cant get my GTX 660 to run... the last i did and it showed that the device was working properly in the device manager but the clock and all showed " 0 ", could someone help me out here? im trying to get it to run using the internal screen much appreciated.

when you switch to internal screen,you put the prefered grapchics processor to nvidia in the nvidia control panel?

Share this post


Link to post
Share on other sites

Is it possible to run an external GPU on a Macbook Pro with dedicated graphics (650M) on Windows 8.1 in BIOS mode? I'm thinking about testing my Akitio Thunder2 + 970 on our rMBP, while I wait for my G46VW Thunderbolt mobo to arrive. Also to see how it performs on TB2 vs TB1.

Share this post


Link to post
Share on other sites

Hey,

I sent this in an email to nando and jacobsson, yet I got no response so I thought I would see what the general users think of it. I feel that this forum is a bit messy and hard to read for new users, so I devised what I think is a better way to organize the forum.

http://pastebin.com/eJ4DT8hE


Share this post


Link to post
Share on other sites
when you switch to internal screen,you put the prefered grapchics processor to nvidia in the nvidia control panel?

thanks for the reply. i cant seem to even have it to run in internal screen... the computer says that it seems to be working properly but it doesnt seem to actually recognise it... is it because i dont have the setup1.x and all?

Share this post


Link to post
Share on other sites
Finally got the benchmarks :D

If you include your pics at http://forum.techinferno.com/diy-e-gpu-projects/2109-diy-egpu-experiences-%5Bversion-2-0%5D-383.html#post108090 , a brief writeup of the steps you did and add 3dmark06 and 3dmark11/13 performance runs at default resolutions then I can add your implementations to http://forum.techinferno.com/diy-e-gpu-projects/6578-implementations-hub-tb-ec-mpcie.html#dx11 . Yours would be one of the first EXP GDC V7 ones and includes exclusive enclosure photos.

Share this post


Link to post
Share on other sites
Yes, I have got it working on the internal screen, I have also managed to working on the external screen, but not without problems. I enable Gen2 port in the setup 1.30, and when I get to the welcome screen, this is where the problem comes in. The display switch back and forth between internal and external screens, with the "an error when running Nvidia graphics driver" pop up appear. It does that repeatedly until BSOD shows up. How did you make it work on your laptop? Please help me out.

@coyote, I have had extensive comms with useafo about why his GTX660 doesn't support Gen2 reliably yet his GTX550Ti does. The conclusion being there is likely a mimatched impedance on the GTX660 preventing Gen2 operation with the possibility that another vendor's card OR use of a EXP GDC instead of PE4C V2.0 will correct that issue.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
regarding more tan 2gb issue you can do a dsdt override.NOW to work with the internal screen you need to have an Intel hd integrated ghrapics to active optimus.i sugeest try sell your laptop and buy one at least with second generation icore.

Thank you for the reply! So it is as I suspected/feared.. Unfortunately I couldn't find this information earlier but at least now I own an eGPU :-) Is it Optimus that require an Intel iGPU so that it can't be tricked? I was hoping that it would work with any iGPU but it doesn't seem to be like that. Buying a new laptop isn't a priority right now so I'll just have to play games on my stationary PC and not while on the go.

I'll check the DSDT override if I get another incentive to try the eGPU with my current laptop.

Share this post


Link to post
Share on other sites
@coyote, I have had extensive comms with useafo about why his GTX660 doesn't support Gen2 reliably yet his GTX550Ti does. The conclusion being there is likely a mimatched impedance on the GTX660 preventing Gen2 operation with the possibility that another vendor's card OR use of a EXP GDC instead of PE4C V2.0 will correct that issue.

Very well. It is indeed odd that his GTX550Ti worked well with the same configuration whilst the GTX660 didn't.

If I were to speculate, I'd say to test the GTX550Ti with the PE4C, see if it works, then if it does, proceed to get another GPU.

@useafo, as Tech Inferno Fan explained, it looks to me like a hardware issue from your GTX660. Return your GPU saying it doesn't work and try to get another one. Good luck.

@Lind.LHeart did you do the DSDT override?

Share this post


Link to post
Share on other sites
Finally got the benchmarks :D

s6c6dGT.png

3DMark 2006 @ 1920x1080

Y2jfNqR.png

3DMark 11 @ 1920x1080

AwcIBFY.png.

thanks.are you run 3dmark 06 with x1.2 optimus?because it seems that you have a low score.

i sugest you a few things:

make sure you have dgpu disable in order to ensure x1.2 optimus acceleration

check that during benchmark your pci-e link it pops-up with x1.2 bandwith.by using EVGAprecisionx with Rivatuner activated ,combined with HWMonitor you could see in real time on the screen the behavior of each component including pci-e link

put the system on máximum performance in the energy options or use throtllestop to increase the performance of the CPU

even with an i7 like yours i think you have to have an increase by 25-30% of the actual results.

Share this post


Link to post
Share on other sites
thanks for the reply. i cant seem to even have it to run in internal screen... the computer says that it seems to be working properly but it doesnt seem to actually recognise it... is it because i dont have the setup1.x and all?

ok.x1 setup is a very usefull tool for the e-gpu users.if you can buy it i recommend to do that.NOW , a egpu card in order to have a fully functionality inside a system like Windows needs to have a space memory alocated in 32bits space.if that does not hapendd(mostly because of a higher tolud)you have to use x1.setup to compact the memory OR use the alternative of making a dsdt override to extend the space memory to a 36bits ,so the egpu could be acomódate in that space.

http://forum.techinferno.com/diy-e-gpu-projects/7476-%5Bguide%5D-dsdt-override-fix-error-12-a.html#post102517

Share this post


Link to post
Share on other sites
ok.x1 setup is a very usefull tool for the e-gpu users.if you can buy it i recommend to do that.NOW , a egpu card in order to have a fully functionality inside a system like Windows needs to have a space memory alocated in 32bits space.if that does not hapendd(mostly because of a higher tolud)you have to use x1.setup to compact the memory OR use the alternative of making a dsdt override to extend the space memory to a 36bits ,so the egpu could be acomódate in that space.

http://forum.techinferno.com/diy-e-gpu-projects/7476-%5Bguide%5D-dsdt-override-fix-error-12-a.html#post102517

i am trying to do the DSDT override but i came across with this error " Error: Count not access the registry path: System\CurrentControlSet\Services\ACPI\Parameters\DSDT\LENOV\TP-6A___\00000180" when i enter " asl /loadtable dsdt.aml " i dont think this is supposed to be like this right? please correct me if im wrong...

i forgot to run it on admin it now says succeded... sorry im bad at this...

Share this post


Link to post
Share on other sites
Very well. It is indeed odd that his GTX550Ti worked well with the same configuration whilst the GTX660 didn't.

If I were to speculate, I'd say to test the GTX550Ti with the PE4C, see if it works, then if it does, proceed to get another GPU.

@useafo, as Tech Inferno Fan explained, it looks to me like a hardware issue from your GTX660. Return your GPU saying it doesn't work and try to get another one. Good luck.

I'm also thinking that the bandwidth is so high on GTX660 that PE4C V2.0 can't handle it. Can you please correct me if I'm wrong?

@Tech Inferno Fan

EDIT: This is what I mean:

taobao-9%20VGA%20card-01.jpg

Share this post


Link to post
Share on other sites
Thank you for the reply! So it is as I suspected/feared.. Unfortunately I couldn't find this information earlier but at least now I own an eGPU :-) Is it Optimus that require an Intel iGPU so that it can't be tricked? I was hoping that it would work with any iGPU but it doesn't seem to be like that. Buying a new laptop isn't a priority right now so I'll just have to play games on my stationary PC and not while on the go.

I'll check the DSDT override if I get another incentive to try the eGPU with my current laptop.

using >4gb ram mean using x64 os bits and x64 driver ghrapics card wich could be an incentive for a low spec.system.i recommend to do that.

http://forum.techinferno.com/diy-e-gpu-projects/7476-%5Bguide%5D-dsdt-override-fix-error-12-a.html#post102517

NOW i sugest a few things to increase the performance of your egpu setup:

if your egpu adapter alows x2 link configuration it could be 15-30%more performance but with the disvantage of spending some extra cash

try upgrading your dual core with a better one(on ebay you should find many these days at a very low Price)

use optimizing tool like razer game booster to minimize the usage of the resource of your system

i was having a good games experience with my old Fujitsu amilopi by upgrading the P7350 weak processor to an T9900 an making an x1.2 link configuration until i could by a laptop with an i7 second-gen processor.Good luck!

- - - Updated - - -

- - - Updated - - -

- - - Updated - - -

i am trying to do the DSDT override but i came across with this error " Error: Count not access the registry path: System\CurrentControlSet\Services\ACPI\Parameters\DSDT\LENOV\TP-6A___\00000180" when i enter " asl /loadtable dsdt.aml " i dont think this is supposed to be like this right? please correct me if im wrong...

i forgot to run it on admin it now says succeded... sorry im bad at this...

ok.let me khnow if it Works.

Share this post


Link to post
Share on other sites

ok.let me khnow if it Works.

it didnt work am did i do something wrong?

Microsoft Windows [Version 6.0.6002]

Copyright © 2006 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd \Users\

C:\Users>cd TEST COM

C:\Users\TEST COM>cd Desktop

C:\Users\TEST COM\Desktop>cd DSDTEditor-Linux-Mac-Win

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>iasl dsdtoverride.dsl

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20120420-32 [Apr 20 2012]

Copyright © 2000 - 2012 Intel Corporation

dsdtoverride.dsl 3701: Method (OGCD, 0, NotSerialized)

Warning 1114 - ^ Not all control paths retu

rn a value (OGCD)

dsdtoverride.dsl 3745: Method (OGCA, 0, NotSerialized)

Warning 1114 - ^ Not all control paths retu

rn a value (OGCA)

dsdtoverride.dsl 5960: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5972: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5985: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5998: Acquire (MUTE, 0x0FFF)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6010: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6023: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6036: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 8516: And (CTRL, 0x1E)

Warning 1113 - ^ Result is not used, opera

tor has no effect

dsdtoverride.dsl 11727: Return (One)

Warning 1104 - ^ Reserved method should not retu

rn a value (_Q6D)

dsdtoverride.dsl 11774: Return (One)

Warning 1104 - ^ Reserved method should not retu

rn a value (_Q6C)

ASL Input: dsdtoverride.dsl - 12162 lines, 379626 bytes, 6387 keywords

AML Output: dsdt.aml - 48543 bytes, 1457 named objects, 4930 executable opcod

es

Compilation complete. 0 Errors, 12 Warnings, 0 Remarks, 48 Optimizations

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>asl /loadtable dsdt.aml

Microsoft ACPI Source Language Assembler Version 4.0.0NT [Aug 28 2009, 18:36:36]

Copyright © 1996,2009 Microsoft Corporation

Compliant with the ACPI 4.0 Specification

Table overloading succeeded

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>

then i rebooted...

then went to device manager , resource connection but large mem seems to be missing

?post-29384-14494998434148_thumb.jpg

Share this post


Link to post
Share on other sites
it didnt work am did i do something wrong?

Microsoft Windows [Version 6.0.6002]

Copyright © 2006 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd \Users\

C:\Users>cd TEST COM

C:\Users\TEST COM>cd Desktop

C:\Users\TEST COM\Desktop>cd DSDTEditor-Linux-Mac-Win

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>iasl dsdtoverride.dsl

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20120420-32 [Apr 20 2012]

Copyright © 2000 - 2012 Intel Corporation

dsdtoverride.dsl 3701: Method (OGCD, 0, NotSerialized)

Warning 1114 - ^ Not all control paths retu

rn a value (OGCD)

dsdtoverride.dsl 3745: Method (OGCA, 0, NotSerialized)

Warning 1114 - ^ Not all control paths retu

rn a value (OGCA)

dsdtoverride.dsl 5960: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5972: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5985: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 5998: Acquire (MUTE, 0x0FFF)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6010: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6023: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 6036: Acquire (MUTE, 0x03E8)

Warning 1128 - ^ Result is not used, p

ossible operator timeout will be missed

dsdtoverride.dsl 8516: And (CTRL, 0x1E)

Warning 1113 - ^ Result is not used, opera

tor has no effect

dsdtoverride.dsl 11727: Return (One)

Warning 1104 - ^ Reserved method should not retu

rn a value (_Q6D)

dsdtoverride.dsl 11774: Return (One)

Warning 1104 - ^ Reserved method should not retu

rn a value (_Q6C)

ASL Input: dsdtoverride.dsl - 12162 lines, 379626 bytes, 6387 keywords

AML Output: dsdt.aml - 48543 bytes, 1457 named objects, 4930 executable opcod

es

Compilation complete. 0 Errors, 12 Warnings, 0 Remarks, 48 Optimizations

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>asl /loadtable dsdt.aml

Microsoft ACPI Source Language Assembler Version 4.0.0NT [Aug 28 2009, 18:36:36]

Copyright © 1996,2009 Microsoft Corporation

Compliant with the ACPI 4.0 Specification

Table overloading succeeded

C:\Users\TEST COM\Desktop\DSDTEditor-Linux-Mac-Win>

then i rebooted...

then went to device manager , resource connection but large mem seems to be missing

?[ATTACH=CONFIG]12723[/ATTACH]

wich O.S do you have?and what laptop model?

Share this post


Link to post
Share on other sites
wich O.S do you have?and what laptop model?

Windows vista enterprise 32 bit service pack 2 and its a lenovo sl400

i know its old

thank you for helping me by the way been stuck for ages

-

Share this post


Link to post
Share on other sites
Windows vista enterprise 32 bit service pack 2 and its a lenovo sl400

i know its old

thank you for helping me by the way been stuck for ages

-

ok.don·t worry i have a Fujitsu siemens with the same age.

now,do you have by chance x1.setup?

i ask because in my amilopi due the high tolud i was need to do both things :dsdt override and egpu compactation on 36 bits to get my laptop working.

.

and what dgpu it has?assume it is a nvidia 9300m gs.

and what egpu do you use?

what is the ram amount?

with a x32 bits system 4gb ram is useless since it could manage up to 3gb.so you could try pull out a ram module see if the egpu is working.in this case dsdt override does not have sense.

if it Works with only 1 ram module (mine was working without nothinhg more to do) then you should consider upgrade ram to 4gb and insatll an Windows x64 versión,and make dsdt override and a 36 bits compactation

Sorry if i am not so explicit!

don;t worry it will Works,finally!

Share this post


Link to post
Share on other sites

Just an update atout my flickering problem, if can be useful for others.

In my case I did see horizontal strings all over the screen when the eGPU come under load, from any kind of app (browser, video editor, 3D engines). Strings disappear immediately after the GPU work finished.

Reading on the net appear to be a common problem for HD 7xxx series, without a single solution.

Can come from Catalyst driver version, problem from voltage management, bad card, OC, connection cable quality, vsync, bad VRAM, bad power supply.

After testing: GPU underclocking, RAM underclocking, voltage increase, voltage decrease, forcing vsync, forcing display refresh, cable connection strengthen, disabling any GPU image enhancement, I did maybe discovered the problem.

I attached as a monitor my led TV using HDMI cable instead of the DVD-I-->VGA adapter I used on the old monitor.

No flickering at all, so I will buy a HDMI or DP or DVI-D to VGA adapter and will see if will work on my display in the same way.

Share this post


Link to post
Share on other sites
ok.don·t worry i have a Fujitsu siemens with the same age.

now,do you have by chance x1.setup?

i ask because in my amilopi due the high tolud i was need to do both things :dsdt override and egpu compactation on 36 bits to get my laptop working.

.

and what dgpu it has?assume it is a nvidia 9300m gs.

and what egpu do you use?

what is the ram amount?

with a x32 bits system 4gb ram is useless since it could manage up to 3gb.so you could try pull out a ram module see if the egpu is working.in this case dsdt override does not have sense.

if it Works with only 1 ram module (mine was working without nothinhg more to do) then you should consider upgrade ram to 4gb and insatll an Windows x64 versión,and make dsdt override and a 36 bits compactation

Sorry if i am not so explicit!

don;t worry it will Works,finally!

unfortunately i dont have the 1.x setup...

it doesnt have any dGPU just a 4500MHD integrated graphics i suppose...

im using a GTX 660 by leadtek 2 GB...

i have 4 GB of ram installed for the computer...

CPU Type Mobile DualCore Intel Core 2 Duo T6570, 2200 MHz (11 x 200)

Motherboard Name Lenovo 2743RS6

Motherboard Chipset Intel Cantiga GM45

System Memory 3036 MB (DDR2-667 DDR2 SDRAM)

DIMM1: Kingston 99U5295-011.A00LF 2 GB DDR2-667 DDR2 SDRAM

DIMM3: Kingston 99U5295-011.A00LF 2 GB DDR2-667 DDR2 SDRAM

so i guess i should take out 1 of the RAM modules and try the eGPU now?

Share this post


Link to post
Share on other sites

:Banane22:

unfortunately i dont have the 1.x setup...

it doesnt have any dGPU just a 4500MHD integrated graphics i suppose...

im using a GTX 660 by leadtek 2 GB...

i have 4 GB of ram installed for the computer...

CPU Type Mobile DualCore Intel Core 2 Duo T6570, 2200 MHz (11 x 200)

Motherboard Name Lenovo 2743RS6

Motherboard Chipset Intel Cantiga GM45

System Memory 3036 MB (DDR2-667 DDR2 SDRAM)

DIMM1: Kingston 99U5295-011.A00LF 2 GB DDR2-667 DDR2 SDRAM

DIMM3: Kingston 99U5295-011.A00LF 2 GB DDR2-667 DDR2 SDRAM

so i guess i should take out 1 of the RAM modules and try the eGPU now?

heyy,sounds too good to be true!

if you have igpu 4500hd you can do x1.1 optimus!!!!!!!!!!!!

BUT you have to use an older driver!

ok ,pull out a ram module ,and try again

Share this post


Link to post
Share on other sites
:Banane22:

heyy,sounds too good to be true!

if you have igpu 4500hd you can do x1.1 optimus!!!!!!!!!!!!

BUT you have to use an older driver!

ok ,pull out a ram module ,and try again

okay i will pull out 1 ram module and try the dsdt setup again.

this might be a stupid question, but when i install the driver, when it is rebooting do i have to plug the expresscard out??? cos my screen goes black if i dont do that? i saw a youtube video and he seems to plug it out when it it is restarting but another guy seems to be able to just leave it on. so i should take it out during restarting procedure right?

once again many thanks!

Share this post


Link to post
Share on other sites
okay i will pull out 1 ram module and try the dsdt setup again.

this might be a stupid question, but when i install the driver, when it is rebooting do i have to plug the expresscard out??? cos my screen goes black if i dont do that? i saw a youtube video and he seems to plug it out when it it is restarting but another guy seems to be able to just leave it on. so i should take it out during restarting procedure right?

once again many thanks!

no dsdt override this time

with one memory stick it should Works without

i think you should try both ways plug it before and after

Anyway once you make dsdt override it remains on the dsdt table!

Share this post


Link to post
Share on other sites
no dsdt override this time

with one memory stick it should Works without

i think you should try both ways plug it before and after

Anyway once you make dsdt override it remains on the dsdt table!

apparently i seemed to be getting the blue screen of death with only 1 2gb ram module is it that i took out the wrong one out? is there such a thing? i tried this one " http://forum.techinferno.com/diy-e-gpu-projects/3539-guide-dsdt-override-simultaneous-igpu-dgpu-egpu.html " just now... maybe i should try the original longer way this time... how do i know if it remains?

i rechecked the file the code is still there...

Share this post


Link to post
Share on other sites
apparently i seemed to be getting the blue screen of death with only 1 2gb ram module is it that i took out the wrong one out? is there such a thing? i tried this one " http://forum.techinferno.com/diy-e-gpu-projects/3539-guide-dsdt-override-simultaneous-igpu-dgpu-egpu.html " just now... maybe i should try the original longer way this time... how do i know if it remains?

i rechecked the file the code is still there...

ok.now do a reverse dsdt override and erase that code.and then load the aml file without it

with only 1 module of ram it is no need,and could cause problems

a litlle complicated isn"t it?

don"t worry it will work.

ram is fine

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.