Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[MOD] Latest Creative SB Recon3Di for M17xR4 & M18xR2 [Win10/8.1/7]

Recommended Posts

Creative SB Recon3Di full package, for both M17xR4 & M18xR2 - Win10, Win8.1 & Win7.

 

Improved sound quality, latest CPL, Dell EQ + Audio Drivers...incl bloatware [Optional].

 

Screenshot.png

 

Clean Install option:

 

Device manager -> uninstall Creative audio drivers (check delete driver and software) .

Programs and Features -> uninstall Recon3Di -> reboot.

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

 

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

 

regedit (registry editor) delete:

HKEY_CURRENT_USER\Software\Creative Tech

HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Creative Tech

 

 

Extract w/ 7-zip -> run setup.exe -> Custom install option -> select both SB control panel & drivers (uncheck Extras) -> reboot.

 

Capture1.thumb.PNG.756905618bef4591ffc50

 

 

 

 

Update:

 

Windows 10/8.1: Sound_Blaster_Recon3Di_v1.01.09_Win10_8.1_M17xR4_M18xR2.7z

 

Windows 7: Sound_Blaster_Recon3Di_Win7_M17xR4_M18xR2.7z

 

 

 

 

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

What mods did you make to this?

 

Is it possible to mod the Alienware 17 R3 flavor of this driver to re-enable bass redirection in Windows 10?

Share this post


Link to post
Share on other sites

hmm no sound on my m17xr4, the sound icon have big red"x" have to restart couple times then working again,   seems very random,

google online most people said its hardware issue have to replace motherboard ...   anything solutions ? Thanks.

Share this post


Link to post
Share on other sites

Hello all,

 

Great work!  Will the above work with an AW 17 R3?  There are some Creative drivers preventing upgrades to Win10 19H1.  Does anyone know if a beta or modded is available?

 

TIA

Share this post


Link to post
Share on other sites
On 3/22/2016 at 3:35 PM, J95 said:

Creative SB Recon3Di full package, for both M17xR4 & M18xR2 - Win10, Win8.1 & Win7.

 

Improved sound quality, latest CPL, Dell EQ + Audio Drivers...incl bloatware [Optional].

 

Screenshot.png

 

Clean Install option:

 

Device manager -> uninstall Creative audio drivers (check delete driver and software) .

Programs and Features -> uninstall Recon3Di -> reboot.

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

 

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

Delete ->  C:\Program Files (x86)\Creative -> C:\Program Files (x86)\InstallShield Installation Information (Hidden folder)\{9C6429B2-8FE9-4B40-8A83-171BCA4FA288} (SpkEQSC3DDell) -> C:\Users\Public\Creative

 

regedit (registry editor) delete:

HKEY_CURRENT_USER\Software\Creative Tech

HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Creative Tech

 

 

Extract w/ 7-zip -> run setup.exe -> Custom install option -> select both SB control panel & drivers (uncheck Extras) -> reboot.

 

Capture1.thumb.PNG.756905618bef4591ffc50

 

 

 

 

Update:

 

Windows 10/8.1: Sound_Blaster_Recon3Di_v1.01.09_Win10_8.1_M17xR4_M18xR2.7z

 

Windows 7: Sound_Blaster_Recon3Di_Win7_M17xR4_M18xR2.7z

 

 

 

 

Hi, the Windows 10/8.1 link is broken, may I ask for a new link? My M17xR4 audio drivers are broken on Win10 -.-'

Share this post


Link to post
Share on other sites
2 hours ago, Mismo_YT said:

Hi, the Windows 10/8.1 link is broken, may I ask for a new link? My M17xR4 audio drivers are broken on Win10 -.-'

Hi!

Right now I checked links, all links works. If you can't download files, then just read "User Account Promotion Rules":  https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
42 minutes ago, Klem said:

Hi!

Right now I checked links, all links works. If you can't download files, then just read "User Account Promotion Rules":  https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

So unitl I get that promoted status, I can't download this drivers? And what can I do to get promoted?

Share this post


Link to post
Share on other sites
On 9/22/2021 at 12:59 PM, Klem said:

Hi!

Right now I checked links, all links works. If you can't download files, then just read "User Account Promotion Rules":  https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

Hi! Sorry for bothering you again, but I have been now promoted, but I can't download the file, I have missed anything? I don't understand it -.-'

Share this post


Link to post
Share on other sites
36 minutes ago, Mismo_YT said:

Hi! Sorry for bothering you again, but I have been now promoted, but I can't download the file, I have missed anything? I don't understand it -.-'

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
12 hours ago, Klem said:

 

This seems to be older than this post, but I'll give it a try and tell you if it works. Thank you :)

Share this post


Link to post
Share on other sites
On 9/24/2021 at 11:42 AM, Klem said:

 

 

14 hours ago, Mismo_YT said:

This seems to be older than this post, but I'll give it a try and tell you if it works. Thank you :)

Well, the older drivers doesn't make any change at all, it keeps doing the same things. You told me that the links from this post were working, but I can't download them, can you send it to me via e-mail or drive or something like that? Thank you for the help. 

Edited by Mismo_YT

Share this post


Link to post
Share on other sites
22 minutes ago, Mismo_YT said:

Well, the older drivers doesn't make any change at all, it keeps doing the same things. You told me that the links from this post were working, but I can't download them, can you send it to me via e-mail or drive or something like that? Thank you for the help. 

Unfortunately, these links stopped working the next day after I checked and wrote that they work. I don't know who did it and why.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
1 minute ago, Klem said:

Unfortunately, these links stopped working the next day after I checked and wrote that they work. I don't know who did it and why.

Well, that's really unfortunate, I don't know what to do now, but thank you anyway. I read in some posts on this page that newest Win10 is giving problems with this laptops, so if you or anyone reading this comment knows that instaling older versions (and what version) could help me, tell me pls. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Guardian241
      So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

      Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?
       
      Thanks for any help you can give.
       
      - M
    • By Guardian241
      Hi,
       
      I've recently got my hands on an M17x R4 Alienware Laptop from 2013 which I love. I've replaced the screen, keyboard, RAM, and hard drive to make it into a fully modern laptop. However, I'm currently waiting on a replacement for the 680m GPU with a 980m from ebay. My question for you all is, do I need to do anything with the BIOS to make this 980m work? Is there a way to prevent the laptop from using Intel HD Graphics with Optimus? I think the Intel HD Graphics on this laptop are currently broken as I see static-looking dots flash on the screen. (See image below for example). My theory is that because Intel HD Graphics with Optimus is still in-use while in-game, the dots are being caused by it.
       
      Thanks for any help in advance.
       
      - M
       

       
       
    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
    • By Freddyicy
      I have spent a little time in the past few days looking around this site. I would love for someone to point me in the right direction to a forum that has information that could help me out with my problem.
       
      I have a:
       
      Alienware M17XR3 
      Windows 7 Home Premium 64-bit
      Intel I7-2820QM 2.3
      Bios InsydeH20 Version 1.0 A12
      NVIDIA GeForce GTX 460M
      (4x) 4 GB Ram
      samsung 2.5" 256 SSD (SATA3.0Gbps)
       
      It has been an amazing machine for the last 10+ years. Minor issues, nothing that an Alien Respawn could not fix, till now! On battery power it works just perfect.  Then I plug it in and it's all OK until I try to do anything, and then the screen goes white. The screen sometimes goes yellow, sometimes blue, but mostly white screen. It will do nothing until I do a hard reset (holding the power button till it turns off and turn it back on) with the power unplugged.  If the power is not unplugged then it will go through boot up to windows swirling dots then go white again. If I plug it in and do nothing I can charge it, unplug and continue what i was doing. I have tried a lot of solutions bouncing around the internet, and thought I was having a DC Jack connection issue (replaced the ac/dc power adapter, then the motherboard). I get a better connection now but with the same white screen result. I stumbled into this forum and I'm hoping to find solutions to my issues.  Then upgrade like so many others have.
       
      Any ideas, comments or suggestions welcome.
       
      Thank you in advance!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.