Jump to content

MacBookPro 2012 + gtx 980 issues


Recommended Posts



I have a Problem with my Egpu Setup. I have a MacBookPro mid 2012 with Intel hd graphics 4000 + a gtx 980 as a Egpu + Windows 8.1 pro. I builded the hole thing and installed the newest drivers.

My Problem is that the pc finds the egpu but doesnt use it. All Games etc. are running on Intel hd graphics. I doesnt know what to do. How can I switch between the 2 GPUs? Would be very nice if someone could help me!



Link to comment
Share on other sites

did you find my thread and switched gpus in efi shell?


stumbled upon this site after a very long time as you'll see, so you might be very lucky.

should still work for your model. it does for me.


EDIT: if you can't make it work or dont get any addtional help sent me a pm, i'll check back in a few days.

Edited by Shelltoe
Link to comment
Share on other sites

Yes it would be great to use the internal Display. On an external Display I scored 6300 in Fire Strike. Think thats ok because of the weak cpu. But the hd graphics is still used on the external display and gets very hot. Is there no way to disable the igpu? 

Thanks for your help 

Edited by flerwa
Link to comment
Share on other sites

  • 3 weeks later...

Are you still having the same issue ? or you solved it .. anyway yesterday i was in the same situation as you ,, and i could not find a way to solve it . 

so i had to remove and reset my system .. and the problem is that i have exams this week so i stopped everything and ill try later after exams ,, then i saw this in reddit i was like why i did not do it before reseting and all duh :(  so if you still facing same issue please try this and let me know too if it worked for you . plus use external display .



You do not need to re-install Windows. Nor, is it a bug.

The swapping between integrated Intel graphics and nVidia hardware is handled by the nVidia driver. One of the reasons why nVidia pushes a new "Game Ready Driver" every week or so, is because they update the list of executable programs the driver monitors as you launch them. When it finds a match, it enables the accelerated hardware for that program with appropriate the GPU settings preselected for you.

If you right click on your desktop and click on "nVidia Control Panel" , a window will open. Click on "Manage 3D settings" on the left hand side and you will then see a couple of tabs on the right.

The first tab (Global Settings) is the settings your computer will use all of the time. I would suggest leaving this tab alone as it can cause unwanted effects or crashes with some games. It can also drain a laptop battery quickly if your accelerated hardware is always enabled - just to open a web site or office application.

The second tab (Program Settings) allows you to modify the list of applications that are monitored. My guess is that your install of GTA is not in the list for some reason. It could be the build version of GTA that you are using - or an unexpected source of how it was installed. Either way, the fix is simple.

Click on the "Add" button in the "Program Settings" tab. Click on the Browse button on the "Select a program" popup. Navigate to the executable that is used for the GTA game itself. Once selected, you will notice that it is now added to the drop down of monitored applications at the top of the "Program Settings" tab. Keeping that application selected, change the "preferred graphics processor" from "Use global setting" to "High-performance NVIDIA processor". Click the "Apply" button at the bottom right of the Control Panel. Close the Control Panel and then start GTA. You should be using the accelerated GPU at this point. If you are not, you should preform a clean install of the latest Windows 10 nVidia drivers.

NOTE: It is common for the nVidia drivers to get confused after an integrated video driver update to leave the GPU on all the time and quickly drain laptop batteries. You will need to reinstall the nVidia drivers if this happens.

NOTE 2: When re-installing nVidia Drivers, if you choose to do a "Clean Install", any of your custom application settings described above will be lost and need to be reset up again. I often do this with javaw.exe so that games such as custom modded Minecraft will run using the nVidia hardware.

Hope this helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.