Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
tiger_1829

RapidDrive VS ExpressCache

Recommended Posts

I just recently clean installed with Windows 10. I'm somewhat confused with the caching feature for my mSATA SSD. People on other forums have shared their frustration on getting the caching feature to work and have narrowed them down to Intel's Rapid Storage Technology's Acceleration feature, Lenovo RapidDrive, and ExpressCache. I scoured all over to find my particular instance but I was left more confused than when I started. I did learn that the acceleration feature no longer works since I do not have an acceleration tab anymore and that RapidDrive no longer seems to apply. I've yet to try ExpressCache. Anyone who has experience with this can lead me to the right direction? 

Share this post


Link to post
Share on other sites

Ive been using express cache myself.  I bought the version of the Y500 without an SSD.  Shortly after I bought a 32GB Crucial mpcie SSD and installed it myself.  I then dealt with the exact question as I was trying to figure out how to make sure it worked.  I ended up going with ExpressCache, though I also had the Intel Rapid Storage on my system.  ExpressCache can be a little confusing as there isnt a specific utility, its all command line based.  But if you get it installed you can confirm it working via the command line and then you are good.  As you may be aware your SSD will not show up under my computer. 

 

This is what I followed to get it working:

https://support.lenovo.com/us/en/documents/ht074404

 

 

Share this post


Link to post
Share on other sites

Thanks man, seems like I managed to get it working I think. I ran "eccmd -info" in my CMD after installing ExpressCache and letting it take over my entire mSATA and this is what I got:

 

EC Cache Info
==================================================

Mounted                   : Yes
Partition Size            : 14.88 GB
Reserved Size             : 2.00 MB
Volume Size               : 14.88 GB
Total Used Size           : 12.92 GB
Total Free Space          : 1.96 GB
Used Data Size            : 12.85 GB
Used Data Size on Disk    : 12.92 GB

Tiered Cache Stats
==================================================
Memory in use             : 1024.00 MB
Blocks in use             : 8188
Read Percent              : 5.64%


Cache Stats
==================================================
Cache Volume Drive Number : 0
Total Read Count          : 5867
Total Read Size           : 262.84 MB
Total Cache Read Count    : 2855
Total Cache Read Size     : 115.09 MB
Total Write Count         : 18299
Total Write Size          : 430.77 MB
Total Cache Write Count   : 12711
Total Cache Write Size    : 141.97 MB

Cache Read Percent        : 43.79%
Cache Write Percent       : 32.96%

 

 

Share this post


Link to post
Share on other sites

You bet.  Looks good to me, I get a similar readout.  It will take some time to notice the effects, but once it establishes your common used files etc, it really speeds certain things up, especially boot times.

Edited by IR1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Klem
      In this thread you can post your requests for Lenovo Y50-70, Lenovo Y70-70, Lenovo Z50-70, Lenovo Z70-70, Lenovo G50-70, Lenovo G70-70.
      If someone want upgrade Wi-Fi card and remove whitelist, or unlock hidden additional menus and settings in bios setup menu, or unlock vbios for overclock NVIDIA card, then you can post your request in this thread.
    • By mssfss
      hi,
       
      I need a help to remove whitelist from bios to install my new wlan.
       
      model :lenovo g405 
       
      thanks.
       
       
      https://www.sendspace.com/file/7gvm11
    • By blaz_evic
      Hello

      I upgraded my old laptop with i7-3632qm and its working fine, temps are ok but he wont boost. Lenovo g500s could be bought with i7-3632qm and it had same cooling as was 2020m so i dont think cooling is problem. Can i bios unlock? I cant acces advanced settings in bios. i need help

      thanks
    • By Klem
      If someone wants upgrade Wi-Fi card and remove witelist, or unlock hidden additional menus and settings, or unlocked vbios for overclock NVIDIA card, then you can post your request in this thread.
    • By alexey621
      Hello, I have several Lenovo L530 notebooks, but there is no wi-fi adapter inside. I tried to use my wi-fi adapters, but whti every adapter I have an error "1802 unauthorized network card is plugged in". I have already used all available wi-fi adapters, but no result. I really need professional help and I hope I find it here. As far as I understand there is a way to remove whitelist in BIOS, so here's the file with my BIOS dump.
      https://disk.yandex.ru/d/GcILQafHeDzxZw
      Hope you can help me with BIOS mod. Thanks in advance. 
      P.S. Sorry my English, I'm from Russia
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.