Jump to content

M15x not starting at all, no lights nor fun starts


Recommended Posts


my M15x seems dead for no obvious reasons, simply one day worked, the other day not. No liquid inside. Battery is very old so I use notebook without it.


The symptoms are that it does almost nothing. When I press power button, nothing happens. Sometimes, when I hold the power button, it blinks twice (the power button only).


After some checks I suspected the motherboard so I bought a new one from ebay, reinstalled everything but it behaves the same. It could be faulty too but the probability to have two motherboards with the same issue is very little.


I tried to run it without RAMs, with different AC adapter, no change. Now I'm guessing that the CPU could be dead. But don't want to waste another money just like that so I hope someone from you, experts, could face the same earlier and I can learn from it.


Do you know how M15x behaves when CPU is completely removed? And what if GPU is removed? This could help me to isolate the origin of problem.




Link to comment
Share on other sites

Hi mate not sure what use ill be as mines was a little different to yourself. My dad thankfully has the m15x as well. So i tested all my main parts in his the gpu, cpu, mem hard drive, wifi card and power strip and stuff. 


Em it could be a number of things man . Is it just the alien head power button thats flashing , no num lock keys or that ?


Try the laptop without the battery in it, just the power adapter, do a discharge with the batter out first tho, take battery out leave unplugged and hold the power button for 20 seconds. 


Wouldt think the same issue with both boards but u could try removing the cmos battery under the back panel and then do a discharge, reset the bios see if thats causing the issue.


Were u over clocked at all. Whats the spec of the laptop mate, heard alot of peoples crappy out on the 260m gpu,


Also is there any lights at all on your power adapter, still glowing blue ? 


all i can think off without more info basically the stuff i did with mines



Edited by stephen0205
Link to comment
Share on other sites

Thanks for your feedback and suggestions.


I tried all the reset options and also I re-installed all the components to a new motherboard. Unfortunately no change. With battery in the power button (alien head) is flashing but the battery is really dead so it has no chance. Without battery it flashes twice only. When  I press the power button, flashing stops, I can hear very little "clap" from the area where the power adapter is connected to the motherboard. But no LED lights or blinks, simply no activity at all. Adapter still glowing blue, I tried also another adapter, same.


And I do have the crappy 260 GPU. But I assume if this is dead, the CAPS/NUM/SCROLL LEDs should blink, there are some error codes to show that.


When you tried to replace components in your M15X, by a chance, did you try to run it without CPU or GPU? Did it anything or nothing at all? I'm asking because it seems to me that CPU could be the reason of this behavior. Battery charging works without CPU. But to activate motherboard, I guess only two components are mandatory: motherboard and CPU. If I disconnect all the other ones, motherboard should start and to show some error codes (see attached). 


Link to comment
Share on other sites

id assume it would power but display a black screen without the cpu, possibly even beep. As for the gpu i assume the same. You can pick up the i7 720 for super cheap, but i cant say it will solve your problem. 


My one was worse than yours, i didnt get any power at all, not even the alien light, so i cant say for sure what it would do without those components, but from what i read, sounds similar.

Link to comment
Share on other sites



Just wanna share what happened to my m15x about 2 years ago, recorded and uploaded to youtube (See below)


Issue / Caused / Solution : Forgot to lock the CPU socket on it, silly mistake! :)


Good Luck!






Edited by Genetics
Spoiler for vid.
Link to comment
Share on other sites

Thank you all for your inputs.

I did some further tests and it seems that the motherboard tends to boot (alien lights for 10 secs, then switches off automatically). When I insert VGA, it does nothing. Therefore I guess the VGA is dead. Will try with another one and will see.

I'll share results later.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.