Jump to content

ASUS GTX 750 Ti (ASUS ROG GR8) vBIOS problem.


Recommended Posts

I have an ASUS ROG GR8 (https://www.asus.com/uk/ROG-Republic-Of-Gamers/ROG_GR8/) which comes with an INTEL HD 4000 Series card and the nVidia GTX 750 Ti. The nVidia drivers clearly read it as the 750 Ti but the nvflash utility states I have the following

<0> GeForce GTX 860M (10DE,1392,1043,84BB) H:--:NRM B:02,PCI,D:00,F:00

I tried to OC the card by increasing the wattage - which worked fine! I started playing around with the KeplerBiosTweakerand eventually came across the option to Fix Invalid Clocks (shown below)


I saved the file and since then, the drivers don't even recognise the card.

In the process , I lost the original BIOS backup I had. YES, I am stupid for this and I now regret my failure to being more careful with my backups (especially for BIOS edits)

I have tried every single .rom file included in all the versions of ASUS GPUTweak and ASUS GPUTweakII, I have tried the ROMS from the BIOS DB...nothing works.

I plead someone with the same model or someone who happens to have the ROM backed up to upload it for me. GPU-Z saved the file as GM107.rom.

I would be forever grateful!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.