Jump to content
EwinRacing Flash Series Gaming Chairs

No PEG on M17X-R4 with nVidia GTX 980M

Recommended Posts

Hi, I installed a new GTX 980M in a M17X R4 but there's no way to get PEG mode working.

First I tried to follow instructions from Lee James Wood (who sold me the card), using the stock A12 BIOS but it didn't work.

He stated I shouldn't stay on Windows 10 x64 with Optimus mode because it'll cause issues and probably damage my new GTX card because of erroneous temperature readings, so I have to try harder.

I tried with an unlocked A11 BIOS and then following J95's instructions:

Unlocked BIOS.

- Unplug power cord

- Remove battery

- Hold power button for 30 seconds

- Remove CMOS coin battery (next to GPU fan)

- Remove gtx 770m -> 2 screws only, there's no need to remove the heat sink.

- Reinsert CMOS battery

- Plug power cord

- Power on -> Beeps -> hold power button until shutdown.

- Power on -> F2 -> disable the integrated graphics - Second Advanced Menu -> Video Configuration -> disable IGP -> set display to PEG -> Exit menu 'Save Without Exit' -> shutdown.

- Reinsert gtx 770m.

- Power ON -> F2 -> shutdown.

- Reinsert Battery.

...but it didn't go. In a different way.

By the time I power on the notebook after reinserting the card back, I obtain a black screen and beeps.

I tried the procedure step by step, first by setting in the BIOS the mode to PEG and disabling the integrated graphic card.

then I tried by setting the mode to PEG and setting the integrated GFX to auto instead of disabling it.

No way: always black screen and beeps. :apologetic:

Actually the video cards are in SG mode, and nVidia Optimus seems to work right.

I'm not enough into video card tech to judge but mr Wood, who's much more expert than I am, told me that using SG mode the dedicated card signal and management go through the integrated GFX; because of this there's the risk the dedicated card isn't correctly managed, especially regarding temperature readings. Nothing wrong except slower performances.

Has anyone a piece of advice for me?

Has anyone with a similar hardware configuration managed to use PEG mode? And How?

It seems there's no other thread regarding this matter, and that I'm not the only one with this problem.

Thanks in advance!

Share this post

Link to post
Share on other sites

Haha I am very new to this forum, this is my first post, but I just got through getting mine configured with the help of phobos1984. Were you able to flash the unlocked A11 BIOS? Since then have you gone into your BIOS and tried to change the Video Settings?

Share this post

Link to post
Share on other sites
Were you able to flash the unlocked A11 BIOS? Since then have you gone into your BIOS and tried to change the Video Settings?

Yes to all, as you can read in the OP.

But it didn't work: black screen and beeps.

Share this post

Link to post
Share on other sites

assuming you flashed A11 unlocked do this:

- go to the bios (press F2 repeatedly on boot), load the default settings. Now Save WITHOUT exit. Go to Boot menu -> "Boot list option" UEFI -> "Load Legacy Option ROM" Disabled -> "Secure boot" Disabled-> " Windows 8 Fast Boot" Disabled. Now go to "Advanced tab" -> "Video Configuration" -> "Primary Display" PEG. Now go to "PCI Expless Graphics" -> "Aways Enable PEG" Enabled. Save and Exit bios.

From here you have completely disabled your integrated graphic card and will run only on Nvidia. Keep in mind that you will need to use DDU to remove the old Nvidia drivers and then install the modified one. You will need to disable the DSE in Windows in order to install them. When installing the drivers install only display adapter drivers and PhysX, nothing else.

PS. It is not required to pull your card. If you are stuck with 8 beeps just remove the CMOS battery and hold down the power button for more then 30 secs. Do it with your clock on hand 'cause it seems an eternity. Then power on and do the steps above. Only pure UEFI will work.

  • Thumbs Up 1

Share this post

Link to post
Share on other sites

Thank you!!! :triumphant:

I don't know how or why but this time it worked!

I was quite sure I've tried all and every option, even the configuration you posted, but I was wrong.

As I said I already had unlocked bios A11 correctly flashed. Now the system is in PEG mode, there's only one video card and with a different hardware ID from before (in Windows Device Manager) so I had to mod again the drivers and reinstall them but then everything went smoothly!

Performances are improved greatly since before: I'm impressed I can play The Witcher 3 at Ultra configuration with such a great framerate.

Thank you again, phobos! :Banane47:

P.S.: now max card temperature can reach 88°C. What about yours?

Share this post

Link to post
Share on other sites

You are welcome!

I never saw mine over 70. But have to say that the most demanding games I run so far are: Watchdogs, Shadow of Mordor and Crysis 3. Don't know how bad/heavy Witcher 3 is.

Share this post

Link to post
Share on other sites

How did you get the second advanced menu in BIOS?  I have BIOS A13 and there's only 1 advanced menu?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Guardian241
      So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

      Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?
      Thanks for any help you can give.
      - M
    • By ReverseEffect
      3dMark11 Performance Preset Benchmark: http://www.3dmark.com/3dm11/11262792
      Required items:
      1.) Lenovo u310 (I have a Core i3 - Ivy Bridge, 8GB RAM)
      2.) 65CN99WW unwhitelisted.
      3.) eGPU (I used a EVGA GTX 750 Ti from another computer I had).
      4.) EXP GDC mPCIe Edition adapter (got from eBay - banggood seller).
      5.) ATX power supply (I used a 600W PSU from another computer I had).
      6.) USB wireless.
      7.) External monitor, keyboard, and mouse.
      1.) Obtain and install a unwhitelisted BIOS. If you are unable to obtain a unwhitelist BIOS, I think it might be possible to bypass it with Tech Inferno Fan's Setup 1.x (may need confirmation as I haven't used it myself yet.)
      2.) Shutdown computer and remove all USB devices, ethernet cables, power cables, card reader cards.
      3.) Remove mPCIe wireless card and detach antennas.
      4.) Attach EXP GDC external mPCIe cable to the former wireless slot and screw down.
      5.) Attach HDMI end of the mPCIe cable adapter to the EXP GDC device.
      6.) Attach graphics card to the EXP GDC device (I moved my laptop off the desk and onto the side shelf to make room on the desk for the monitor/keyboard/mouse).
      7.) Using the power cable adapters that came with the EXP GDC device, I hooked in my ATX power supply's 20 pin and CPU 4 pin cables. Then hooked the other end (8 pin) into the EXP GDC device. My EVGA 750 Ti also required that I use an additional PCIe power cable (6 pin) in the top of the card.
      8.) Then I attached my misc devices (HDMI monitor, USB keyboard/mouse/wireless adapter), and hooked in my PSU and powered it on (below is image of final product, also moved HDMI cable out of the way).

      9.) Power on your computer and let it install the standard VGA drivers and then install your drivers (I didn't have to go in the BIOS for any graphics settings, which it doesn't have anyways, nor did I have to disable iGPU in Device Manager before the card was added).
      Extra Info:
      I found that most games will play on med settings with about 45 FPS with this particular card.
      BDO: Upscale on - Anti Aliasing on - SSAO off - med settings.
      Skyrim: Med-High settings.
      Fallout 4: Med settings.
      (EDIT 5/19/2016) > Images added.
    • By Brentjuh2000
      Who can help me with modding and getting my 980M working?
      I replaced the M6100 that was originally in the laptop with a 980M but I can't seem to get it to work. I keep getting Code 43
      the Hardware ID : PCI\VEN_10DE&DEV_13D7&SUBSYS_15CD1028
      I heard i need to modify and INF file but i have no experience with it
      The vBIOS is from MSI
    • By blancaster
      does anyone know why a vbios file  8mb in size for nvidia k80 , myu backup bios is only 256kb
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.