Jump to content
EwinRacing Flash Series Gaming Chairs

[Windows 10] on Clevo Laptops Issues and Solutons

Recommended Posts

I did this around 5x and it didn't work.

Could this be related to my 157SM not supporting the 970M by default and requiring a INF edit?

I guess trying a driver with modded .inf wouldn't hurt. Guide here:

1. Go to laptopvideo2go.com

2. Click "Drivers" tab

3. Go to Device Manager -> Display Adapters -> "Properties" of GTX980M -> "Details" tab

4. Select "Hardware Ids" from the drop-down menu

5. Copy required values from "Hardware Ids" to laptopvideo2go "Search terms" field

6. Set other search parameters at laptopvideo2go, as desired

7. Click on "Filter"

8. Download latest modded .inf file from laptopvideo2go.com and the latest NVidia driver

9. Unpack the driver

10. Copy (or replace) the modded .inf file into the folder, where you unpacked the driver

11. Run the driver installer

12. Reboot

13. Enjoy clear.png

Anyone else experiencing Win10 capping fps at 60 when using DX11 applications? I'm using P170EM w/980m.

Try disabling VSync in NVIDIA Control Panel :)

Share this post

Link to post
Share on other sites

I have a Clevo P570WM, and I was surprised that Windows 10 actually fixed something for me. On windows 8.1, even after countless uninstalls and reinstalls of the driver, the hotkey program (that lets you customize the keyboard lighting) would crash on startup and not be able to be launched until restarting the computer multiple times in order to get a colored keyboard other than the default solid blue. Upon upgrading to Windows 10, this crashing has stopped. Why? I don't know, but it's a fantastic thing. So I'm someone that actually had a positive experience with a Windows 10 upgrade and Clevo hardware/software. However, I have had multiple negative issues with non-Clevo hardware (creative soundcard namely, which still hasn't been fixed even with windows 10 drivers), so Windows 10 has still been an overall negative experience for me. Does anyone know how to downgrade back to 8.1? :P

Share this post

Link to post
Share on other sites

Go to the main Settings menu in Windows 10, click “Recovery,” then click “Go back to Windows 8.1.” Follow the on-screen instructions.

  • Thumbs Up 1

Share this post

Link to post
Share on other sites

Hello there,

has anyone got the clevo w370ET laptop, successfully upgraded to windows 10?

I always get error code 0xc000000f.

I tried every possible way. Windows Update, GWX, usb stick, dvd disk. I also tried from windows 8, windows 8.1 and clean install of windows 8.1.

I can do clean install of windows 10 just fine, but windows don't activate unless you upgrade.

I have tried more than 20 times so far, but nothing!

Share this post

Link to post
Share on other sites

My Sager NP8651 has two problems

1)Because of heat from CPU,the left side of the keyboard are sticking , i have the problem with "W" key which i use more because of games

2)the paint is coming off from the laptop chassy at the spot where i rest my hands

i would have inserted a image but i cant

Share this post

Link to post
Share on other sites

upgraded P150SM from Win7x64U to Win10x64Pro.

apart from few drivers that needed to be updated, all went perfectly fine.

the biggest problem was with the keyboard that stopped working immediately after upgrade, so had to use usb external to upgrade hotkey.

loving it so far.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.