Jump to content

Throttling issue with 970m


Recommended Posts

So I took the plunge, and bought a 970m. Got it all up and running, but the GPU is throttling in every game I try and run.

Has anyone had this problem and been able to overcome it?

So far I've...

  • Tried a couple of different driver versions (345.20 and 347.88). Neither driver fixed the issue.
  • Flashed with the slv7 vbios. Still the same issue.
  • Reinstalled Windows 8, and tried the drivers again. Still not working.
  • Tried forcing P0 P-State in nVidia Inspector. Nothing happens.


  • Using MSI Afterburner, the GPU load never goes above 50%.
  • nVidia Inspector shows the P-State as P1 whenever I'm in a game, not P0.
  • 3DMark11 score is only ~P4000


  • Alienware M15x
  • Core i7 920XM (standard clocks)
  • GTX 970M 6GB with slv7 vbios
  • 8GB RAM
  • Windows 8.1 Pro (fresh install)
  • 240W PSU

Can anyone help? I'm completely stumped at this point...


Link to comment
Share on other sites

It might be due to Windows 8.

Are you sure you don't have another system setting overriding the performance state? Windows 8 has a few extra power management (and other setting) convolutions than Win 7 did.

Do you have CC installed? Do you have AlienFusion active?

Have you monitored the temperature of the GPU while under stress?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.