Jump to content

My BAD experience with Y510P


Recommended Posts

Hi, I bought this laptop because it was in October 2013 the best choice for me. It had a new i7-4700MQ Haswell, a powerfull GT 755M GPU that can handle any game, a FULL HD screen, 8GB of RAM, plenty of space, backlit keyboard, even a M.2 cache SSD to boost up the performance of the OS and some programs, and a new Intel Wireless-N 7260 card (300Mbps) PLUS Bluetooth 4.0. I like Lenovo/IBM, pretty solid devices. I trust on Intel (trusted...), I needed a powerful machine, so I purchased it.

The first impressions were good, stunning screen, beautiful design, fasty fasty...

I started to see some weak points: it's noticeable wider than any 15" laptop, Num Lock was not always activated at startup, really BAD touchpad, Dolby Home Theater v4 was not that great (stock drivers), the screen should be more stable (hinges should be tougher holding the screen unmovable)...

Then I changed the touchpad driver by UltraNav one, HUGE difference, much better experience, much better features. Nice.

Then I discovered the REAL DEAL of the Dolby Home Theater v4, when I installed the drivers from a Thinkpad driver's page. Much better sound, when watching films it makes a huge difference. Really a MUST-HAVE.

Then I noticed that the wireless card wasn't that good. Intel Wireless-N 7260 has a shitty range, it is worse than any of my different laptops or smartphones. I don't really know if it's this WiFi card or if it's a Lenovo's fault. I've contacted to Intel and they say that if I have WiFi range problems, I have to ask Lenovo for a solution, and it's probably an antenna issue. Nevertheless, it was "good" enough, so I didn't care too much. In 5 months of use I've not had a WiFi problem at all, just lower signal than the rest of my devices. Well, sometimes there have been issues, yes, but I've solved them. I don't know if they were because of the antenna, or Windows 8.1 or the drivers.

BTW, I've always been using generic drivers, and the latest ones, except audio drivers (Dolby) and Touchpad (ultranav). All was up to date, 7260, bluetooth, GPU...

Then I noticed that Windows 8.1 was great, but it has some huge fails: WiFi interface (notification bar, lower-right corner) is pure pure pure SH*T, it's like I had a tablet, the menu, the lack of options (well, it has just like 2 options), the lack of information, the network scan... My Android smartphone shows more detailed information about networks than that. To see more detailed information, you gotta go to Control Panel, Networks, search WiFi card and right-click.

Windows Store is just unbelievably bad, you can't clear installed apps, it's laggy, sloppy, and slow. Here again, Android's Google Play is WAAAY better than it.

Then I've found 2 programs that are not too friendly with Windows 8.1, and it annoys me, and the admin notifications sometimes drive me crazy, but meh, more or less I love Windows 8.1 once you "delete" Metro screen and install Classic Shell and use this OS as W7.

Then I discovered the Energy Management stunning option to improve the battery life SO much. It charges the battery to 60% and then it doesn't use it or charge it, so I have almost a brand new battery after 5 months. Then I find out that when I remove the battery, that options is reset. Then I find out that when you use the laptop without AC, it's bugged, cause it says that the battery is going to last 4h when you have 60% of the battery (surfing, YT, forums...), and then it lasts 1h, because the battery drains from 42% to 10% in less than 20 seconds. It's fixed with a battery gauge reset, which is done through Energy Management, and it lasts almost 6h after doing that (with 100% battery). But I think that the issue of the battery drain comes again after a full discharge of the battery, or at least the battery doesn't last as long as it should be. Really impressive battery life (for a normal use), but bad software management.

Another issue I had was that when I turned off the laptop, backlit keyboard didn't turn off, and the laptop never shut down. So I had to press the ON/OFF button for a few second to force shut down. After a few weeks, it has never happened. It was a driver problem, I think.

But the first real issues came:

First, I had to restore my laptop because of a Windows Update KB2919355. I SWEAR that 890MB update is so messed up, it's a joke how corrupted it is. After 2 days contacting to Microsoft, even TIER 2 (the most expert agents of Windows support), controlling remotely my laptop, tried to fix the issue, and nothing. They said that I had to freaking RESTORE my laptop. Just because an update wasn't working. Great MS. As it was impossible to solve, I had to do it. BTW, their reply was "this error says that the update is corrupt, and we don't know how to fix it. It happens RANDOMLY, it's not your laptop, we've been facing this issue in other laptops". Randomly. Wow, Windows Update is now Kinder Surprise, you can update correctly or you can open the Kinder and corrupt your OS, hell yeah.

Second, my WiFi range mysteriously is reduced (more than usual) to the router/modem's room. If I wasn't in the same room (where the signal was good-best and it worked nice), signal was poor and VERY unstable. I gotta say that my ISP replaced my modem 1 day ago before this occurred, but since every single device (3 laptop's with different OS, smartphones...) worked perfectly with it, it was a problem of my laptop. After trying out a lot of drivers, rolling back, original ones, the newest ones... I gave up and restored. I also tried Intel's PROSet utilities, and the same.

Third, after restoring, I didn't install any software, first I checked my WiFi range, and it had changed to it's previous range (kind of what the hell, without touching anything but my laptop). I started to updating Windows 8.1 x64 through Windows Update, everything automatically and restarting when it asked me to, and BOOOM, after 49 updates, there it came that mother ***** corrupt update again and the same error again. Restore again, Windows update, fail again, that same update. Just about call Microsoft again, try one more time, restore, Windows Update, and worked, installed correctly.

Now I'm facing a new problem. I've updated everything (drivers too) but Intel 7260 drivers and Bluetooth drivers of the same card (so I don't touch any thing related to the WiFi range, though latest drivers of both devices were working great days before my ISP replaced the modem). When I add a new device to my Bluetooth devices, a BSOD appears, restarts my laptop and DELETES my official, stock, original and untouched Bluetooth drivers. I go to device manager and there's no Bluetooth there.

I install the latest BT drivers from Intel.com, and after restarting, device manager is still not showing any BT device. And those drivers are the ones I've been using for 5 months. May be they don't work If I don't update my 7260 card. But I'm not doing that.

I've installed the drivers from lenovo.com, that are newer than the ones that come when I restore to factory status. Apparently, the issue is solved, cause I've added a device now. After sending some files and check that it's working, I delete the device and try to add it again. BSOD appears, I go nuts. After it has restarted, I check device manager and I see a Bluetooth error, that wasn't there the last time I checked. Windows error code 43. I restart, reinstall the web official drivers again, disassemble the back of the laptop, unplug the WiFi card (7260 where's the Bluetooth too), reconnect the 2 black and white wires, and FOR NOW it's solved.

BTW, after 5 months, I've never had a problem with Bluetooth, though I've been using the latest BT drivers all the time: 17.X.X.

Man, I don't know if it's Windows 8.1, hardware, Lenovo's software design... but I wish I don't have any other problem related to this laptop, ever.

Some questions here:

1. The Wireless card antenna is in the same card or it's in the laptop? I've read that it's in the screen of the laptop. My point is, if the range problem is a antenna's issue, changing the card won't do anything.

2. With my BIOS v3.07, I can't change the Wireless card, right? I have to install a new version, isn't it?

Link to comment
Share on other sites

Then I changed the touchpad driver by UltraNav one, HUGE difference, much better experience, much better features. Nice.

Can you give more info on this one? Is is some king of fan driver?

Link to comment
Share on other sites

I don't think so. I have another Windows 8.1 laptop, x64, and the WiFi range is nice. And it has no problems at all.

NEWS: OMG, I don't know what the hell is going on. I had an stable WiFi connection, poor range as always, but the "normal" range of this card in this laptop. I was looking at all the options of the WiFi card, through control panel. I right-click it, Status, Wireless Properties, tick "Enable Intel connection settings", configure, and I enter to a menu that I have never seen. I see that the first option is about the WiFi bands. It was in mixed, and I select 2.4GHz, and may be with that I could have a better connection. It doesn't really matter, and I try the other option, 5.2GHz. My modem does not support this band. I'm unable to connect to it, and you can't access to that previous menu if you're not connected to a network. Great Intel, great.

I decide to install the drivers that Lenovo provides in a partition of the laptop, called Lenovo. Intel It's supposed that those drivers are the ones that come when you restore the system, so, they are the same drivers I had 10 minutes ago. I install them so the settings get reset and the band is MIXED.

And... again, I'm dealing with the same range problem. I can't connect to my modem if I'm not 4-5m close. If I go to the next room, connection fails. I have in that room a W7 laptop and it has 5 out of 5 of signal strength and reaches the top speed of downloading/uploading. Nevertheless, I'm able to connect to a router I have in one of my rooms, more or less with the same strength that my other laptop. BUT while in the W7 I get 7Mb/s, in the lenovo I get 5-6Mb/s. So there's STILL something wrong. It's not just my modem. I can't believe that a 3 years old low-middle end laptop can achieve better values than this laptop.

Link to comment
Share on other sites

i dont think its a windows problem, i have win8,1 on my secondt laptom toshiba and i have superior range to other laptops, like new HP, lenovo,.

My y510p have 3/4 of range, but its not that bad, but ... wifi killer 1202 waiting on desk

Link to comment
Share on other sites

Well, My bad experience with this laptop came in the worst kind of issues... Creating Recovery Media under Windows 8.1. Every time I followed the steps on screen and while on telephone with the tech support guys from lenovo, I encountered an error which just stopped me from finishing the creation of media. At the end I was so irritated, I decided to use a Disc Cloner, Got my old laptop's HDD on, cloned the HDD and I use that to reinstall whenever I feel I need to do some surgery on my Laptop.

Works Like a charm.

Link to comment
Share on other sites

The WiFi problem is weird, really weird. During 5 months, I've been using the latest drivers every time. No problems with WiFi or Bluetooth at all, though the range was worse than the rest of the laptops and devices I have. But I'm not sure because I've been using the laptop in the same room during that time. Once, that Windows update corrupted my OS, so I restored to initial status. Then WiFi still was as "good" as always. My ISP then changed my modem, and mysteriously, my range is reduced, and I couldn't connect to it unless I was in the same room. The thing is that ALL my other devices work great. And for now, the only drivers or whatever it is that works are the initial status's ones. I was wrong, these drivers are:

Link to comment
Share on other sites

Can you give more info on this one? Is it some kind of fan driver?

Unfortunately, I don't have it right now because I formatted the HDD and I don't know where I got it. I'm asking in lenovo forums so I can install it (the UltraNav that had three finger tapping to open right-click menu).

I'll let you know if I find them.

Link to comment
Share on other sites

  • 1 month later...

Do you have a link for that sound drivers used for your laptop?

Thank you.

I have this driver for "Speakers (Realtek High Definition Audio)":


This one for "Realtek High Definition Audio":

Yeah, in Device Manager there are 2 different Realtek devices related to sound. The one you wanna change is the second one.

First you have to install the original Audio drivers for the Y510P, in lenovo.com. A file named "raudio113w8". Although I have a Windows 8.1 x64 Y510P, I installed the Windows 8 driver:

Laptops and netbooks :: IdeaPad Y Series laptops :: IdeaPad Y510p Notebook - Lenovo (US)

Once you've completely installed the driver (I think I had to reboot 2 times), you install this driver named "gaas05ww":


And you finally get a functional Dolby software :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.