Jump to content

need help, think I fried my m18xr2


Recommended Posts

OK, flashed some timings that did not work to one stick of my g.skill ram. Still had a good stick so I used these instructions:

1: take off the keyboard

2: remove all ram except for a low grade working one.

3: put it in the bottom slot. (under keyboard)

4: boot to bios and set 1333

5: shut down

6: get jacked up ram ready for insertion...

7: turn on computer and wait 2 seconds and insert jacked up memory.

8: boot to windows

9: this is the trickey part...make sure you flash the right one because TB can read both memorys.

10: once flashed, shut down and turn off. turn on and boot to bios. that stick should now be showing.

As soon as I put in the incorrectly timed stick, the laptop shut down. Now when I power on the laptop with known good ram in any slot, the fans come one, keyboard lights up and the computer reboots, never completes post. With bad ram, it does not reboot or complete post. Tried resetting bios by taking out cmos battery, still no go.

Any other suggestions or a place where I can get a r2 board that doesn't cost $600?

Link to comment
Share on other sites

  • Moderator
Thank you for the link' date=' but I need a m18x R2 board. Sorry, should have made that more clear. If you find any reasonable, send them my way, thanks![/quote']

Lol, sorry. I'm a bit tired.. I saw it was the m18x in your first post..

Link to comment
Share on other sites

Have you tried with another stick of RAM that wasn't in the laptop when this happened?

EDIT: Here's a mobo at a decent price INTEL i7 MOTHERBOARD rPGA989 GRP9C 0GRP9C for DELL ALIENWARE M18X R2-in Motherboards from Computer & Networking on Aliexpress.com

Thanks for the link, I did look at that one. I even contacted the seller just in case. And yes, I did try two other sticks besides the one that was in the laptop (the other g.skill.) No joy, unfortunately. Thinking about trying our reflow oven at work. Not sure all the plastic connectors can take it though. Appreciate your help!

Link to comment
Share on other sites

So the bios was the issue? Interesting. Glad you got it working.

Sent from my GT-N7000

Thanks! Yeah, somehow I managed to corrupt it. I thought for sure the board was a goner. I have to say these forums are great! Without the help, I would have dropped hundreds on a new board for sure.

Link to comment
Share on other sites

I heard that the m18xr2 monitor has the wrong connections to change the laptops non 3d screen to a 3d screen or am I wrong? I'd also love to have 3d on y m18xr2 that would save me a lot on buying a 3d monitor unless it costs more to buy the 3d screen that is lol. I'm glad that your lappy is now working and I also agree Mr. Fox is very good at helping others and he's lovely hehe.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.