Jump to content

"No drives were found." in Windows 7 Installation


Recommended Posts

Okay guys, I'm really stuck. My desktop PSU went bad probably about a year ago, (I thought the computer was completely fried) so I took out the HDD and began using it as an external hard drive. I formatted it, and used it however I needed it. I finally got around to repairing my desktop, and it now works. So I formatted the HDD again, and put it back into the desktop. When I attempt to install Windows 7 via a disk, however, I get this error: "No drives were found. Click Load Driver to provide a mass storage driver for installation." I attempted to find drivers and install them onto a USB to allow me to use the HDD, unfortunately none of them worked though. I have absolutely no idea what to do now. Any help would be appreciated!

Here are some specs:

HP Pavilion a824n

PTGD1-LA motherboard

Western Digital WD Caviar SE WD2000

One final note: When I click "Load Driver" then click "Browse" it detects the HDD, so I don't believe the HDD is faulty. Thanks again!

Link to comment
Share on other sites

  • 4 weeks later...

Here are some things to try/check ....

(1) does the drive still work as an external drive?

(2) have you checked your jumper settings on the drive? i.e., is it set as master, slave, cs select?

(3) have you tried another port on your motherboard?

(4) does your bios detect the hard drive? are there any bios settings you need to enable/disable?

(5) when you formatted it, did you do it as mbr or gpt?

Link to comment
Share on other sites

  • 3 months later...

There might be some obscure firmware embedded onto the hard drive when the drive was used as an external drive. You can grab a low level format utility that will erase everything except the manufacturers code section, run that and see if it helps. Alternately, make sure you're not using a RAID slot or some other specialized port on the motherboard by accident. If you're using just an SATA port by default, try load driver and pick the Microsoft SATA driver or the Intel SATA driver and see if that happens to kick it over. Dumb as it might sound, double check the cables are in there securely and all the way in at both ends.

Link to comment
Share on other sites

  • 1 year later...
  • 1 year later...

I had the same problem a few months ago. You are probably trying to install it via an USB 3.0 port, right?


Win7 doesn't have the USB 3.0 drivers, you need to install it on a 2.0 port or embed the USB 3.0 drivers on the ISO.


Here you can download the drivers:



A tutorial on how to do it:


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.