Jump to content

MSI GT60one not detecting graphics card Nvidia GT680m PLEASE HELP.

Harsh Wardhan

Recommended Posts



i recently bought msi gt60 one 403, online from xoticpc.com .

i am facing this following disorder after a recent update of Nvidia GTX680m driver from nvidia's official site:

the laptop has stopped detecting nvdia graphics card after I installed an update from windows update and started using the intel hd 4000 graphics card.

I tried uninstalling and re-installing the drivers but none worked. While reinstalling the error popped up stating " No supported hardware found".

Later I restored the notebook from windows restore disc but still the problem remained same. Same error message popped up while re-installing the driver.

Now the card isn't listed in the device manager under Display Adapters which wasn't the case earlier.

under system devices in the device manager, i see Xeon® processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port - 0151

what is this?? even dxdiag is showing intel hd 4000 as my default card. attached are some screenshots showing the above issue.


what is the issue and how to resolve this problem??PLEASE HELP.




Link to comment
Share on other sites

That sucks, OP.

One of my friends had this exact same problem.

First thing first, this problem WON'T happen on Windows 7. We tested a dual boot of fresh installs, and his pc detected the gpu fine on 7 but not 8.

Update your windows as much as you can, because this is a problem that reared its ugly head in the early days of Windows 8 release. I'm willing to be your computer contains an early RTM build, which appears to be one of the problems (since they're not updated as far as newer releases of the same build).

If that doesn't work, disable optimus in your bios, and load safe mode with vga. This will force your laptop to use windows drivers on your nvidia card. Since it will now be recognized, you can go ahead and install the driver.

Link to comment
Share on other sites

  • 1 year later...

I also encountered this issue with the same scenario. I tried the above steps however the bios are locked down such that I can't access optimus. The BIOS are extremely locked down from what I can tell. Any additional thoughts that I may try before I completely nuke it and start over?

Link to comment
Share on other sites

Which BIOS version and which GT60 you have exactly? I recently had a GT60 0NC here, where I wanted to install a GTX780M, there were similar problems. Only with the latest bios (51X) everything went without hesitation and directly plug and play.

Link to comment
Share on other sites

  • 1 month later...

hi itzzent,

Im having a similar issue with a gtx 770m on my GT60 E16f3IMS, i managed to get it detected by flashing vbios to msi stock bios, but after updating the drivers the system BSODed so i disabled it now, this is the card i got if it helps! Nvidia GeForce GTX 770M 3GB DDR5 MXM 3.0 Type B for MSI Alienware | eBay

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.