Jump to content
EwinRacing Flash Series Gaming Chairs
sgtrobo

garbage wifi on Y580

Recommended Posts

My rig:

IdeaPad Y580

i7-3610

8 GB PC12800

240GB Mushkin SSD (Win7x64 Pro, SP1 installed)

1 TB Seagate 5400 RPM

nVidia GTX 660M (2GB)

and importantly:

Intel Centrino Wireless-N 2200 BGN 2x2 HMC WiFi/Bluetooth Adapter

Driver 15.3.1.2, 30 September 2012

D-Link DIR-825 router

as you can guess from the title, I'm one of the many dissatisfied customers with this laptop due to the wifi. I actually am quite pleased with the laptop otherwise, but the wifi performance is terrible. Dropped signal, random disconnect/reconnects, performance fluctuations, etc. I'd like to get a new network card for the laptop as I believe that 2200 is probably the source of my issues, but from what my untrained mind is reading, it might be impossible, because even if I do install a new card, the BIOS will booger up on me?

Share this post


Link to post
Share on other sites
Yeah, it looks like lenovo put a whitelist on cards that can be installed
the wifi is very buggy at times, I disabled n and it seems a bit more stable now.

whitelist is disabled using the unlocked bios @svl7 kindly provided. That effectively allows you guys to install any wifi card

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

i have Y580 with i5 and SSD, but only problem with wifi for me is: week ago i had bsod, after boot to windows icon of wifi was pernament "not connected" though i was connected. I don't know what to do with that.

Share this post


Link to post
Share on other sites

This was an old post... I believe most of the issues regarding flashing are resolved, as the BIOS for Windows 8 was released (the one that shipped with the newer configurations of the Y580). Please correct me if I'm wrong.

Will be flashing this weekend if all goes well.

Share this post


Link to post
Share on other sites
This was an old post... I believe most of the issues regarding flashing are resolved, as the BIOS for Windows 8 was released (the one that shipped with the newer configurations of the Y580). Please correct me if I'm wrong.

Will be flashing this weekend if all goes well.

slv7 posted a modded version of the Win8 BIOS (v8.00 & v8.01) but they are not posted on Lenovo's site, which makes flashing a bit scary for me esp since I'm a noob. If anything goes wrong I wouldn't be able to recover the BIOS via USB

Share this post


Link to post
Share on other sites

It is weird so you many of user are complainnig about the stock wifi. What router are you guys using? I am using dd-wrt and tomatos w/ Broadcom based chipset and not experiencing any drop out, lag or slow speed. Maybe I am one of the few lucky one. Have you tried the latest driver from intel.com?

Share this post


Link to post
Share on other sites

My 4 year old Acer laptop have stronger signal compare to my new lenovo y500, And the problem is i cant change the wifi card i need cause it is whitelisted.

Share this post


Link to post
Share on other sites

yeah, i have the latest updated drivers, used multiple routers. i have issues connecting all over the place, either at my home router (DIR-825) or on public networks (i.e. Starbucks, hotel chains, etc.)

I ended up getting a TP-Link USB wireless adapter and it works 100x better, but it's still annoying. I'm just going to get a hacked BIOS and install a real wifi adapter internally. Really strange because the laptop is an absolute beast in everything else, but the wireless is just terrible

Share this post


Link to post
Share on other sites

The unlocked BIOS that slv7 made works flawlessly, just make sure you follow directions closely and flash the correct version.

I installed a centrino 6205 and it is working great.

Share this post


Link to post
Share on other sites

the wifi chip in mine seems to cut out for a few seconds every 10-15 minutes or so. and its not even a couple months old.

Share this post


Link to post
Share on other sites

I don't believe it's purely an issue with the WiFi card. I had a T430 with a 6300 ultimate that had the same dropout/need to restart every time issue.

Share this post


Link to post
Share on other sites

I have a ddwrt router, and I get random disconnects every 15 minutes when I'm upstairs. However, when I'm close to the router it's fine.

My previous laptop didn't have this issue.

Share this post


Link to post
Share on other sites

Stock WiFi card in my Y580 has been working flawlessly, have one with the newer 8.XX BIOS versions. Looking forward to flashing the faster 660m BIOS and eventually upgrading my Wifi card. Sometimes I think that these issues with computers are in the hardware itself, faulty computers and whatnot. I have been fortunate enough to be problem free!

Share this post


Link to post
Share on other sites

A lot of people complain about the poor quality of the internal WiFi. Laptop design can significantly affect your wireless performance. Lenovo makes the design error of Wi-Fi cabling and routing it right near the CPU and GPU noise generators. So the right RF cable routing may solve the problem.

Share this post


Link to post
Share on other sites

I've got a Centrino 2230 in my Y410P and it has caused me nothing but headaches from the start. I've got a fresh Centrino 6235 to replace it, but like others, am waiting on getting a BIOS which is opened up to allow hardware modifications. Once I have it, I'll gladly post back here to share how my connectivity has changed, if at all.

Share this post


Link to post
Share on other sites

I've been having problems for the last 9 months with it and my resolution is to restart. ( I have a SSD so only a few seconds :D )

But my school just upgraded all their wireless to the state of the art nice stuff 5GHz but this thing only has 2.4 and its iffy so i bought a Intel 622ANXHMW Centrino Advanced-N + Wimax 6250 on ebay for like $10 when i found out that Lenovo y580 had a whitelist. So when im approved to download the files im gona give the mod Bios a go.

Thanks to slv7.

Share this post


Link to post
Share on other sites

I have the same problem which occurs around 4 times a day. Extremely annoying. I'm hoping to install a new wifi adapter once I flash my bios.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.