Jump to content
EwinRacing Flash Series Gaming Chairs
Xonar

MSI G-Series Unlocked BIOS

Recommended Posts

so i managed to flash the bios but i have a major problem, it seems it wasnt happy or went wrong as now it wont POST and just has blank screen. Is there any chance a kind soul or souls would reply back to me to help a brother out in his time of need.

I'm 'normally' quite technical however i feel i may have done goofed and bricked my mates gaming laptop!

Should i make a new thread somewhere to get help?

Thanks.

Share this post


Link to post
Share on other sites

Hey you guys, just wanted to ask if the file "MSI GT70 Unlocked.zip" is actually the correct one for me.

i have a MSI GT70 0NC

Mainboard: MSI MS-1762

System BIOS: AMI (OEM) E1762IMS.105 03/14/2012

Processor: Intel® Core i7-3610QM CPU @ 2.30GHz

17'' display

i am just confused by the descrition of "3rd-gen core-i" and don't really want to mess it up with the wrong bios version

greetings

Thomas

Share this post


Link to post
Share on other sites
Hey you guys, just wanted to ask if the file "MSI GT70 Unlocked.zip" is actually the correct one for me.

i have a MSI GT70 0NC

Mainboard: MSI MS-1762

System BIOS: AMI (OEM) E1762IMS.105 03/14/2012

Processor: Intel® Core i7-3610QM CPU @ 2.30GHz

17'' display

i am just confused by the descrition of "3rd-gen core-i" and don't really want to mess it up with the wrong bios version

greetings

Thomas

Yes, the file "MSI GT70 Unlocked.zip" is actually correct for your laptop.

Share this post


Link to post
Share on other sites

Hey everyone,

my MSI GT70 0NC is not working anymore. The Graphics Card is destroyed by an overheated chip. To change my fan speed, I need a unlocked Bios for that ?

Is it right, that I also need the "3rd-gen core-i" Bios version .30 ?

Thanks for your help ;)

Share this post


Link to post
Share on other sites
Yes,the 30M is the right one for GT70 ONC

But it will not give a chance to change fan speed.

Fan speed adjustment in EC firmware.

Share this post


Link to post
Share on other sites
But it will not give a chance to change fan speed.

Fan speed adjustment in EC firmware.

So what you mean is even if I flash my GT70 with the unlocked bios I won't be able to control the fan speed without updating EC firmware? Is it possible to just flash the EC?

Basically I'm having the issue where I removed my faulty GPU from the GT70 and the fan goes full blast after a few seconds while its on the integrated gpu.

Share this post


Link to post
Share on other sites

I have replaced the motherboard in a GT60

i used an MEDION MS16F3 X682X

bios version E16F3IM7.101

EC Version 16F3EMS1 Ver 4.14

the GTX 670M is bad and i removed it until i can replace to prevent mainboard damage.

I would like to have my fan not spinning 100% does the MS16F3 bios http://forum.techinferno.com/attachments/msi/10736d1390945397-ms16f3.zip work for these needs?

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

to follow up i purchased a subscription and have downloaded the bios

booting successfully with a pile of options now if anyone would direct me in the right one for getting the fan to spin normal on an ms16f3 when without a GPU it would be appreciated

my EC is 16F3EMS1 V 4.14 and i did not touch it yet

Share this post


Link to post
Share on other sites

set Primary Display to iGFX and that's all what you need (default is SG if i good remember)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
set Primary Display to iGFX and that's all what you need (default is SG if i good remember)

yeah i ended up doing that yesterday actually after much goofing about found it was not in a submenu but in the big one on the first page about half way down.

very much appreciated followup Debianik

Share this post


Link to post
Share on other sites

Hey guys, I'm trying to slow down my fan from spinning and like a leaf blower after removing a faulty GPU. I installed the unlocked bios from the first page here on my GT70 everything seems alright. Downloaded and installed the EC firmware from MSI's website, unplugged AC power and battery for ~20secs and it is still uncontrollable. I am missing something? I tried searching for the " set Primary Display to iGFX" in the bios setting, as mentioned in a few comments before, but couldn't find it! Hints/suggestions would be much appreciated!

~blood

Share this post


Link to post
Share on other sites
Hello

Another Bios don`t Change this.

You don`t must take out the Card.

You must only deactivate the GPU in the Device Manager.

Hey Bloetschkopf, thanks for the response! If I dont take my GPU out, my laptop won't turn on at all. I want to use my integrated intel graphics until I get a new GPU but the fans spin max speed all the time! Device manager doesn't give me any option to disable the nvidia gpu since its not physically there I had it's drivers uninstalled.

post-37615-14495000597496_thumb.jpg

Share this post


Link to post
Share on other sites

@blooddrunk

set Primary Display to iGFX and that's all what you need (default is SG if i good remember)

it's hidden or available in main menu under System information (all hidden options should be available in one place)

if not grab https://www.google.com/search?safe=active&q=AMIBCP+4.53&spell=1&sa=X&ved=0CBoQBSgAahUKEwjuls6mpfjGAhXKkSwKHXx-DqQ&biw=1664&bih=840&dpr=1.15 AMIBCP 4.53

grab you bios and change that settings and ofcourse flash with that new bios

Share this post


Link to post
Share on other sites
@blooddrunk

it's hidden or available in main menu under System information (all hidden options should be available in one place)

if not grab https://www.google.com/search?safe=active&q=AMIBCP+4.53&spell=1&sa=X&ved=0CBoQBSgAahUKEwjuls6mpfjGAhXKkSwKHXx-DqQ&biw=1664&bih=840&dpr=1.15 AMIBCP 4.53

grab you bios and change that settings and ofcourse flash with that new bios

There is no such option in Xonar's unlocked bios under hidden. Is AMIBCP 4.53 compatible with MSI GT70 0NC?

I tried fanspeed and Fncontrol by dave p. nothing seems to work.

Share this post


Link to post
Share on other sites

fanspeed not helps in this case - you need to disable in bios dedicated gpu

its for sure available but probably hidden , amibcp im used in gt60 3gen few times, friend use in gt70 also 3gen - then in compatible

Share this post


Link to post
Share on other sites
Hello everyone,



I bought a laptop and the description was "MSI WHITEBOOK MS-1761-ID1 17.3 inch LED Barebone Notebook-Intel HM67 Express Chipset-Socket G2-Core i3, Core i5, Core i7 Support-Full HD Display-Seria [ASIN: B0058RLB1C]"

It came with a NVIDIA GeForce GTX570M. It didn't have a CPU, HD, or RAM when I bought it. I had an i7 2.0 GHz Sandybridge, 2HDs, and 8 Gb of RAM from a previous MSI laptop. I read that "whitebooks" could not use MSI factory BIOS. In searching for a BIOS, I found this forum.



My computer works fine. Although, my BIOS is acting funny. Whenever I access it, I don't have control over it. It switches screens on its own and doesn't allow me to move to pages I want or choose options I want.



Windows 10 says this about my BIOS in System Information:



BIOS Version/Date American Megatrends Inc. E1761IG6 V3.0H, 11/18/2011

SMBIOS Version 2.7

Embedded Controller Version 255.255

BIOS Mode Legacy

BaseBoard Manufacturer Micro-Star International Co., Ltd.




So, do I have a "Retail" or "Whitebook" ? It would appear from the table on Page 1 that I have a Retail version of Bios. Or am I reading the numbers wrong? :disturbed:













































































2nd-Gen Core-i:



Retail:

S-GT780/783(17''):

.30H MSI GT783 Unlocked.zip

Whitebook:

MS-1761(17''):

3.06 MSI MS-1761 Unlocked.zip





Two other questions.........



#1) After I flash the BIOS with the new files can I use a SSD in my system. I get mixed reviews about using one in this motherboard. It has 2 HDs (RAID non-enabled) and I would like to get one for my OS drive.

#2) I currently use 16 Gb (4x4Gb) of Patriot RAM in the system. Could I upgrade that to 32 Gb?



Thank you in advance for your help!!!! :smilingface (52):



R. Jimenez

Share this post


Link to post
Share on other sites
No! Do not try! Your laptop is 4x generation. There are no bioses for the new generation of MSI laptop.

ok.

thanks 4 your answer,.

Share this post


Link to post
Share on other sites

For SSD you don`t Need Bios Update,SSD will work also without Bios update.

Sandybridge i7 supported 32GB Ram.

You can use the MSI Bios,if it don`t work right you can Change back or try the Bios for Whitebooks.

I use in every Ms-1761 (Erazer,Hyrican) the MSI Bios without Problems.

You also can use the Raid Bios,normaly the MS-1761 Boards have the Raidcontroller inside.

Share this post


Link to post
Share on other sites

Bloetschkopf,

Thank you very much for that info!

If my original BIOS wasn't acting funny, I wouldn't even bother messing with it.

Do the BIOS files listed contain files for RAID?

Thanks again.

Share this post


Link to post
Share on other sites

Man I am really hoping flashing the 16f2 bios will fix this little problem I am having. When i boot up sometimes my gpu is not detected and i get nothing but a black screen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.