Jump to content
EwinRacing Flash Series Gaming Chairs
Sign in to follow this  
Apollo93

Lenovo Y50-70 throttling issues.

Recommended Posts

Hello everyone,

 

I have a Lenovo Y50-70 touch, i7-4700, gtx 860m. I'm having some throttling issues with games on MINIMUM settings. Most games, load up screens and such are causing major stuttering. I'm running them windowed right now to monitor values on nvidia inspector and throttlestop. MSI afterburner isn't giving me much information. 

I'm getting PL2, EDP and POWER errors on throttlestop. Active throttling.

Here are some timestamps and data.

          DATE     TIME      MULTI  C0% CKMOD BAT_mW  TEMP    VID      POWER

2021-02-11  00:56:32  31.97   18.7  100.0       0                 59   0.9537   19.9   EDP

2021-02-11  01:18:33  31.93   90.8  100.0       0                 78   0.9259   46.4
2021-02-11  01:18:34  31.96   92.6  100.0       0                 79   0.9244   46.1
2021-02-11  01:18:35  31.61   99.3  100.0       0                 78   0.9259   47.5   PL2
2021-02-11  01:18:36  31.57   97.3  100.0       0                 80   0.9050   47.4
2021-02-11  01:18:37  31.40   94.1  100.0       0                 79   0.9219   47.3
2021-02-11  01:18:38  31.55   90.9  100.0       0                 80   0.8866   47.1
2021-02-11  01:18:39  31.47   92.2  100.0       0                 80   0.9244   47.5   PL2

2021-02-11  01:21:13  31.98   53.9  100.0       0                 90   0.9160   40.6
2021-02-11  01:21:14  31.87   61.3  100.0       0                 92   0.8962   41.6
2021-02-11  01:21:15  31.43   86.4  100.0       0                 93   0.9170   45.6   PL2
2021-02-11  01:21:16  31.54   89.7  100.0       0                 93   0.9160   46.1
2021-02-11  01:21:17  31.20   92.3  100.0       0                 94   0.8962   46.1   PL2
2021-02-11  01:21:18  31.31   92.3  100.0       0                 95   0.9148   46.5   PL2
2021-02-11  01:21:19  31.45   88.2  100.0       0                 93   0.9148   46.6
2021-02-11  01:21:20  31.38   85.6  100.0       0                 95   0.8612   45.9   PL2
2021-02-11  01:21:21  31.16   90.8  100.0       0                 94   0.9148   46.2
2021-02-11  01:21:22  31.65   87.2  100.0       0                 94   0.9160   46.3   PL2

 

 

 

 

If anyone has any ideas or advice, please don't hesitate to tell me.

I'd like to avoid buying a new computer, but I've had this unit for about 5-6 years.

When I first bought it, it did have to get serviced due to a motherboard failure. I did notice the lack of processing power though, it always felt kind of slow after that.

Share this post


Link to post
Share on other sites

It is throttling due to power limit. PL2 = Power limit. I do not own Y50-70 but i do own the predecessor Y510p and there is a way to bypass this limit but it'll not help in your case as your temps are already very high. Even a slight increase in power limit will push temps to 100 degrees easily. Let's assume you have improved the cooling and bypassed power limit, still you might get limited by current throttling (EDP). There is no way to bypass EDP in your system.

 

In short, you can improve cooling a bit and get a bit more performance but you cannot bypass the throttling limits. Blame lenovo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By TetroM
      Hello everyone,
      My new laptop Thunderobot Zero 11800H_RTX3060 have a locked bios. I tried CPU undervolt via ThrottleStop utility and Intel XTU utility, but they didn't work. I heard I need to unlock advanced settings in BIOS to unlock these utilities. So, I need help to unlock hidden advanced settings. Thanks!
    • By Blackyhimself
      Hi guys,
       
      Apologies for posting on multiple forums. I cant seem to get ThrottleStop to work since reinstalling windows 10.
       
      Previously Throttlestop seemed to be the only way to get the Turbo Boost functioning and it was working well. I was running the m15x with an i7920XM and 7970m and all working great (after a minor BIOS blip with the 7970m). However, I hadn't used the laptop for about a year (built a new desktop) and wanted to get it ready to sell (hence the clean Windows install). I've now reinstalled windows and ThrottleStop but now the multiplier doesn't seem to change no matter what settings I tweak. It just stays at a multiplier of 9 which kind of defeats the point of having the i7 Extreme.
       
      Has anyone come across this? Maybe i'm just forgetting something (its been a while). Maybe I've installed it wrong?
       
      Set Multiplier ticked and set to 16T, Disable Turbo unticked, Power Saver unticked, TRL set to 26, 25, 20, 20.
       
      Please help!
    • By Kanyeezy
      Hello!
       
      I have a Lenovo Y50 with a shitty Wifi-Card and i wanted to unlock the BIOS, so i can replace it with a better one! Now I saw there are Instructions for the Y500 but none for the Y50! Is there a possibility for me to unlock it on my own, or do I have to rely on other Users on this Forum, who know how to do it? Greatly appriciate any help regarding that matter :/. My BIOS is on V1.13 by the way.
    • By Retrorockit
      I overclocked My Dell Dimension E520 QX6800 up to 3.99Ghz using Throttlestop software.
      http://valid.x86.fr/l2j5p1
       I'm of course thrilled with this result. But I'm having a few issues with TS and I thought this might be the place to get answers  since many here have used the program.
      In Windows XP all my setting would be saved when I shut down and rebooted. In Windows7 at first I had to ask permission from Windows security to run it. So I turned that down to minimum. It still wouldn't load by itself. But if I wanted it it was a click away, so for browsing I left it off and used it as needed.
       Now I've had a Window Critical Update. TS runs in taskbar without WS badge there, but it loses my overclock at random times. I find EIST turned off, and I have to reset VID , and Multiplier to apply it again. I'm wondering if going to the Throttlestop 8.00 beta would help, or are there some settings I could apply to get it to save my settings at startup. Due to a cooling mod my computer throws a fan fail message at boot so I prefer to use sleep mode as much as possible. So it's important that my setting are recovered there also.
       
      I received a reply to this from Unclewebb at a post about Throttlestop8.00 beta at Overclock.net.  
    • By Sspawn26
      I recently installed my new 780m. I started playing Arma 3 and I watched my temps climb to 90c pretty quickly. The card throttled itself like it was supposed to and the game started to lag. I tabbed out to look at PrecisionX and try and set a new fan curve because they wouldn't turn on. Then, all of a sudden, the fans turned on pretty high and dropped the temps down to 52c rapidly. I was able to play for a couple of hours with no problem. I tried to start up DayZ and the fans wont turn on at all after sitting at 90c for a while.
      Whats going on? How do I get the fans to turn on before it reaches 90c for an extended period of time?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.