Jump to content
EwinRacing Flash Series Gaming Chairs
svl7

AMD 7970m - modified VBIOS

Recommended Posts

Anyone has experience with Windows 8 with M17x or laptop with 7970m ? Did Windows 8 has the boot menu , for us to set which devices boot first , so that we could Flash the vbios ? Reply ASAP thanks

Share this post


Link to post
Share on other sites

Anyone has experience with Windows 8 with M17x or laptop with 7970m ? Did Windows 8 has the boot menu , for us to set which devices boot first , so that we could Flash the vbios ? Reply ASAP thanks

Share this post


Link to post
Share on other sites

The boot menu only depends on the bios... So Win8 won't change anything when it comes to this.

Share this post


Link to post
Share on other sites

i think i found a way to stop the screen flickering while on the desktop, i used the ov1075v.bios and then overclocked the card to 1000/1550 the screen would flicker, i then ran gta 4 from steam for about an hour and now the screen has stopped flickering, im not sure whats the cause of this, but im thinking it may be a driver issue, svl7 have you ever heard of this before ?

Share this post


Link to post
Share on other sites

Seems so... it's weird, but I really think in this case it must be software related.

Share this post


Link to post
Share on other sites

so you dont think it has to do with the 2d clocks then ? i cant understand why this is happening

i now have access to your vbios patcher and i will be testing higher 2d clocks and 2d voltages, i really want to thank you for all that you have done and released to the public. my performance is outstanding now. and so far no screen flickering even after a few rounds on bf3 with the settings on max, love it

Share this post


Link to post
Share on other sites

ok so after playing around with the vbios patcher and messing with some 2d overclocks i managed to patch a very stable vbios on my 7970m. the settings are

core 3d 1000

memory 3d 1500

voltage 3d 1075

core 2d 350

memory 2d 250

voltage 2d 850

no flicker what so ever, and because i never take this laptop off my coolermaster sf-19 i don't mind the higher clocks/temps @ 24/7 idle 47ºC / load 71ºC very happy with the overclock now, thanks again svl7

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

ok so after some massive testing and many different vbios flashes i found the best settings for stability, 1000 core 1500 memory.

core 3d 1000

memory 3d 1500

voltage 3d 1125

core 2d 300

memory 2d 150

voltage 2d 850

the other settings i had in the previous post was stable until i ran furmark for about 10 min, the screen started getting artifacts then the driver crashed, i also tried 1.1v and this also made the driver crash, i guess my 7970m needs more juice to overclock well. the extra 25mV to the 2d voltage stopped the screen flicker and my 2d to 3d transition is now working, before the gpu would stay at 2d clocks while running a game in full screen. i will continue testing until i hit my wall, but i have a feeling that this is the best stable overclock i can achieve on my system

Share this post


Link to post
Share on other sites

Don't run furmark, problem solved. Furmark is useful for only one thing - killing GPUs. It stresses the voltage supply circuits way beyond any scenario, without actually completely loading the GPU. It really doesn't make sense using this tool, same with Kombustor.

Share this post


Link to post
Share on other sites

Max before it shuts down automatically is 105-110°C, can't remember exactly. But that's not really a healthy temperature for your GPU, try staying below 80-85°C. The lower the better.

Share this post


Link to post
Share on other sites

Mine is installed, but I"m having some issues. I'm installing a fresh version of Windows right now. I need to get up to 5 posts so I can download the patcher.

Share this post


Link to post
Share on other sites

Hi svl7,

I would like to try 1.175 on my 7970m, I have tested that voltage with a software mod (changing the profile xml file with ccc).

It seems I should be able to handle the temps.

Could you please mod my clevo vbios (attached to this post) to set the frequency to 1200mhz and the voltage to 1.175 please?

Share this post


Link to post
Share on other sites

SLV7 Can you look at my VBIOS for my 7970M. It's for the G73JH upgrade so it should have enduro disabled. I'm getting that weird flickering and then it shuts off like I told you in PM. I'd like to try again but only if there is something you see wrong with the VBIOS. I tried to use MSI combuster and it shut down when it got to 71C. That was the start of the issues I'm having now. Did I kill my card?

https://www.dropbox.com/s/h702yvqqeisyejs/7970M.zip There is the 7970M ROM

Here is the video:

http://www.youtube.com/watch?v=QF1XpgdNj6g&feature=g-upl

Share this post


Link to post
Share on other sites
SLV7 Can you look at my VBIOS for my 7970M. It's for the G73JH upgrade so it should have enduro disabled. I'm getting that weird flickering and then it shuts off like I told you in PM. I'd like to try again but only if there is something you see wrong with the VBIOS. I tried to use MSI combuster and it shut down when it got to 71C. That was the start of the issues I'm having now. Did I kill my card?

https://www.dropbox.com/s/h702yvqqeisyejs/7970M.zip There is the 7970M ROM

Here is the video:

What happens when you run it in safe mode? Also, are you already running a modded vbios or is it the stock one? If its the stock one, you could try changing the voltage (either higher or lower) and/or clocks using vbios patcher to see if that has any effect. If not, then I'd guess the card is the problem or your mainboard. Either way it might be a good idea to contact whoever you bought it from and see if you can get an RMA.

Share this post


Link to post
Share on other sites

Hope you get it working on the g73, I'm hoping to drop in a 7970m in my g73 in the future. Right now, the first upgrade it needs is a new screen. What manufacturer made your mxm card? I hear clevo is the way go on the g73. I heard issues with the dell one.

Share this post


Link to post
Share on other sites

That is a modified one that sosa106 and robtherob are using on NBR. When I try to open it with the patcher, it errors out and doesn't work. I think the card might just be dead though. This is what it looks like now:

http://www.youtube.com/watch?v=JZFDwLBas7s&feature=g-upl

I might just try it one more time, just to see what happens.

Share this post


Link to post
Share on other sites

hey Svl7, did you find the time needed to look into the newer vBIOS version some of us posted back in Summer yet?

Share this post


Link to post
Share on other sites
1.2GHz? Wow... let me see some benches... :D

Looks like I was a bit optimistic, couldn't get past the login screen.

If you have some time, could I please try 1.1Ghz @ 1.175V instead?

Share this post


Link to post
Share on other sites

Thanks again for the modded bios!

I don't know why, but still I can't get past the login screen, it will just BSOD.

I know it's happy with 1.075V and 1030mhz.

Also I know it's happy with 1.175V and 1030mhz.

Why would 1.175V and 1100mhz not work?

Maybe I should try stock clocks and 1.175V and see if the overclock is too high?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By Klem
      Klem's_vbios_MSI_GTX770M_80.06.54.00.11_UNLOCKED
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked Power Limit.
      3. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      4. Increased Power Limit and Power Target.
      5. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
    • By Klem
      Klem's_vbios_ASUS_GTX870M_80.04.F4.00.01_UNLOCKED
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked Power Limit.
      3. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      4. Increased Power Limit and Power Target.
      5. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
    • By Klem
      Klem's_vbios_MSI_GTX880M_80.04.EA.00.03_UNLOCKED.rar
      For both, 4Gb and 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked Power Limit.
      3. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      4. Increased Power Limit and Power Target.
      5. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.