Jump to content
EwinRacing Flash Series Gaming Chairs
Klem

Lenovo ThinkPad T440p / T440s/ T540 / E440 / E540 unlocked BIOS menu / wlan / wi-fi whitelist mod

Recommended Posts

55 minutes ago, Klem said:

Your unlocked bios done. I sent it to you in a new PM. Check please.

Thank you very much. I have tested and all is working as expected.  I would love to know your secret on how it is done. I tried patching and unlocking myself, but could not. Lenovo T440 with BIOS version 2.54. Everything unlocked and Wifi card unlocked / whitlisted. I have installed AX210NGW WiFi Card, Wi-Fi 6E 11AX Wireless Module. And it works!  I tried for hours to unlock on my own... couldnt figure it out!

Once again, love your work. Thank you

Share this post


Link to post
Share on other sites

Is it possible to unlock battery check (Whitelist) on W541? I have a branded aftermarket battery and got error message on boot. Won't charge.

 

IMG-0331.jpg

Edited by feherhollo

Share this post


Link to post
Share on other sites
1 hour ago, feherhollo said:

Is it possible to unlock battery check (Whitelist) on W541? I have a branded aftermarket battery and got error message on boot. Won't charge.

 

IMG-0331.jpg

 

Hi!

Restrictions on the type of battery are located in the EC firmware (not in bios). But I don't work with EC firmware.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
7 minutes ago, sxjiangq said:

Hello Krem,

Thank you so much for your work.

I have a Lenovo T440 ,Can you please help me patch and whitelist, unlock advanced menus and UEFI sign

 

Bios dump is here: https://mega.nz/folder/pb5WCLzL#T4TwN5WoNaSdZNx-RIHl7w

Hi!

In Lenovo ThinkPad T440, any modified bios can be flash using hardware SPI programmer only, exactly the same as described in the first post of this thread.

So, for creating backup (dump) of bios you need to use hardware SPI programmer only.

Share this post


Link to post
Share on other sites
12 minutes ago, Klem said:

Hi!

In Lenovo ThinkPad T440, any modified bios can be flash using hardware SPI programmer only, exactly the same as described in the first post of this thread.

So, for creating backup (dump) of bios you need to use hardware SPI programmer only.

This is T440 Bios dump: https://mega.nz/folder/pb5WCLzL#T4TwN5WoNaSdZNx-RIHl7w

 

Share this post


Link to post
Share on other sites

Hello Klem!

I have updated t440p bios to the newest version while having AX200 Intel Wifi Card by accident.

Would you be so kind to unlock the bios with all the mods you have listed?

Bios dump link: https://1fichier.com/?2u8pa9tlp93xtvn82r2c (first time working with SPI Programmer and test clips, so I hope I did it right).
Thank you so very much!

Share this post


Link to post
Share on other sites
22 hours ago, Emberiza said:

Hello Klem!

I have updated t440p bios to the newest version while having AX200 Intel Wifi Card by accident.

Would you be so kind to unlock the bios with all the mods you have listed?

Bios dump link: https://1fichier.com/?2u8pa9tlp93xtvn82r2c (first time working with SPI Programmer and test clips, so I hope I did it right).
Thank you so very much!

Hi!

Ok. Your unlocked bios done. Check PM.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello
I have a damaged bones batch bios Laptop T440P
after starting 5 x beep and the black screen turns off
I would need a bios batch with ME Region cleared
I can rip the batch just waiting for the ch341 programmer

Share this post


Link to post
Share on other sites
14 hours ago, robercikfred said:

Hello
I have a damaged bones batch bios Laptop T440P
after starting 5 x beep and the black screen turns off
I would need a bios batch with ME Region cleared
I can rip the batch just waiting for the ch341 programmer

Hi!

Did you save your bios dump before it got corrupted?

Share this post


Link to post
Share on other sites
10 hours ago, Klem said:

Hi!

Did you save your bios dump before it got corrupted?

Hi

Unfortunately, I do not have a copy of the bios, I got it in this condition for repair
eventually it will try to upload from another working laptop and run
Kosc will desolder and record a new 25Q32FV
I will not move the original, but as I wrote, I am still waiting for the CH341A programmer

Share this post


Link to post
Share on other sites

amazing!

Edited by tuye

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By rajsinghfan
      UEFI BIOS Version: GJETA4WW (2.54)
      UEFI BIOS Date (Year-Month-Day): 2020-03-37
      ME Firmware Version: 9.5.60.1952
      Embedded Controller Version: GJHT30WW (1.14)
       
      I need Battery Authentication whitelist Removal because my laptop showing "the battery installed is not supported."
       
      Result.rar & .rom file: https://www.mediafire.com/file/byxsoqpg4j3od25/result_rar_and_rom_file.zip/file
    • By biuro74
      Hi,
       
      So I've landed here to get some help with unlocking my old laptop. I must confess I've done few mods before, but it was on PCs, so was a piece of cake - adding Xeon to supported CPU models, or updating OROM to get a system boot from RAID SSDs. But now I'm trying do "the same" with laptop first time and this is a nightmare, mostly due to multiple BIOS vendors/methods, each of which requires own tools, some works with older revisions, some don't, some require 32-bits, some don't, and all YT examples being done using various configs = so in the end: a mayhem.
       
      My laptop config is:
      Lenovo B570e, i5-2520M, 10GB RAM
      BIOS: 44CN43WW (latest, unmodified), SMBIOS 2.6
      Phoenix/EFI SLIC Mod indicates it is an EFI/Insyde BIOS, but entering the BIOS I've got "Phoenix SecureCore Tiano" info
      WLAN: original damaged, a replacement (by chip) doesn't allow laptop to start - Error 104 Unsupported wireless network device...
       
      All I've found so far was:
      * Universal BIOS Backup Toolkit 2.0 - to make a BIOS dump file (succees)
      * UEFI Tool - to load dump file, search required module and extract it (success)
      * WinHex - to search an assembler code boundaries, and extract it (WinHex will not save edits = unregistered version), so semi-success
      * Hex Editor Neo - to disassembly code, and probably make changes (so far: in progress:))
       
      And I've stopped at searching the JZ/JNZ mnemonics, probably this is because I've got wrong code boundary (from WinHex), which gives improper disassembled program in preview pane. What I'm looking for is a loop, which I try to obey - regarding to some "popular" links describing this method (unfortunately I can't follow these instructions 1:1 as some programs don't work as supposed and crash - like WinHex, yup, some don't work at all and I need to use different tool).
      One more frustrating thing is I can't find proper tool for final stage - which is good (working) flasher. I can't remember how I've reflashed BIOS previously - must have been years ago - but now PhoenixUEFIWinFlash makes a BSOD (original, executable BIOS downloaded from Lenovo support website uses this program, which shows its GUI for a moment and makes BSOD), and "external", latest Phoenix UEFI WinFlash program doesn't want to work properly at setting up stage. Probably I will have to use phlash16 and FreeDOS, but will see at the end, when I have modded BIOS completed.
       
      Any suggestions (or even better - some ready, modded file), please ?
       
      Thanks in advance for any help, I appreciate any clue.
    • By DoenerBoy123
      Hello guys 
       
      I've got a pretty weird problem with my M18x R2. I already searched the web but couldn't find an answer. A few days ago I changed some settings in the bios, if I remember correctly DMVT Pre-Allocated.
      After saving this setting the notebook refuses to even POST. I get no beep errors or anything. If I press the power button the system turns on, the leds turn on and then the system shuts itself off. I already reset the cmos, the IME, tested different configurations and so on. If I remove all the memory sticks I actually get the memory error code. At this point I'm pretty sure that the bios got corrupted for some reason when saving these mentioned settings. Did anyone had a similar problem and got a solution for this? I repaired lot's of notebook but never had an error like this...
      The Bios installed is the a15 unlocked.
    • By Malenford
      Is it possible to unlock bios on that model? Please help me with it if somebody can.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.