Jump to content
EwinRacing Flash Series Gaming Chairs
Klem

Lenovo ThinkPad T440p / T440s/ T540 / E440 / E540 unlocked BIOS menu / wlan / wi-fi whitelist mod

Recommended Posts

8 hours ago, Klem said:

Hi!

Ok. Check PM.

I think my messages only allows 1 new message from you.. so I deleted all the messages... are you able to provide URL to download the unlocked BIOS for me please?

Share this post


Link to post
Share on other sites
3 hours ago, ssj47 said:

I think my messages only allows 1 new message from you.. so I deleted all the messages... are you able to provide URL to download the unlocked BIOS for me please?

Your unlocked bios done. I sent it to you in a new PM. Check please.

Share this post


Link to post
Share on other sites

Thank you! I am testing now... 

Share this post


Link to post
Share on other sites
55 minutes ago, Klem said:

Your unlocked bios done. I sent it to you in a new PM. Check please.

Thank you very much. I have tested and all is working as expected.  I would love to know your secret on how it is done. I tried patching and unlocking myself, but could not. Lenovo T440 with BIOS version 2.54. Everything unlocked and Wifi card unlocked / whitlisted. I have installed AX210NGW WiFi Card, Wi-Fi 6E 11AX Wireless Module. And it works!  I tried for hours to unlock on my own... couldnt figure it out!

Once again, love your work. Thank you

Share this post


Link to post
Share on other sites

Ok. Thanks for your feedback.

Share this post


Link to post
Share on other sites
Posted (edited)

Is it possible to unlock battery check (Whitelist) on W541? I have a branded aftermarket battery and got error message on boot. Won't charge.

 

IMG-0331.jpg

Edited by feherhollo

Share this post


Link to post
Share on other sites
1 hour ago, feherhollo said:

Is it possible to unlock battery check (Whitelist) on W541? I have a branded aftermarket battery and got error message on boot. Won't charge.

 

IMG-0331.jpg

 

Hi!

Restrictions on the type of battery are located in the EC firmware (not in bios). But I don't work with EC firmware.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
7 minutes ago, sxjiangq said:

Hello Krem,

Thank you so much for your work.

I have a Lenovo T440 ,Can you please help me patch and whitelist, unlock advanced menus and UEFI sign

 

Bios dump is here: https://mega.nz/folder/pb5WCLzL#T4TwN5WoNaSdZNx-RIHl7w

Hi!

In Lenovo ThinkPad T440, any modified bios can be flash using hardware SPI programmer only, exactly the same as described in the first post of this thread.

So, for creating backup (dump) of bios you need to use hardware SPI programmer only.

Share this post


Link to post
Share on other sites
12 minutes ago, Klem said:

Hi!

In Lenovo ThinkPad T440, any modified bios can be flash using hardware SPI programmer only, exactly the same as described in the first post of this thread.

So, for creating backup (dump) of bios you need to use hardware SPI programmer only.

This is T440 Bios dump: https://mega.nz/folder/pb5WCLzL#T4TwN5WoNaSdZNx-RIHl7w

 

Share this post


Link to post
Share on other sites

Hello Klem!

I have updated t440p bios to the newest version while having AX200 Intel Wifi Card by accident.

Would you be so kind to unlock the bios with all the mods you have listed?

Bios dump link: https://1fichier.com/?2u8pa9tlp93xtvn82r2c (first time working with SPI Programmer and test clips, so I hope I did it right).
Thank you so very much!

Share this post


Link to post
Share on other sites
22 hours ago, Emberiza said:

Hello Klem!

I have updated t440p bios to the newest version while having AX200 Intel Wifi Card by accident.

Would you be so kind to unlock the bios with all the mods you have listed?

Bios dump link: https://1fichier.com/?2u8pa9tlp93xtvn82r2c (first time working with SPI Programmer and test clips, so I hope I did it right).
Thank you so very much!

Hi!

Ok. Your unlocked bios done. Check PM.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Hello
I have a damaged bones batch bios Laptop T440P
after starting 5 x beep and the black screen turns off
I would need a bios batch with ME Region cleared
I can rip the batch just waiting for the ch341 programmer

Share this post


Link to post
Share on other sites
14 hours ago, robercikfred said:

Hello
I have a damaged bones batch bios Laptop T440P
after starting 5 x beep and the black screen turns off
I would need a bios batch with ME Region cleared
I can rip the batch just waiting for the ch341 programmer

Hi!

Did you save your bios dump before it got corrupted?

Share this post


Link to post
Share on other sites
10 hours ago, Klem said:

Hi!

Did you save your bios dump before it got corrupted?

Hi

Unfortunately, I do not have a copy of the bios, I got it in this condition for repair
eventually it will try to upload from another working laptop and run
Kosc will desolder and record a new 25Q32FV
I will not move the original, but as I wrote, I am still waiting for the CH341A programmer

Share this post


Link to post
Share on other sites

amazing!

Edited by tuye

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By DoenerBoy123
      Hello guys 
       
      I've got a pretty weird problem with my M18x R2. I already searched the web but couldn't find an answer. A few days ago I changed some settings in the bios, if I remember correctly DMVT Pre-Allocated.
      After saving this setting the notebook refuses to even POST. I get no beep errors or anything. If I press the power button the system turns on, the leds turn on and then the system shuts itself off. I already reset the cmos, the IME, tested different configurations and so on. If I remove all the memory sticks I actually get the memory error code. At this point I'm pretty sure that the bios got corrupted for some reason when saving these mentioned settings. Did anyone had a similar problem and got a solution for this? I repaired lot's of notebook but never had an error like this...
      The Bios installed is the a15 unlocked.
    • By Malenford
      Is it possible to unlock bios on that model? Please help me with it if somebody can.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.