Jump to content
EwinRacing Flash Series Gaming Chairs
Mivas

Windows 7 on Intel Core 8th generation???

Recommended Posts

Hi! I registered for the specific topic. So, the big question for which I found no answer in internet.

 

Windows 7 on Intel Core 8th generation.

 

Officially, Intel supports windows 7 up to 6th generation. Unofficially, with an easy trick up to 7th generation. The question is, how can we make it work on 8th generation?

 

I installed windows 7 Ultimate 64bit on my new DELL Inspiron 5770 high end non-gaming 17 inch laptop, without any issue apart from the integrated GPU (Intel UHD Graphics 620). This also blocks the functionality of the AMD Graphics card too.

 

So, since for many reasons I want to have windows 7 instead of windows 10 or Linux, I did my best but I got stuck. I created a hybrid driver from 2 different versions of official Intel drivers, the latest, which supports this iGPU, but only on Windows 10 and the last windows 7 compatible, which does not include support for the specific 8th gen processor/graphics card, since it is newer. I mixed some files and also edited the inf file from the old driver.

 

I will share with you what I did, so that someone who has knowledge might get 100% functionality. I get only partial.

 

So, here is my guide.

 

1. Download the last Win7 compatible driver from Intel for HD Graphics. It is the version win64_15.45.19.4678
2. Download a newer version which is win10 only but contains the driver for your processor. In my case, Intel Core i7 8550U with DEV_5917. I downloaded the latest driver.
3. Make copies/backup of both folders and save elsewhere before starting editing.
4. Unzip both. From the unzipped ones, go to the new driver folder, then Graphics, then copy all components and paste in the Graphics folder of the old (15.45.19.4678) version. Note; So far in my case I didn't play a role if I replaced the same names of the old files with the new ones or skipped them to keep the old ones. Exception; do NOT replace the igdlh64.inf file and the igdumdim32.dll
5. Find the DEV number of the processor. Device Manager (from Control panel or search), right click on generic VGA Adapter, properties, details, ID.
6. Open the igdlh64 file (with a notepad) from the new version (Graphics folder) find the DEV number under windows 10 and copy the whole line.
7. Paste it under the Windows 7 section in the igdlh64 file of the old driver and correct the ikbl win10 with iskl win7 (known trick for 7th gen).
8. Copy all lines that include the 4-digit number from the igdlh64 file from the new driver and paste in the respective sections of the igdlh64 of old driver. In the end of the text, also add the name of the driver as a label, eg Intel UHD Graphics 620.
9. Install the modified old driver (win64_15.45.19.4678) and reboot.
10. After reboot. Copy the igdumdim32.dll file from the Graphics folder of the new version and paste it to the C:\Windows\SysWOW64 replace the existing files

 

This way, I get all resolutions, full brightness, colour, contrast etc control of the display, intel graphics control panel, full windows 7 effects (aero glass etc), but I dont actually get video support (apart from 3rd party software, like VLC/GOM player which even play 4K video smoothly), 3d applications are not functional, I dont get hardware acceleration etc. I concluded that the solution is to edit the igdumdim32.dll file, so that I copy elements from the new version to the old one. This way, theoretically, it should work. Anyone who has experience with driver and dll modification???

 

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By Qvixot
      Hello everyone! First of all sorry if this isn't the correct forum to post this.
      I bought a laptop few days ago. The laptop is Sager P150EM.
      Cpu:i7 3610qm 
      Gpu: amd hd 7970m
      Ram: 8gb
      Os: windows 8.1 pro
      So my problem is that everytime i install the amd driver after the intel driver my laptop freezes or gets a bsod or something that stops it from working. Any help would be appreciated. I saw somewhere something about vbios does this matter anywhere?
    • By Binarious
      I installed an NVIDIA Quadro P4000 Max-Q in a Clevo P750DM-G.
       
      Device manager hardware ID shows:
      PCI\VEN_10DE&DEV_1BB7&SUBSYS_75021558&REV_A1
       
      I have done the standard inf file mod, then disabled driver enforcement as I have done successfully in the past, but it's not working this time. The install starts, then fails less than half way through. I have tried the DCH version, standard version, and studio versions and none of them will work. I am probably missing something. Could it be the result of the vBIOS?
       
      Below are screenshots starting with GPUz
       

       
       
       

       
       

       
       
       
       
    • By Lisa Scott
      Sometimes, our Computer becomes very slow and gives tough time to make work on it. This makes slow because of hard drive holding the plenty of data, files. So, to make faster speed clear the some space.
      Some background applications or programs running make computer slow.
      Remove or disable any TSRs and startup programs that automatically start each time the computer boots. 
      Scan for Malware and Adware, if your system infected by them.
      Uninstall Programs You Don’t Use
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.