Jump to content
EwinRacing Flash Series Gaming Chairs
ChillAlarm

m18x r2 GTX 980m upgrade

Recommended Posts

Hey all,

 

I'm going to be upgrading my m18x r2 from dual radeon hd 7970m's to a single gtx 980m. Ordering an upgrade kit today from here that should arrive in 3 days or so. 

I've taken it apart before but all parts are original thus far. I've noticed this is a pretty common topic here on TI but haven't found a straighforward guide. I'm planning to

document the upgrade as I go along to serve as that guide. My plan as it stands right now is this: Flash swick and SVL7's A11 unlocked BIOS, teardown and replace the cards

more or less following this guide, rebuild and check that I didn't screw anything up too terribly, and flash prema's vBIOS. As of now my next step is downloading the latest 

nvidia drivers and modifying them for my system following this guide, but if that doesn't work I may just revert to using j95's modded drivers

 

 

My specs are:

PC: Alienware m18x r2

OS: Windows 10 Home

CPU: Ivy Bridge Intel i7 3630QM

RAM: 12GB Dual Channel DDR3

HD: 1TB RAID 0

GPU: 7970m Crossfire (sadly dead)

BIOS: A11(stock)

 

 

For flashing the BIOS and vBIOS you have to create a bootable dos usb. I found a great guide for that here.

Edited by ChillAlarm

Share this post


Link to post
Share on other sites

 

I'm having a little trouble getting a hold of premas vBIOS so can anyone recommend an alternative?

Would this one from SVL7 work?

Share this post


Link to post
Share on other sites

 

A little more research done and now I'm beginning to doubt this whole complicated process.

From the forums here and here it seems like I don't need to jump through so many hoops.

Just update to A12 BIOS and pop in the card.

 

Can anyone confirm or deny this?

Share this post


Link to post
Share on other sites

You have an M18xR2 not Alienware 18, two different machines. 

 

You should get this BIOS:

 

 

Also, much cheaper to buy here:

 

http://www.ebay.com/itm/New-NVIDIA-GTX980M-Graphics-Card-8GB-GDDR5-256-Bit-MXM-3-0-GPU-Upgrade-/282591461768?hash=item41cbc38188:g:oHMAAOSwIjJZXvQ0

 

If I remember correctly, with the 980M , all you have to do is flash that BIOS. Turn off, swap cards and it should be good to go. I think the 7970m heatsink also works with 980M but don't remember. 

 

Share this post


Link to post
Share on other sites

@ssj92 Thanks for you quick response!

 

I've got that BIOS downloaded and ready to go as soon as my card comes in. Really I could do it today but don't have a reason to.

 

I read elsewhere that the heatsink should be good but I'll see. Planning to do the upgrade Sunday night.

 

Are you saying that I don't even need to mess with the vBIOS or modifying the drivers?

 

Share this post


Link to post
Share on other sites
33 minutes ago, ChillAlarm said:

@ssj92 Thanks for you quick response!

 

I've got that BIOS downloaded and ready to go as soon as my card comes in. Really I could do it today but don't have a reason to.

 

I read elsewhere that the heatsink should be good but I'll see. Planning to do the upgrade Sunday night.

 

Are you saying that I don't even need to mess with the vBIOS or modifying the drivers?

 

You will need to modify drivers everytime since this isn't an official configuration. If the card comes with a dell vBIOS, I would leave it as is and see how it performs before flashing it. 

Share this post


Link to post
Share on other sites

Hey all,

 

Did the upgrade last Sunday and everything went smoothly. Haven't flashed a modified vBIOS as of yet seeing as I haven't had any major issues thus far. 

All I've done is flashed the unlocked BIOS, installed the new card, and installed the modified driver. Pretty simple in hindsight, just seemed pretty daunting 

at first. 

 

Now my only issue is that I believe my display cable is damaged. That started before my last cards died. I suspect it's the cable because when on integrated graphics

the display works perfectly. But when switched to the discrete graphics the display is fuzzy. Just looks like there's a lot of static, but when connected to an external monitor

it works perfectly. But that's a problem for another day.

Share this post


Link to post
Share on other sites

So am I to understand that if you have the M18X R2 

On 03/08/2017 at 8:07 PM, ssj92 said:

You will need to modify drivers everytime since this isn't an official configuration. If the card comes with a dell vBIOS, I would leave it as is and see how it performs before flashing it. 

I'm literally after the same upgrade this guy is. have the same setup too but on Win 7 64bit. Just my BIOS is A12. Do I still need to move to the A11 unlocked BIO you talk about or does the A12 facilitate the 980m. 

Second question, do I need to buy a 980m with dell vBIOS or would one thats come out of an MSI machine work?

Edited by CryPlz

Share this post


Link to post
Share on other sites

Also does it matter if the 980m has g-sync or not. Is there a preference here?

Share this post


Link to post
Share on other sites

Hi Cryplz,

 

I would say the preference would be non g-sync. I have a 970m gsync and I only get a blank screen if I boot it PEG but it does work in SG / Optimus. Also worth noting latest NVidia hotfix driver now officially supports the 970m / 980m in the M18x R2 so no more driver modifying, but only standard cards not gsync ones.

 

Jon

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Thats good news, am I still looking at not getting a card unless it has come out of a dell machine? As ebay has 2 MSI 980m's that have been in msi laptops. Just worried about buying them and realising later that they dont work in an Alienware m18x r2 

Share this post


Link to post
Share on other sites

any advance on this? unsure whether to go ahead and get an MSI gtx980m, anyone fitted one of these to an M18X R2?

Edited by CryPlz

Share this post


Link to post
Share on other sites
On 21/10/2017 at 3:36 PM, javers said:

Hi Cryplz,

 

I would say the preference would be non g-sync. I have a 970m gsync and I only get a blank screen if I boot it PEG but it does work in SG / Optimus. Also worth noting latest NVidia hotfix driver now officially supports the 970m / 980m in the M18x R2 so no more driver modifying, but only standard cards not gsync ones.

 

Jon

is that SLI they support or just single gpu

 

Share this post


Link to post
Share on other sites

I know this post is old, but I just went from dual 675M to single 980M, I Have the A12 bios (I can't download on this site yet to get the unlocked A11).  I am getting 8 beeps. Is this because of the bios? I am running Windows 10 because I thought with Windows 8 and 10, the maxwell was supported on the R2. Do I need to reinstall the old card and wait to be able to download this BIOS? I have been waiting about a week to get promoted. I am impatient, but I am super excited to complete this upgrade. (Also put in a 1TB SSD!) Please help!!! haha! Thanks!

 

Edit: I now have this working, Thanks!

Edited by Losercore13
Got It working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By bagster
      Hello world...
       
      I was wondering if anyone tried to install a tesla p6 mxm gpu in a laptop. I am looking to doing this - modification- not quite an upgrade  - because I will have to accept optimus - if it will work - nvidia states there is no optimus support, as well as no video output - but I am optimistic - i will try the flash a hex modified bios of a p5000 on it - via spi flasher and see if it will do the trick - the specs and the card itself seem to be identical... but I was just wondering if anyone did this before.
       
    • By Guardian241
      So I just received a 980m in the post and after installing it I was greeted by multiple system crashes on my Alienware m17xr4 and was unable to install new drivers.

      Is there a step in the intallation process I missed? A bios setting I was supposed to change? The laptop is already set to UEFI mode in preperation for this and upon putting the old 680m back in the system it now works again. I have heard that I need to change INI files to install drivers but I expected it to at least function without large bugs such as these. Do you think that this GPU is faulty or have I done something wrong?
       
      Thanks for any help you can give.
       
      - M
    • By Guardian241
      Hi,
       
      I've recently got my hands on an M17x R4 Alienware Laptop from 2013 which I love. I've replaced the screen, keyboard, RAM, and hard drive to make it into a fully modern laptop. However, I'm currently waiting on a replacement for the 680m GPU with a 980m from ebay. My question for you all is, do I need to do anything with the BIOS to make this 980m work? Is there a way to prevent the laptop from using Intel HD Graphics with Optimus? I think the Intel HD Graphics on this laptop are currently broken as I see static-looking dots flash on the screen. (See image below for example). My theory is that because Intel HD Graphics with Optimus is still in-use while in-game, the dots are being caused by it.
       
      Thanks for any help in advance.
       
      - M
       

       
       
    • By Aun
      I am trying to find unlocked bios for overclocking but i cannot find it from a few days please someone help in me. its for my alienware 17 r3 with 970m and i7 6700hq.
       
      my dumped gpu bios
       
      i would really appreciate your help!
       
      and btw rn i OCed thru msi after burner core clock +135 and memory clock +250.
       
      cpu gpuz pic
      gpu pic
       
    • By Miyagi1007
      Hello guys so i bought a used alienware m17x r3 with hd 6870m on it, so when i was trying to boot well it goes to the windows 7 loading screen that says starting windows after that the screen turns white and goes to bsod saying atikmpag.sys
       
      also i attempt to switch my integrated gpu to my discrete card ( hd6870m)  and i wont switch at all 
       
      Responses are highly appreciated 
      Thank you in advance
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.