Jump to content

Lenovo Y580 with GTX 660m don't run dedicated graphics card as default's card


Recommended Posts

Hello guys, I tried everything from removing drivers, installing clean OS, configuring the nvidia control panel, and nothing works. I'm wondering if the dedicated GPU could be taken as main graphics card by Lumion or Rhino for small rendering. I know this card is not high end, but i'm pretty sure I can go betther with this one than the Intel 4000 HD. Pleage give me a hand here.

I just noticed I posted it in a wrong category, help me moving it please. Sorry for that.

Link to comment
Share on other sites

Have we tried adding the executable of the program in 'Program Settings' under 'Manage 3D Settings'?

You could add the program manually and select the GPU in step 2.


Alternatively, if you right click on the .exe file for the program, you might see a ribbon option to 'Run with graphics processor'. From there you can select the GPU as well.

What is the state of the device in 'Device Manager'? Any errors? What version of the NVidia Driver software are we running?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.