Jump to content

What am I missing?


Recommended Posts

Hi all and merry Christmas / happy holidays


I bought myself an unknown laptop. It is called Vision Computer, but has no other name. CPU-Z says the mobo is PBL21, and apparently some Clevo laptops and IBuyPower laptops has this mobo.

Anywho, it works, it's fast and was cheap. It has a 4 core 8 thread intel I7 2720QM, 16 gb RAM, Nvidia gt 540m, ssd and a screen. Note that it doesn't have an iGPU only dGPU.


First I tried to just plug and play. Didn't succeed.


Secondly I did a successful DSDT override, got the large memory, but nope. 


Then I tried some stuff with the DIY setup 1.30 although most of the time, it couldn't connect to the eGPU.


I have successfully installed the drivers, when the eGPU was detected correctly. But it doesn't want to play ball.


Some advice would be nice. :)

Link to comment
Share on other sites

Hi and thanks for replying


Yes I am using an external monitor. I forgot to mention that. But still no image on screen.


The eGPU is an R9 290 from sapphire.

It worked before on my other laptop.

Link to comment
Share on other sites

  • 2 weeks later...

I managed to install the eGPU driver again. I still have the large memory configuration, but the system keeps recognizing it as HD8600/8700M and keeps giving me the code 45 (not plugged in). The DIY consequently doesn't detect my eGPU. 

Can someone please help?

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.