Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

Hey guys i have alienware m17r4 gtx 870m so can you tell me how could i run 375.76!When i try installing it doesnt recognise my gpu! I have disabled my DSE!I cant install any new drivers pls help!At the moment im with 344.75!

Share this post


Link to post
Share on other sites
4 hours ago, HANS VOLKBERG said:

Hey guys i have alienware m17r4 gtx 870m so can you tell me how could i run 375.76!When i try installing it doesnt recognise my gpu! I have disabled my DSE!I cant install any new drivers pls help!At the moment im with 344.75!

Hey there!

 

Check out my post from the 1st of December (page 62). I describe the way I managed to update my driver to the newest one. In the meantime I also updated the PhysX drivers too. I think it might work for you too, as I was rocking even older drivers then you are at the moment. You just do a clean install of your old driver and overvrite it with the new one. Try doing it with Optimus enabled as I did. If the drivers still fail to recognize your GPU you need to modify the INF files yourself. The guide is on the forums here, or here http://tinyurl.com/heuv8le.

Edited by Fetaznapleta

Share this post


Link to post
Share on other sites
17 hours ago, HANS VOLKBERG said:

i have alienware m17r4 gtx 870m

Hello, with this combination you always need modded drivers. It's because Dell never sold this combi and so it's not listed in the Nvidia driver.

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
48 minutes ago, Zoldago said:

Hello, with this combination you always need modded drivers. It's because Dell never sold this combi and so it's not listed in the Nvidia driver.

Yeah, by new drivers we mean the modded drivers from this thread. No official NVIDIA drivers will work. T-thanx Dell...

Share this post


Link to post
Share on other sites
8 hours ago, Fetaznapleta said:

Yeah, by new drivers we mean the modded drivers from this thread. No official NVIDIA drivers will work. T-thanx Dell...

 

9 hours ago, Zoldago said:

Hello, with this combination you always need modded drivers. It's because Dell never sold this combi and so it's not listed in the Nvidia driver.

Thanks for the reply guys!!!Ill will try doing all the stuff when i get promoted because i still cant download anything from this thread!As soon as this happens i will try with the drivers here!Thanks again for helping!

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Hey guys i have alienware m17r4 gtx 870m so can you tell me how could i run 375.76!When i try installing it doesnt recognise my gpu! I have disabled my DSE!I cant install any new drivers pls help!At the moment im with 344.75!

Share this post


Link to post
Share on other sites
Guest
2 hours ago, HANS VOLKBERG said:
Hey guys i have alienware m17r4 gtx 870m so can you tell me how could i run 375.76!When i try installing it doesnt recognise my gpu! I have disabled my DSE!I cant install any new drivers pls help!At the moment im with 344.75!

Have you checked to confirm that your hardware ID is in the INF file?

 

What OS version are you running?

 

By disabling DSE, are you doing that using F8 and choosing "Disable Driver Signature Enforcement" or simply using the bcdedit from command prompt? (Using F8 will still be necessary unless you also use additional "bcdedit.exe /set nointegritychecks on" command to make it complete.)

 

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 10
locale                  en-US 
loadoptions             DISABLE_INTEGRITY_CHECKS
inherit                 {bootloadersettings}
recoverysequence        {b0e9c08e-b894-11e6-83ae-a975ab43e2a0}
recoveryenabled         Yes 
nointegritychecks       Yes
testsigning             Yes 
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {b0e9c08c-b894-11e6-83ae-a975ab43e2a0}
nx                      OptIn 
bootmenupolicy          Legacy

 

Share this post


Link to post
Share on other sites
Guest
5 hours ago, J95 said:

Wrong forum, thanks for asking...

Hi Nephew. Please see PM.

Share this post


Link to post
Share on other sites

GeForce 376.19 & 376.33

 


    *Install drivers at your own risk* Windows 10 + GeForce Drivers are Killing Samsung and LG Notebook LCD Display Panels
      Uninstall PrecisionX, including screen overclocking tools. Instead, keep MSI Afterburner's RTSS for monitoring purposes.

 

       Requirements:

       Flash latest @Prema's v2 980M & 970M (Please consider donating to Prema)


  • Win10/8.1 'F8' Boot options 'Safe Mode' & 'Disable driver Signing'
    cmd (Admin)
bcdedit /set {default} bootmenupolicy legacy

 

        -> reboot -> F8 -> select 'Disable Driver Signature Enforcement' -> Install drivers

  • Run DDU "Clean & Shutdown (Safe Mode)
  • Extract driver using 7-Zip
  • Display.Driver folder,  copy/overwrite the proper .inf file(s).
  • Extracted driver package >> delete the folders as shown below (don't skip this step)  -> run setup.exe  

       >>> Keep these folders only <<<

373.06.PNG

 

 

    INF MOD v376.19 & v376.33

nv_dispi.inf (including nvdmi.inf) PEG/Dedicated All Models: M15x, M17x, AW17 R1, M18x, AW18 R1 (including Optimus/M17xR4) excluding AW 2015 - GTX 980 , 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX , 660M

 

nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M

    

GeForce 376.19 Win 7/8.1


GeForce 376.19 Win10

 

GeForce 376.33 Win 7/8.1


GeForce 376.33 Win10

 

 

Alienware

v376.19

nv_dispi.inf_v376.19_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v376.19_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v376.19_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v376.19_Win10_Optimus_Alienware_17.zip

 

v376.33

nv_dispi.inf_v376.33_Win7_8.1_PEG_Dedicated_Alienware.zip

nvcvi.inf_v376.33_Win7_8.1_Optimus_Alienware_17.zip

 

nv_dispi.inf_v376.33_Win10_PEG_Dedicated_Alienware.zip

nvcvi.inf_v376.33_Win10_Optimus_Alienware_17.zip

 

 

Clevo Laptops (non-Optimus)

v376.19

nv_dispi.inf_v376.19_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v376.19_Win10_PEG_Dedicated_CLEVO.zip

 

v376.33

nv_dispi.inf_v376.33_Win7_8.1_PEG_Dedicated_CLEVO.zip

nv_dispi.inf_v376.33_Win10_PEG_Dedicated_CLEVO.zip

 

 

 

 

AW 900M Throttling workarounds:

M18xR2

First, flash @Swick1981 [Bios Mod] M18xR2 - Legacy Support now Available 

M18xR2 980M workaround

 

Hibernation method HERE and HERE

 

 

Please use the SEARCH function to see if your question has been answered/posted already.

 

https://www.techinferno.com/index.php?/announcement/4-user-account-promotion-rules-read-before-posting/

  • Thumbs Up 6

Share this post


Link to post
Share on other sites
6 hours ago, thegh0sts said:

these modded INFs work great with the MSI 1070 Notebook GPU!

No problem. Now you need to dump that half-baked GPU and try out MSI 1080 (GT73), cable mod & heat sink mod, keeping the chassis intact....:rofl:

 

1080_XXX.PNG

  • Thumbs Up 1

Share this post


Link to post
Share on other sites
3 minutes ago, J95 said:

No problem. Now you need to dump that half-baked GPU and try out MSI 1080 (GT73), cable mod & heat sink mod, keeping the chassis intact....:rofl:

 

1080_XXX.PNG

 

not an easy feat really!

Share this post


Link to post
Share on other sites
On 15.12.2016 г. at 0:01 AM, Mr. Fox said:

Have you checked to confirm that your hardware ID is in the INF file?

 

What OS version are you running?

 

By disabling DSE, are you doing that using F8 and choosing "Disable Driver Signature Enforcement" or simply using the bcdedit from command prompt? (Using F8 will still be necessary unless you also use additional "bcdedit.exe /set nointegritychecks on" command to make it complete.)

 

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 10
locale                  en-US 
loadoptions             DISABLE_INTEGRITY_CHECKS
inherit                 {bootloadersettings}
recoverysequence        {b0e9c08e-b894-11e6-83ae-a975ab43e2a0}
recoveryenabled         Yes 
nointegritychecks       Yes
testsigning             Yes 
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {b0e9c08c-b894-11e6-83ae-a975ab43e2a0}
nx                      OptIn 
bootmenupolicy          Legacy

 

My OS is windows 7 ultimate and yes im doing the f8 and then  "Disable Driver Signature Enforcement" then i did it in command prompt too! Yes my hardware id is in the INF file!

 

Edited by HANS VOLKBERG

Share this post


Link to post
Share on other sites
Guest
11 hours ago, HANS VOLKBERG said:

My OS is windows 7 ultimate and yes im doing the f8 and then  "Disable Driver Signature Enforcement" then i did it in command prompt too! Yes my hardware id is in the INF file!

 

Hmm, that's odd. I don't know what the problem would be if all of those things are correct. Disabling DSE should not be required with W7. I don't have any suggestion at this point since your hardware ID is in the INF. The @J95 mod should work fine. Maybe there is something wrong with your GPU.

Share this post


Link to post
Share on other sites

Wanted to move to a stable driver newer one, from 369.05 I moved to 373.06 and I get Black screen boot and then machine reboots all over and then it boots successfully says PC ran into a prob checking the dmp file shows the nvlddmkm.sys / ntsokrnl (wmiacpi - this one is new one i noticed after 4th time of failure never saw it again tho), which error happened . Anyone with AW17 R1 could replicate this ? Running SVL7 vBIOS.

 

 

Edit : Tried Prema v2 vBIOS, same issue, tried the driver 375.63 same issue with both vBIOSed. Tried disabling the Win8.1 fastboot no change, always happens when I shut the system down and start, with restart doesn't happen, A huge PITA T__T. Win8.1 something is happening with the new drivers...!!

error.PNG

 

Edit2 : Weirdly after disabling the hiberfile using powercfg.exe -h off it boots (the reboot causing the system to boot everytime after that shutdown is because of the messed up hiberfil, wow ngreedia & I disabled the fast boot in BIOS it doesnt but the admin cmd does disable the fast booting properly wtf ? ) Keeping that aside, So what's the issue with the Hiberfile.sys on these new drivers ? They don't allow what ? Dafuq Nvidia shenanigans did omg !! 

Trying the notebook drivers this time..

 

EDIT 3 - Posted at Nvidia forums.

Edited by Ashtrix
  • Thumbs Up 1

Share this post


Link to post
Share on other sites
Guest
8 hours ago, Ashtrix said:

Wanted to move to a stable driver newer one, from 369.05 I moved to 373.06 and I get Black screen boot and then machine reboots all over and then it boots successfully says PC ran into a prob checking the dmp file shows the nvlddmkm.sys / ntsokrnl (wmiacpi - this one is new one i noticed after 4th time of failure never saw it again tho), which error happened . Anyone with AW17 R1 could replicate this ? Running SVL7 vBIOS.

 

 

Edit : Tried Prema v2 vBIOS, same issue, tried the driver 375.63 same issue with both vBIOSed. Tried disabling the Win8.1 fastboot no change, always happens when I shut the system down and start, with restart doesn't happen, A huge PITA T__T. Win8.1 something is happening with the new drivers...!!

error.PNG

 

Edit2 : Weirdly after disabling the hiberfile using powercfg.exe -h off it boots (the reboot causing the system to boot everytime after that shutdown is because of the messed up hiberfil, wow ngreedia & I disabled the fast boot in BIOS it doesnt but the admin cmd does disable the fast booting properly wtf ? ) Keeping that aside, So what's the issue with the Hiberfile.sys on these new drivers ? They don't allow what ? Dafuq Nvidia shenanigans did omg !! 

Trying the notebook drivers this time..

 

EDIT 3 - Posted at Nvidia forums.

That's really nuts. Now that 1080 is on the loose those dirty rats must be treating 980M owners like the wicked stepchildren now, just as they did all of us 780M owners when 980M was released.

Share this post


Link to post
Share on other sites
5 hours ago, Mr. Fox said:

That's really nuts. Now that 1080 is on the loose those dirty rats must be treating 980M owners like the wicked stepchildren now, just as they did all of us 780M owners when 980M was released.

Yeah very bad, But seems like the Quadro is also affected lel. Nvidia really worst at delivering the drivers nowadays it's more of a 99% miss.

  • Thumbs Up 2

Share this post


Link to post
Share on other sites
Guest
9 hours ago, Ashtrix said:

Yeah very bad, But seems like the Quadro is also affected lel. Nvidia really worst at delivering the drivers nowadays it's more of a 99% miss.

They're too busy working on insanely important junk like NVIDIA Drive, Shield and GeForce Experience to be bothered by something as trivial as device drivers or post-sale product support.

Share this post


Link to post
Share on other sites
On 20/12/2016 at 6:20 AM, Ashtrix said:

Yeah very bad, But seems like the Quadro is also affected lel. Nvidia really worst at delivering the drivers nowadays it's more of a 99% miss.

 

I tested both GeForce 376.19 and 376.33 drivers in my M18X-R2 and I can say that  while 376.19 driver is working properly, the same not apply with the 376.33 driver because when you try to install it only updates the nvidia high def sound leaving the video driver untouched.  But at least the 376.19 is enough for now I guess. 

Share this post


Link to post
Share on other sites

@Tulius Hey buddy I haven't been following, Sorry if this is off base. If what you are running is in your sig. you should be ok. I had no issues myself.

 

Try Manually modding the driver I have had some really good luck here

 

9J2SBxU.png[
 

 

Edited by kkthebeast
  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Onehit
      I've been scouring the internet in search of anything regarding an updated bios for my Clevo P170SM. I have found many mentions of Prema Bios mods on various websites, but good luck trying to find actual download links. They all seem to vanish or have dead links. Wayback Machine doesn't help either and I was only able to find stock Clevo bios as early as 2015 via the WayBack Machine. If anybody has an updates Prema Bios or some other unlocked bios file for the P170SM, that would be fantastic! Otherwise, I might have to consider paying over $100 to Eurocom for their unlocked bios.
    • By Henrik9979
      Okay here is what's going. I have a alienware m18x r1 running an amd 8970m, I wanted to upgrade it to crossfire but I could see a 8970m was more expensive than a r9 m290x
      So I decided to buy a r9 m290x and see if I could make it work in my alienware and also run crossfire.
      Even though many shops refused to sell me one because the didn't think it would work in an alienware m18x r1 only in the r2.
       
      Here is the whole process.
       
      19/08/17 23:15
      No post bios showing when booting, so impossible to enter bios menu, but can boot into windows 10 with no problems.
       
      19/08/17 23:20
      Because I haven't deleted the old AMD 8970m the r9 m290x shows as a 8970m with no problems.
       
      19/08/17 23:34
      First performance test was a success. The r9 m290x changed p-state normally. The gpu fan start spinning normally. But because of no thermal paste, the test lasted 20 seconds because the temperature raised fast.
       
      20/08/17 00:00
      Created a backup of the vbios version
      015.032.000.004.044450
       
      20/08/17 00:10
      Flashed a new clevo vbios version 015.032.000.003.044465
      Caused the card to be corrupted and resulted the 8 beep code.
       
      20/08/17 00:35
      Finally managed to flash the back and return the graphics card to its original state.

      20/08/17 00:50
      Flashed a new dell vbios version 015.046.000.014.045579
      No change in behavior
       
      20/08/17 01:07
      After trying multiple vbios with no luck I finally found one.
      Dell vbios Version 015.041.000.000.044966
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      Note: This vbios reduce the cards performance from 900 mhz to 850 mhz
       
      20/08/17 01:21
      After more testing I found one that is working with no limits.
      Clevo vbios version
      015.036.000.005.044618
      Brings back the post bios screen and I can now enter the bios menu through the r9 m290x.
      This will be the vbios I will keep at the moment.

      20/08/17 01:56
      I completely uninstalled the previous driver and installed the newest driver. The graphics card is recognized as a 8970m but works normal.

      21/08/17 20:15
      I have inserted my old 8970m in the secondary slot and will start testing crossfire.
       
      21/08/17 21:45
      I have found out that the fan for the secondary fan did not spin. The is a cable that have felt out. I will fix it now.

      21/08/17 22:00
      In my try to test crossfire compatibility, I installed the newest AMD driver 17.7.2 but as soon it installed the driver for the secondary card it caused black screen. Only booting the computer in safe mode brings the screen back.

      21/08/17 23:02
      After many frustrating hours I finally managed to get crossfire working with the r9 m290x as the primary card and my old 8970m as the secondary.
      I have flashed the same vbios on both cards so the r9 m290x shows up I device manager as a 8970m.
       
      I first installed AMD driver version 16.2.1
       
      Then installed AMD driver version 16.6.1 in order to play battlefield

      21/08/17 23:20
      First test run in battlefield 1

      21/08/17 23:40
      Battlefield 1 is flickering bad, this can maybe be solved with a new patch or driver.
      Other games I have tried is working perfect with crossfire on.


      Now what I would like to try is somehow force the r9 m290x driver to be installed and see if it will make it possible to run the latest AMD driver without getting a blackscreen.
       
      I have tried to edit the .inf file like you would do with nvidia but no luck.
      I have also tried to figure out how to edit the device id in the vbios, but I find it too complex.
    • By rsk
      Hello everyone just a little question. 
       
      i've just flash my p751dm2-g with the backed's bios and i gonna overclock it of course but i don't know how to clear cmos on this laptop.
      i have find nothing about it in the manual so i ask here. 
       
      Thanks 
    • By rsk
      Hello everyone I'm new on this forum and i'm new with clevo laptop. 
      I've recently buy a second hand laptop a clevo p751dm2-g with a i7 6700k and a 1070 mxm and unfortunatly the bios is locked i can't overclock my cpu or my ram. :sadge: 
      So i wanted to know if you guys on this forum have alternative solution to oc your cpu and your ram with a locked bios. 
      Thanks 
    • By Klem
      Klem's_vbios_MSI_GTX880M_80.04.EA.00.03_UNLOCKED.rar
      For both, 4Gb and 8Gb card.
      1. Unlocked Nvidia core limit +135 MHz.
      2. Unlocked Power Limit.
      3. Unlocked Power adjustment by software (for example with Nvidia Inspector).
      4. Increased Power Limit and Power Target.
      5. Enabled some additional tweaks.
       
      If you liked my mod, you can buy me some beer:   https://www.buymeacoffee.com/ekushukovZ
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.