Jump to content
EwinRacing Flash Series Gaming Chairs
J95

[Alienware - Clevo - MSI] Aftermarket Upgrades Driver Support - Modded INF

Recommended Posts

I installed 347.90 on a M18x R2 with a single GTX 980M. Yet I can't find the DSR option in the Nvidia Control Panel. Anybody know why?

DSR is not enabled for mobile maxwell GPUs

Share this post


Link to post
Share on other sites
Note:

PEG All models & Optimus/M17xR4 install using nv_whql.inf_v347.90_Desktop_GTX_TITAN X_980_970_Mobile_980M_970M_965M.zip

Alienware 17 / 05AA Optimus install nv_whql.inf_v347.90_Optimus_GTX_980M_970M_965M.zip

http://forum.techinferno.com/nvidia/9434-geforce-347-90-mod-desktop-mobile-900-series.html#post127799

All imma say is THANK YOU FOR POSTING THIS! >_<

Spent all morning taking apart my own m18x to install a pair of GTX 980M's and this has got the full system up and running again.

Ran the Heavensward FFXIV benchmark on it too. Old score i got was 5235 with the old 675m's. New score I got was 12903 O.O

Not seeing any throttling on it either tho Ive yet to test a game on it.

Want to install the new 350.12 drivers but cant find a full package that'll install. Geforce experience shows up to date on the driver :S

Trying to download the modified inf's but cant atm :C

Share this post


Link to post
Share on other sites

Seems like Geforce 352.86 WHQL drivers are out today in anticipation of The Witcher 3.

Share this post


Link to post
Share on other sites

@J95, can you mod the inf for the new driver? I'm getting driver upgrade itch now.. Haven't upgraded for ages now :)

Share this post


Link to post
Share on other sites

J95 please work on 352.86 ASAP! Super hyped for the Witcher 3 which is unlocking tonight, but I don't think experience will be optimal without game ready drivers

Share this post


Link to post
Share on other sites

Hello,

I've been following this thread and I am confused about what the latest working drivers to install. I have a single 970m on Alienware M18xR2.

Thank you

Share this post


Link to post
Share on other sites
Hello,

I've been following this thread and I am confused about what the latest working drivers to install. I have a single 970m on Alienware M18xR2.

Thank you

Latest release drivers only came out this morning 352.86. You can download the latest package but until J95 is nice enough to get round to putting up a modified inf file for us the latest ones you can actually use would be the 350.12 drivers. Would do it myself if I could wrap my head around the modification process but not that great at it personally.

Share this post


Link to post
Share on other sites

Thank you for your reply. My brain is overheating after reading all pages of this thread and I just need a working driver, which to install and what file to use to overwrite and do i need to flash ? for the 970m on A 18xR2 :)

Share this post


Link to post
Share on other sites
Thank you for your reply. My brain is overheating after reading all pages of this thread and I just need a working driver, which to install and what file to use to overwrite and do i need to flash ? for the 970m on A 18xR2 :)

First post of this thread covers the install process. Link to the most recent AW INF is usually posted in J95's signature. This is currently v350.12.

Although with the universe hopefully on our lazyside, @J95 is already working on 352.86. (Insert insurmountable gratitude for J95 here)

You'll need 5 hopefully decent posts before you can DL anything from TechInferno.

Information on flashing vbios can be found in the General Notebook Discussion.

Share this post


Link to post
Share on other sites

GeForce 352.86 WHQL


    Game Ready
  • Best gaming experience for The Witcher 3: Wild Hunt, including support for SLI Technology
    INF MOD v352.86
    nv_dispi.inf: PEG/Dedicated All Models (including Optimus/M17xR4) except 2015 - GTX 980M , 970M , 965M , 880M , 870M , 860M , 780M , 770M , 765M , 680M , 675MX , 670MX
    nvcvi.inf: Optimus Alienware 17 / 05AA (only) GTX 980M - 970M - 965M
    GeForce 350.12 WHQL

- - - Updated - - -

@ALL v352.86 >TDRs< stock clocks all games & benchmarks, desktop identical issues...another hotfix soon. DDU in safe mode, reinstall v350.12. Don't update GeForce Experience to v2.4.4.24 >TDRs<, _v2.4.3.22 uncheck "beta" option.

Single & SLI, I've included v352.86 game profiles "Witcher 3: Wild Hunt" M18xR2/SLI users feedback please.

nv_dispi.inf_v352.86_AW_PEG_GTX_980M_970M_880M_870M_860M_780M_770M_765M_680M_675MX_670MX.zip

nvcvi.inf_v352.86_Optimus_Alienware_17_GTX_980M_970M_965M.zip

  • Thumbs Up 3

Share this post


Link to post
Share on other sites

Hey this might be a bit of a long shot but do you have any idea why I might get display glitches/crashes when I install modded drivers with these in UEFI Windows 8.1 with a 980m and 120Hz monitor? It worked for a day but then it started crashing and it's been broken ever since

Share this post


Link to post
Share on other sites

I've been reading this thread backwards and forwards but cant figure out to get to this 352.86-driver working on my M18X-R2 with Win8.1 and a 980M-card. Been trying to modify .inf files but I'm not even sure I'm modifying the correct file. Would anyone inform me which file is the correct one as I've been getting mixed messeges here.

My HW-ID is: PCI\VEN_10DE&DEV_13D7&SUBSYS_05501028

Share this post


Link to post
Share on other sites
Hey this might be a bit of a long shot but do you have any idea why I might get display glitches/crashes when I install modded drivers with these in UEFI Windows 8.1 with a 980m and 120Hz monitor? It worked for a day but then it started crashing and it's been broken ever since

@ALL v352.86 >TDRs< stock clocks all games & benchmarks, desktop identical issues...another hotfix soon. DDU in safe mode, reinstall v350.12. Don't update GeForce Experience to v2.4.4.24 >TDRs<, _v2.4.3.22 uncheck "beta" option.

Single & SLI, I've included v352.86 game profiles "Witcher 3: Wild Hunt" M18xR2/SLI users feedback please.

nvdrsdb_v352.86.zip

Share this post


Link to post
Share on other sites
@ALL v352.86 >TDRs< stock clocks all games & benchmarks, desktop identical issues...another hotfix soon. DDU in safe mode, reinstall v350.12. Don't update GeForce Experience to v2.4.4.24 >TDRs<, _v2.4.3.22 uncheck "beta" option.

Single & SLI, I've included v352.86 game profiles "Witcher 3: Wild Hunt" M18xR2/SLI users feedback please.

Hey alright, I've tried reinstalling a couple times and uninstalling with DDU, I'll give it another try I guess in safe mode

Share this post


Link to post
Share on other sites
Hey alright, I've tried reinstalling a couple times and uninstalling with DDU, I'll give it another try I guess in safe mode

Run DDU and then reinstall v350.12.

Single & SLI, I've included v352.86 game profiles "Witcher 3: Wild Hunt" M18xR2/SLI users feedback please.

Share this post


Link to post
Share on other sites
Run DDU and then reinstall v350.12.

Yep that seems to have fixed it for now, thanks for the help and the mods :)

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

J95, I'm in the same boat as the Mr. Fox, as I have dual 780M and all drivers beyond 345.20 are throttling

even when the gpus aren't overclocked. Is there a way to adapt the 352.86 SLI profiles in the 345.20 drivers? Thanks in advance.

Share this post


Link to post
Share on other sites

Well I have no idea what happened but now no matter what I can't install drivers on my 120Hz pure UEFI 980m Alienware 17 R5. I've tried full uninstalls using DDU in safe mode, various versions of the drivers and .inf mods from here as well as laptopvideo2go. No matter what I try I get bizarre glitches with the display and my computer will immediately crash if I load a 3D game. It has to be driver-related as my computer is running perfectly when I have no NVIDIA drivers installed. Any ideas?

Share this post


Link to post
Share on other sites
J95, I'm in the same boat as the Mr. Fox, as I have dual 780M and all drivers beyond 345.20 are throttling

even when the gpus aren't overclocked. Is there a way to adapt the 352.86 SLI profiles in the 345.20 drivers? Thanks in advance.

Hi there.

Enter safe mode -> "C:\ProgramData\NVIDIA Corporation\Drs" -> copy/overwrite "nvdrsdb0.bin" & "nvdrsdb1.bin" -> reboot.

NVCPL -> Manage 3D Settings -> Global Settings -> Power management -> set balanced mode -> Apply -> set high performance -> Apply.

Set SLI settings.

Well I have no idea what happened but now no matter what I can't install drivers on my 120Hz pure UEFI 980m Alienware 17 R5. I've tried full uninstalls using DDU in safe mode, various versions of the drivers and .inf mods from here as well as laptopvideo2go. No matter what I try I get bizarre glitches with the display and my computer will immediately crash if I load a 3D game. It has to be driver-related as my computer is running perfectly when I have no NVIDIA drivers installed. Any ideas?

1- Uninstall current drivers DDU/ "Clean and Shutdown" option.

2- Flash -> Prema's latest vBIOS MOD v1.1 -> NVFLASH_WIN_5.218_x64 (password premamod.com)

3- *Driver signing disabled* -> GeForce 350.12 WHQL -> Display.Driver folder -> copy/overwrite nv_dispi.inf_v350.12.zip

4- Extracted driver package, keep these folders only -> run setup.exe

post-3012-14495000108611_thumb.png

5- (Optional) Install Geforce Experience standalone installer v2.4.3.31 Download GeForce Experience | NVIDIA | GeForce

Preferences

post-3012-14495000108838_thumb.png

6- *Disable/uncheck batteryboost*

post-3012-14495000109329_thumb.png

7- *Stock clocks* "P-states matching" -> Nvidia Inspector -> Performance Level [2] (P1) -> "Unlock Max" -> set core 1127 MHz -> vram 2505 MHz -> apply -> right click "create clock shortcut" -> "Create clock startup task" -> Done.

post-3012-14495000109731_thumb.png

- - - Updated - - -

@N!IGHTHAWK! just follow the steps above 1, 3, 4, *7*.

nvdrsdb0.bin_nvdrsdb1.bin.zip

  • Thumbs Up 2

Share this post


Link to post
Share on other sites

@J95

Here are the results!

?temp_hash=795b58b8b3a2619fe626cb98463a2fda

Thank you so much! Throttling is gone for now. I really don't understand this stuff. When I started out a couple of days ago. I didn't have these issues. The more I played with it the worst it got. I don't mind playing around with setting and trying things but it really is weird when you can't get back to a good baseline.

I'll be donating you some cash today or tomorrow! Big thanks! Do you have any tips for pushing it more? Or should I be happy with that? Plus I'm still waiting on my second heatsink for the other beast and I hope I don't mess anything up on that one hahaha

Things of note running it without the OC still had throttling. First pass was good at 7420. Second pass 1290. OC first pass was 8504 second was 8550 so I am hopeful things are good to go. I'll be calling it a day in a few so I'll update if I get any major issues. Also before I noticed that when I had my ext monitor pluged in I got a much worse throttling issue.

Thanks Again

  • Thumbs Up 1

Share this post


Link to post
Share on other sites

Noticed since i installed the new drivers that when i initially start my system the computer is doing slow stuttering like freezing for a 1-2 seconds every couple of seconds in part because the computer is almost jumping strait from the bios to the login screen nearly strait away.. Restarting the computer seems to sort it out tho. Havent uninstalled for now but it is a little bit of an oddity.

Share this post


Link to post
Share on other sites
Guest
Hi there.

Enter safe mode -> "C:\ProgramData\NVIDIA Corporation\Drs" -> copy/overwrite "nvdrsdb0.bin" & "nvdrsdb1.bin" -> reboot.

NVCPL -> Manage 3D Settings -> Global Settings -> Power management -> set balanced mode -> Apply -> set high performance -> Apply.

Set SLI settings.

- - - Updated - - -

@N!IGHTHAWK! just follow the steps above 1, 3, 4, *7*.

This will work for 350.12, but will not work for me with 345.20 drivers. Since I cannot use 350.12 I had to find a different workaround. With 345.20, I can overwrite the profile .BIN files in Safe Mode, but apparently the Windows Repository replaces them when I reboot, because the old versions keep coming back upon reboot. If I delete them from the repository, then there are no profiles accessible in NVCP. The only way I could do it without the PeeForce Cancer Experience is to install 352.86 over the top of 345.20 (no DDU cleaning), reboot with DSE disabled and then go into Device Manager and manually select 345.20. Since the only game I have that is not covered in the new game profiles is Wolfenstein: The Old Blood, it doesn't really make any difference for me one way or the other. I am not planning to purchase GTA V or The Witcher 3 until they can be purchased for $20 or less. I am not a huge fan of either genre... much prefer FPS. What did work was exporting 352.86 profiles for those games as NVIDIA Inspector .NIP files and importing them into a clean 345.20 installation. So, that might be an option that will work for some folks.

352.86 NV Inspector Profiles.zip

post-119-14495000110988_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By -GP
      I got a msi ge60 2pf Apache pro & its specs :
       
      Processor-i7 4710MQ
      Ram-16GB 
      VGA- GTX 860M 2GB Maxwell 
       
      Could anyone tell me the best overclock that I could use on this GPU?
      Please keep in mind that the voltage cannot be changed as this is a laptop
       
      Thank you
    • By OnaStack100
      I have a p150sm which has a seemingly dead 780m due to a perpetual error 43 which came after a big BSOD about 6 months ago. I upgraded the laptop to a 980m and modded the inf files. The upgrade was perfectly fine for a week. One day, i left the laptop and something related to sleep or power may have caused the laptop to shut off. Since then, the laptop with the 980m won't boot. I tried many things like resetting cmos, taking out the hardware and putting it back in, and resetting bios, and buying a 230W adapter. Nothing worked. The laptop works fine with the old dead 780m in there, but now when the 980m is in there, holding the power button generates a green light flash and then the power LED goes back to orange. No sounds, maybe one tick, and that's it. What is left to try?
    • By DragonRai
      After the most recent Windows 10 update, my Clevo Control Centre has stopped working properly. When I try to change the fan speed nothing happens and this is causing my laptop to overheat when playing certain games. This has happened before but using malware bytes seemed to work; that was a free trial so I no longer have access to this. 
      Please can someone help? I'm at my wits end with this.
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.