Jump to content

Attempted overclock caused drivers to crash, forced restart, can no longer boot with eGPU


Recommended Posts

So I screwed up today, and tried overclocking my HD 7850 with sapphire trixx, which immediately caused the drivers to hang, and I got a black screen where my cursor could still move. Nothing would respond, so I had to force shut down, and now my laptop will get stuck on a black screen when trying to boot with the PSU powered on, meaning it won't even get to the BIOS. I've already tried a system restore and uninstalling Trixx, which did nothing. The fans still spin, so I don't think it's fried. I'm running the gpu through the PE4C 3.0 into the laptop's mini PCI port.


I have a feeling the bad settings are stuck on the card, and since I can no longer access the card through Windows, I don't have any way to reset it. I run an Optimus laptop setup, so the only way the card can be detected is at powering on.


I'm about to try and uninstall the AMD drivers, but I'm doubtful it will do anything. Does anyone know what I could do? Or am I SOL?

Edited by StormHertz
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.